LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 04-13-2013, 11:35 AM   #1
TheStarLion
Member
 
Registered: Nov 2009
Location: UK
Distribution: Gentoo
Posts: 472

Rep: Reputation: 41
Java not respecting ALSA or Phonon audio settings


Bit of a problem. On a KDE4 session running on Debian Wheezy, I've managed to get almost everything routing audio to the USB headset I'm using thanks to gstreamer-properties and Phonon itself handing it.

However, Java is ignoring both of them.
gstreamer-properties is directing all ALSA traffic to the headset using ALSA, and phonon (using the phonon-gstreamer backend) is doing the same.

Without using Pulseaudio, which I don't want to have to resort, I can't seem to find any way to tell Java where it's supposed to send its audio.

This appears to be affecting Flash also, and happens the same regardless of whether either are being run in a browser or standalone.

Last edited by TheStarLion; 04-13-2013 at 12:10 PM.
 
Old 04-14-2013, 04:54 AM   #2
gradinaruvasile
Member
 
Registered: Apr 2010
Location: Cluj, Romania
Distribution: Debian Testing
Posts: 511

Rep: Reputation: 102Reputation: 102
You need to route EVERYTHHING through one method.
Best is to route ALSA through PulseAudio (this works well). Dont forget the alsa-oss package for non-ALSA applications (such as Java).
Then i suppose Gstreamer and Phonom can use PulseAudio as backend.
 
Old 04-14-2013, 07:29 AM   #3
TheStarLion
Member
 
Registered: Nov 2009
Location: UK
Distribution: Gentoo
Posts: 472

Original Poster
Rep: Reputation: 41
I didn't really want to resort to PulseAudio, but I've just done that along with the alsa-oss package. In-browser stuff now all uses the USB headset fine, but Java is still ignoring everything and outputting directly to the speakers instead.
Phonon is still directing to gstreamer, which is in turn now set to use Pulseaudio and the USB headset device, and everything else is doing just that - except for Java.

Edit: I figured it out thanks to the Archlinux Wiki right here: https://wiki.archlinux.org/index.php...ith_Pulseaudio

Last edited by TheStarLion; 04-14-2013 at 08:27 AM.
 
Old 04-17-2013, 10:42 PM   #4
jACK-ah
LQ Newbie
 
Registered: Feb 2013
Posts: 27

Rep: Reputation: Disabled
JAVA not gona support both of them
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
HD-Audio: ALSA settings not persistent across reboots. stf92 Slackware 18 01-09-2013 03:32 AM
[SOLVED] ALSA, Phonon, Debian Squeeze. sevs Linux - Software 2 02-15-2011 09:24 AM
[SOLVED] Kde 4.4.5: Use custom Alsa device in Phonon Vookimedlo Linux - Software 6 01-30-2011 04:39 PM
Trying to customize my audio/Alsa settings. Galaxy_Stranger Linux - Software 0 05-07-2009 10:43 PM
GTK Applications Not Respecting Subpixel Settings tvynr Linux - Desktop 1 09-06-2006 06:42 PM


All times are GMT -5. The time now is 11:07 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration