LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Desktop (http://www.linuxquestions.org/questions/linux-desktop-74/)
-   -   I've finally admitted defeat; ATI 7950, X11, fglrx: No matching Device (http://www.linuxquestions.org/questions/linux-desktop-74/ive-finally-admitted-defeat%3B-ati-7950-x11-fglrx-no-matching-device-4175458926/)

pwn 04-20-2013 02:56 PM

I've finally admitted defeat; ATI 7950, X11, fglrx: No matching Device
 
Hi everyone,

I was hoping I could get some advice or help on an issue thats been plaguing me. I've tried this in CentOS 6, Ubuntu 12.10 and XUbuntu 12.10.

Its pretty basic, I've generated the deb packages with the AMD script and installed the drivers. I'm trying to get X11 to work now. After the drivers are installed, things look good.

Code:

sudo aticonfig --lsa
* 0. 01:00.0 AMD Radeon HD 7900 Series

* - Default adapter

Ok, great. I run the ATI script to generate the xorg configuration. Here is that file post script:

Code:

Section "ServerLayout"
        Identifier    "aticonfig Layout"
        Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
EndSection

Section "Monitor"
        Identifier  "aticonfig-Monitor[0]-0"
        Option            "VendorName" "ATI Proprietary Driver"
        Option            "ModelName" "Generic Autodetecting Monitor"
        Option            "DPMS" "true"
EndSection

Section "Device"
        Identifier  "aticonfig-Device[0]-0"
        Driver      "fglrx"
        BusID      "PCI:1:0:0"
EndSection

Section "Screen"
        Identifier "aticonfig-Screen[0]-0"
        Device    "aticonfig-Device[0]-0"
        Monitor    "aticonfig-Monitor[0]-0"
        DefaultDepth    24
        SubSection "Display"
                Viewport  0 0
                Depth    24
        EndSubSection
EndSection

I reboot the machine, and I get this when I try to check card status / startx:

Code:

root@morgan-MS-7788:~# aticonfig --adapter=all --odgt
ERROR - X needs to be running to perform AMD Overdrive(TM) commands
root@morgan-MS-7788:~# startx


X.Org X Server 1.13.0
Release Date: 2012-09-05
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.2.0-30-generic x86_64 Ubuntu
Current Operating System: Linux morgan-MS-7788 3.5.0-17-generic #28-Ubuntu SMP Tue Oct 9 19:31:23 UTC 2012 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.5.0-17-generic root=UUID=aeaad78b-ebcc-4e78-8586-3541e36691b8 ro quiet splash vt.handoff=7
Build Date: 08 October 2012  03:34:01PM
xorg-server 2:1.13.0-0ubuntu6 (For technical support please see http://www.ubuntu.com/support)
Current version of pixman: 0.26.0
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.1.log", Time: Sat Apr 20 12:45:47 2013
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
Initializing built-in extension Generic Event Extension
Initializing built-in extension SHAPE
Initializing built-in extension MIT-SHM
Initializing built-in extension XInputExtension
Initializing built-in extension XTEST
Initializing built-in extension BIG-REQUESTS
Initializing built-in extension SYNC
Initializing built-in extension XKEYBOARD
Initializing built-in extension XC-MISC
Initializing built-in extension SECURITY
Initializing built-in extension XINERAMA
Initializing built-in extension XFIXES
Initializing built-in extension RENDER
Initializing built-in extension RANDR
Initializing built-in extension COMPOSITE
Initializing built-in extension DAMAGE
Initializing built-in extension MIT-SCREEN-SAVER
Initializing built-in extension DOUBLE-BUFFER
Initializing built-in extension RECORD
Initializing built-in extension DPMS
Initializing built-in extension X-Resource
Initializing built-in extension XVideo
Initializing built-in extension XVideo-MotionCompensation
Initializing built-in extension XFree86-VidModeExtension
Initializing built-in extension XFree86-DGA
Initializing built-in extension XFree86-DRI
Initializing built-in extension DRI2
Loading extension GLX
(WW) fglrx: No matching Device section for instance (BusID PCI:0@1:0:1) found
Loading extension ATIFGLRXDRI
Loading extension FGLRXEXTENSION
Loading extension GLESX
Loading extension AMDXVOPL
Loading extension AMDXVBA
^Cxinit: connection to X server lost

waiting for X server to shut down Server terminated successfully (0). Closing log file.

I've gotten the same error code on all three distros, so there has to be something I'm doing wrong. Its strange it complains about the 1:0:1 device, which is the HDMI audio interface. Here is lspci:

Code:

01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Tahiti PRO [Radeon HD 7950]
01:00.1 Audio device: Advanced Micro Devices [AMD] nee ATI Tahiti XT HDMI Audio [Radeon HD 7970 Series]

I'm unsure what to try at this point. Does anybody have some great tips? I'm really not very experience with graphical work under unix. I will forever be in your debt.

Thanks,
Morgan

yowi 04-20-2013 03:11 PM

That's not an error, it's a warning (WW).

What happens if you let it continue?

pwn 04-20-2013 09:14 PM

Nothing happens, I can let it sit there and it will hang all day.

I see the process running.

Code:

/usr/bin/X :0 -core -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch -background none
I'm a complete idiot when it comes to graphical stuff under linux/unix, I don't typically use it ever. However, some software I need to run that makes use of GPU parallel processing needs to be able to read GPU metrics, which can't happen if the ATI tool can't even read them.

I've read that in order to do this I need to disable the access control for x server by running xhost +, but I get:

Code:

root@morgan-MS-7788:~# xhost +
No protocol specified
xhost:  unable to open display ":0"

Log has the following.. http://pastebin.com/mVFQh9c8

Thanks,
Morgan

pwn 04-20-2013 09:24 PM

I removed lightdm and installed kdm but doesn't seem to have changed anything, except the x process now runs as:

/usr/bin/X :0 vt7 -br -nolisten tcp -auth /var/run/xauth/A:0-Lp3D2a

Drakeo 04-20-2013 10:51 PM

if you in fact have that device and you must use a rpm or deb system make sure when using proprietary drivers that purge the system of the generic drivers and black list them.
in ubuntu please follow the documentation. install ati ubuntu
have fun


All times are GMT -5. The time now is 09:25 PM.