LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 09-20-2012, 09:38 AM   #1
ylang
Member
 
Registered: Sep 2012
Posts: 45

Rep: Reputation: Disabled
Is there any way to make kde faster on older PCs


I really like KDE but it is really slow on my old PC. Is there any way to make it fast?
 
Old 09-20-2012, 10:26 AM   #2
snowpine
Senior Member
 
Registered: Feb 2009
Posts: 3,915

Rep: Reputation: 1047Reputation: 1047Reputation: 1047Reputation: 1047Reputation: 1047Reputation: 1047Reputation: 1047Reputation: 1047
What are your hardware specs? Which KDE distro are you running on it?
 
Old 09-20-2012, 10:58 AM   #3
ylang
Member
 
Registered: Sep 2012
Posts: 45

Original Poster
Rep: Reputation: Disabled
I am running mepis on amacbook with core 2 duo and 1gb ram. Intel integrated graphics. Quite slow and eats battery life.
 
Old 09-20-2012, 11:03 AM   #4
snowpine
Senior Member
 
Registered: Feb 2009
Posts: 3,915

Rep: Reputation: 1047Reputation: 1047Reputation: 1047Reputation: 1047Reputation: 1047Reputation: 1047Reputation: 1047Reputation: 1047
I am no expert on Apple hardware, sorry. Maybe try a lightweight DE like Xfce or Fluxbox?
 
Old 09-20-2012, 11:26 AM   #5
szboardstretcher
Senior Member
 
Registered: Aug 2006
Location: Detroit, MI
Distribution: GNU/Linux systemd
Posts: 3,187
Blog Entries: 1

Rep: Reputation: 1014Reputation: 1014Reputation: 1014Reputation: 1014Reputation: 1014Reputation: 1014Reputation: 1014Reputation: 1014
I would say no. KDE is a power hungry, eyecandy based DE and a Mac is only suitable for, well, I cant think of anything its suitable for

I have an old laptop that fits that spec, and to speed it up I went with Arch + Openbox. Its pretty zippy now.
 
Old 09-20-2012, 11:33 AM   #6
craigevil
Senior Member
 
Registered: Apr 2005
Location: OZ
Distribution: Debian Sid
Posts: 4,733
Blog Entries: 12

Rep: Reputation: 456Reputation: 456Reputation: 456Reputation: 456Reputation: 456
Disable desktop effects, and nepomuk and akonadi. Also disable any unneeded services.

it flies on this ancient Thinkpad R40.
Code:
System:    Host: debian Kernel: 3.5-trunk-486 i686 (32 bit) Desktop: KDE 4.8.4 Distro: Debian GNU/Linux wheezy/sid
Machine:   Mobo: IBM model: 27223YU Bios: IBM version: 1PET41WW (1.09 ) date: 03/03/2003
CPU:       Single core Intel Pentium M (-UP-) cache: 1024 KB clocked at 1300.00 MHz 
           CPU Flags: fpu vme de pse tsc msr mce cx8 sep mtrr pge mca cmov clflush dts acpi mmx fxsr sse 
           sse2 tm pbe bts est tm2 
Graphics:  Card: Advanced Micro Devices [AMD] nee ATI RV200 [Mobility Radeon 7500] 
           X.Org: 1.12.3.902 drivers: ati,radeon (unloaded: fbdev,vesa) Resolution: 1024x768@60.0hz 
           GLX Renderer: Gallium 0.4 on llvmpipe (LLVM 0x209) GLX Version: 2.1 Mesa 8.0.4
Audio:     Card: Intel 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller driver: snd_intel8x0
           Sound: Advanced Linux Sound Architecture ver: 1.0.25
Network:   Card-1: Intel 82801DB PRO/100 VE (MOB) Ethernet Controller driver: e100 
           IF: eth0 state: down mac: 00:06:1b:cd:f5:82
           Card-2: Intel PRO/Wireless LAN 2100 3B Mini PCI Adapter driver: ipw2100 
           IF: eth1 state: up mac: 00:04:23:5b:b5:88
Drives:    HDD Total Size: 17.2GB (57.3% used) 1: id: /dev/sda model: IC25N020ATCS04 size: 17.2GB 
Partition: ID: / size: 16G used: 9.2G (64%) fs: ext3 ID: /boot size: 228M used: 39M (18%) fs: ext2 
           ID: swap-1 size: 0.51GB used: 0.00GB (0%) fs: swap 
Sensors:   System Temperatures: cpu: 45.0C mobo: 44.0C 
           Fan Speeds (in rpm): cpu: N/A fan-1: 0 
Info:      Processes: 97 Uptime: 5:05 Memory: 364.4/2025.7MB Client: Shell inxi: 1.8.17
 
1 members found this post helpful.
Old 09-20-2012, 12:57 PM   #7
nileshgr
Member
 
Registered: Aug 2007
Location: Pune, Maharashtra, India
Distribution: Gentoo
Posts: 84

Rep: Reputation: 16
People hate Gentoo users for always talking about compiler optimizations, but I have to say this here: compile it with -O3 -march=native -mtune=native.
I have almost the same configuration as your's- dual core 2 ghz, initially 1 gb ram; but now 3 gb (got it for virtualization). There only two significant differences here: I use pf-kernel, and as much as possible, everything is compiled with those C{,XX}FLAGS (managed by portage).
 
Old 09-20-2012, 02:56 PM   #8
jefro
Guru
 
Registered: Mar 2008
Posts: 11,590

Rep: Reputation: 1419Reputation: 1419Reputation: 1419Reputation: 1419Reputation: 1419Reputation: 1419Reputation: 1419Reputation: 1419Reputation: 1419Reputation: 1419
I have run Knoppix for a while and some of the very first versions were kde I think. It ran pretty good so I'd think maybe an older version of kde.
 
Old 09-21-2012, 02:59 AM   #9
ylang
Member
 
Registered: Sep 2012
Posts: 45

Original Poster
Rep: Reputation: Disabled
I think I will try to use archbang.... Seems pretty light.
 
Old 09-23-2012, 07:16 AM   #10
David the H.
Bash Guru
 
Registered: Jun 2004
Location: Osaka, Japan
Distribution: Debian sid + kde 3.5 & 4.4
Posts: 6,823

Rep: Reputation: 1948Reputation: 1948Reputation: 1948Reputation: 1948Reputation: 1948Reputation: 1948Reputation: 1948Reputation: 1948Reputation: 1948Reputation: 1948Reputation: 1948
I've found that one thing that makes a big difference is compositing. kde without direct graphics support is dog-slow, even with most of the effects disabled. It performs much better when the gpu can take over the rendering work.

If you don't already have compositing enabled, look into whether your card and driver support it.
 
Old 09-23-2012, 07:28 AM   #11
craigevil
Senior Member
 
Registered: Apr 2005
Location: OZ
Distribution: Debian Sid
Posts: 4,733
Blog Entries: 12

Rep: Reputation: 456Reputation: 456Reputation: 456Reputation: 456Reputation: 456
Quote:
Originally Posted by David the H. View Post
I've found that one thing that makes a big difference is compositing. kde without direct graphics support is dog-slow, even with most of the effects disabled. It performs much better when the gpu can take over the rendering work.

If you don't already have compositing enabled, look into whether your card and driver support it.
I have composting disabled and it runs just fine. never noticed any slowness. But I have desktop effects disabled.
 
Old 09-23-2012, 07:47 AM   #12
Xeratul
Senior Member
 
Registered: Jun 2006
Location: Debian Land
Posts: 1,339

Rep: Reputation: 83
Quote:
Originally Posted by ylang View Post
I really like KDE but it is really slow on my old PC. Is there any way to make it fast?
you should do :

apt-get install -f -y openbox kicker kate ... <--- what u need


you should use openbox as wm with kde apps.

Believe me : nothing faster than openbox !!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Make KDE Look Older Zssfssz Ubuntu 2 01-08-2012 11:17 PM
Older pcs -- down for the count? bwgolling Linux - Hardware 17 09-25-2011 08:08 AM
[SOLVED] Any tricks to make kde 4.3 faster TheIndependentAquarius Linux - Desktop 50 04-22-2010 11:31 PM
Best use for several older PCs? robogymnast Linux - General 8 08-14-2008 07:23 AM


All times are GMT -5. The time now is 07:34 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration