LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
LinkBack Search this Thread
Old 10-03-2006, 05:12 PM   #1
rudane
LQ Newbie
 
Registered: Nov 2005
Posts: 1

Rep: Reputation: 0
Invalid ELF Header Error when Compiling - Dell Inspiron 600m


Hi;

I'm running Fedora Core 5 on a Dell Inspiron 600m, 1.4 GHz Centrino, 512 MB RAM. Recently when I compile from source, I always seem to be getting errors like this one:

[mike@localhost ksmoothdock]$ make
cd . && make -f admin/Makefile.common configure.in ;
make[1]: Entering directory `/home/mike/Documents/ksmoothdock'
make[1]: Leaving directory `/home/mike/Documents/ksmoothdock'
cd . && /bin/sh /home/mike/Documents/ksmoothdock/admin/missing --run
aclocal-1.7
/usr/bin/perl: error while loading shared libraries: /usr/lib/perl5/5.8.8/i386-linux-thread-multi/CORE/libperl.so: invalid ELF header
WARNING: `aclocal-1.7' is missing on your system. You should only need it if
you modified `acinclude.m4' or `configure.in'. You might want
to install the `Automake' and `Perl' packages. Grab them from
any GNU archive site.
cd . && \
/bin/sh /home/mike/Documents/ksmoothdock/admin/missing --run automake-1.7 --gnu Makefile
/usr/bin/perl: error while loading shared libraries: /usr/lib/perl5/5.8.8/i386-linux-thread-multi/CORE/libperl.so: invalid ELF header
WARNING: `automake-1.7' is missing on your system. You should only need it if
you modified `Makefile.am', `acinclude.m4' or `configure.in'.
You might want to install the `Automake' and `Perl' packages.
Grab them from any GNU archive site.
cd . && perl admin/am_edit Makefile.in
perl: error while loading shared libraries: /usr/lib/perl5/5.8.8/i386-linux-thread-multi/CORE/libperl.so: invalid ELF header
make: *** [Makefile.in] Error 127
[mike@localhost ksmoothdock]$

I searched the net, and I also checked to see if I had perl installed, and I do have it installed. I'm not sure how to fix this problem. I tried using YUM to maybe uninstall perl and reinstall, but when I did the transaction test, YUM wanted to remove just about all the packages on my computer because of perl dependencies. I appreciate any help.

Thanks,
Mike
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wine: Invalid ELF Header stevesk Linux - Software 1 07-17-2006 09:50 PM
dell inspiron 600m keyboard failure redjokerx General 0 01-02-2005 02:36 AM
Dell Inspiron 600m Wireless CBurt Linux - Laptop and Netbook 3 09-30-2004 07:32 PM
Invalid ELF header when using Automake/Autoconf Zotty Programming 1 09-17-2004 01:23 PM
libpcre invalid ELF header error. geoffd4 Linux - Software 0 05-10-2004 09:30 PM


All times are GMT -5. The time now is 07:13 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration