LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 10-14-2010, 03:21 AM   #1
aluvalassuman185
LQ Newbie
 
Registered: Oct 2010
Posts: 5

Rep: Reputation: 0
Internet is not working on VMPlayer for Ubuntu10.04 but working for Fedora12


Hi Guys,

I got VM Images from the below sites
Ubuntu 10.04 from the VMPlanet and Fedora from the thoughtpolice.

I am able to access the internet from the Fedora12 by selecting the network device as NAT and by entering the proxy settings.

But i am not able to access the internet from the Ubuntu10.04 with the same settings.

Please let me know, whether there are any options i need to enter for getting Ubuntu connected to the internet.

P.S: I searched the forum but didn't got any answer, as i dont want to re-open those threads i am initiating new thread, if i am wrong please apologize me.

Thanks in Advance,
SSuman185#SS185
 
Old 10-14-2010, 03:25 AM   #2
prayag_pjs
Senior Member
 
Registered: Feb 2008
Location: Pune - India
Distribution: Fedora,RedHat,CentOS,Gentoo
Posts: 1,138
Blog Entries: 4

Rep: Reputation: 147Reputation: 147
Hi,

Try to disable iptables ans selinux in ubuntu
 
Old 10-14-2010, 04:46 AM   #3
aluvalassuman185
LQ Newbie
 
Registered: Oct 2010
Posts: 5

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by prayag_pjs View Post
Hi,

Try to disable iptables ans selinux in ubuntu
Hi,

I dont know how to disable IP Tables, i am very new to Linux
Please help me in doing the same

I tried with these commands by searching over the net
# iptables -F
# iptables -X
# iptables -t nat -F
# iptables -t nat -X
# iptables -t mangle -F
# iptables -t mangle -X
# iptables -P INPUT ACCEPT
# iptables -P OUTPUT ACCEPT

but still not working.

As in my company we use proxy server, i entered proxy settings and i am getting "Proxy server is refusing the connections."

P.S: I did under root user

Thanks in Advance,
SSuman185#SS185
 
Old 10-14-2010, 04:52 AM   #4
prayag_pjs
Senior Member
 
Registered: Feb 2008
Location: Pune - India
Distribution: Fedora,RedHat,CentOS,Gentoo
Posts: 1,138
Blog Entries: 4

Rep: Reputation: 147Reputation: 147
To disable iptables do this:

GUI:

System > Administration > firestarter > Click on Stop Firewall button:
 
Old 10-14-2010, 05:20 AM   #5
aluvalassuman185
LQ Newbie
 
Registered: Oct 2010
Posts: 5

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by prayag_pjs View Post
To disable iptables do this:

GUI:

System > Administration > firestarter > Click on Stop Firewall button:
Hi,

I am sorry, i am not able to find "firestarter" in the System > Administrator tools.

Thanks in Advance,
SSuman185#SS185
 
Old 10-14-2010, 05:25 AM   #6
prayag_pjs
Senior Member
 
Registered: Feb 2008
Location: Pune - India
Distribution: Fedora,RedHat,CentOS,Gentoo
Posts: 1,138
Blog Entries: 4

Rep: Reputation: 147Reputation: 147
Hi,

Try this link

https://help.ubuntu.com/10.04/server.../firewall.html
 
Old 10-14-2010, 05:28 AM   #7
sem007
Member
 
Registered: Nov 2006
Distribution: RHEL, CentOS, Debian Lenny, Ubuntu
Posts: 638

Rep: Reputation: 111Reputation: 111
You can flush firewall using

Code:
sudo iptables -F
Are you able to ping your proxy server or gateway?

what is your ubuntu's IP address ?

Regards,
 
Old 10-14-2010, 05:54 AM   #8
aluvalassuman185
LQ Newbie
 
Registered: Oct 2010
Posts: 5

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by prayag_pjs View Post
Hi Prayag,

I disabled the firewall by using "sudo ufw disable" and checked the status as well.

But still not able to access.

Thanks in Advance,
SSuman185#SS185
 
Old 10-14-2010, 05:55 AM   #9
aluvalassuman185
LQ Newbie
 
Registered: Oct 2010
Posts: 5

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by sem007 View Post
You can flush firewall using

Code:
sudo iptables -F
Are you able to ping your proxy server or gateway?

what is your ubuntu's IP address ?

Regards,
Hi,

I tried this as well, still not able to access internet.

Thanks in Advance,
SSuman185#SS185
 
Old 10-14-2010, 06:04 AM   #10
sem007
Member
 
Registered: Nov 2006
Distribution: RHEL, CentOS, Debian Lenny, Ubuntu
Posts: 638

Rep: Reputation: 111Reputation: 111
Quote:
Originally Posted by aluvalassuman185 View Post
Hi,

I tried this as well, still not able to access internet.

Thanks in Advance,
SSuman185#SS185
what about ip address?

what is ip address of Ubuntu machine?

Are you able to ping proxy/gateway or another machine from Ubuntu?

Regards,
 
Old 10-14-2010, 06:18 AM   #11
prayag_pjs
Senior Member
 
Registered: Feb 2008
Location: Pune - India
Distribution: Fedora,RedHat,CentOS,Gentoo
Posts: 1,138
Blog Entries: 4

Rep: Reputation: 147Reputation: 147
Disable selinux (search on google how to disable selinux on ubuntu)

and please show us the output of

Quote:
ifconfig
 
Old 02-21-2011, 07:25 AM   #12
shahsaifi
LQ Newbie
 
Registered: Jul 2008
Location: New Delhi, India
Distribution: CentOS, Fedora, RHEL, Ubuntu, FreeBSD, OpanSolaris, SUSE, Mandriva
Posts: 11

Rep: Reputation: 0
Hi Guys,

I also faced similar issue with Ubuntu 10.04 x86_64: my host ip is 192.168.1.2 and vmnet8 got ip 192.168.1.1 from vm-dhcpd. It seems to be clashed with my lan network so every time when it is looking to connect with it. it gets failed and web is not accessible from host machine. In my case i changed ip address of vm-dhcpd at /etc/vmware/vmnet8/dhcpd/dhcpd.conf from 192.168.1.0 network to other e.g. 192.168.10.0 and modify /etc/vmware/networking "answer VNET_8_HOSTONLY_SUBNET 192.168.1.0 to answer VNET_8_HOSTONLY_SUBNET 192.168.10.0". Restart "sudo /etc/init.d/vmware restart" after running this you would be able to connect web and lan as well. I hope this might help.

Thanks,
Shah
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
not connected to internet in fedora12 gnanam_85 Linux - Newbie 3 05-25-2010 08:15 AM
anyone got vmplayer working on Slackware 13? Kristian2 Slackware 4 02-12-2010 04:09 AM
Internet not working, network working Vossy Linux - Networking 3 12-20-2005 05:20 PM
Internet is working/not working klemen Slackware 3 01-14-2005 06:58 AM
Internet working, network not working... phoenix07 Fedora 1 04-11-2004 02:30 AM


All times are GMT -5. The time now is 02:39 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration