LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Desktop (http://www.linuxquestions.org/questions/linux-desktop-74/)
-   -   Internet is not working on VMPlayer for Ubuntu10.04 but working for Fedora12 (http://www.linuxquestions.org/questions/linux-desktop-74/internet-is-not-working-on-vmplayer-for-ubuntu10-04-but-working-for-fedora12-837979/)

aluvalassuman185 10-14-2010 04:21 AM

Internet is not working on VMPlayer for Ubuntu10.04 but working for Fedora12
 
Hi Guys,

I got VM Images from the below sites
Ubuntu 10.04 from the VMPlanet and Fedora from the thoughtpolice.

I am able to access the internet from the Fedora12 by selecting the network device as NAT and by entering the proxy settings.

But i am not able to access the internet from the Ubuntu10.04 with the same settings.

Please let me know, whether there are any options i need to enter for getting Ubuntu connected to the internet.

P.S: I searched the forum but didn't got any answer, as i dont want to re-open those threads i am initiating new thread, if i am wrong please apologize me.

Thanks in Advance,
SSuman185#SS185

prayag_pjs 10-14-2010 04:25 AM

Hi,

Try to disable iptables ans selinux in ubuntu

aluvalassuman185 10-14-2010 05:46 AM

Quote:

Originally Posted by prayag_pjs (Post 4126897)
Hi,

Try to disable iptables ans selinux in ubuntu

Hi,

I dont know how to disable IP Tables, i am very new to Linux
Please help me in doing the same

I tried with these commands by searching over the net
# iptables -F
# iptables -X
# iptables -t nat -F
# iptables -t nat -X
# iptables -t mangle -F
# iptables -t mangle -X
# iptables -P INPUT ACCEPT
# iptables -P OUTPUT ACCEPT

but still not working.

As in my company we use proxy server, i entered proxy settings and i am getting "Proxy server is refusing the connections."

P.S: I did under root user

Thanks in Advance,
SSuman185#SS185

prayag_pjs 10-14-2010 05:52 AM

To disable iptables do this:

GUI:

System > Administration > firestarter > Click on Stop Firewall button:

aluvalassuman185 10-14-2010 06:20 AM

Quote:

Originally Posted by prayag_pjs (Post 4126948)
To disable iptables do this:

GUI:

System > Administration > firestarter > Click on Stop Firewall button:

Hi,

I am sorry, i am not able to find "firestarter" in the System > Administrator tools.

Thanks in Advance,
SSuman185#SS185

prayag_pjs 10-14-2010 06:25 AM

Hi,

Try this link

https://help.ubuntu.com/10.04/server.../firewall.html

sem007 10-14-2010 06:28 AM

You can flush firewall using

Code:

sudo iptables -F
Are you able to ping your proxy server or gateway?

what is your ubuntu's IP address ?

Regards,

aluvalassuman185 10-14-2010 06:54 AM

Quote:

Originally Posted by prayag_pjs (Post 4126975)

Hi Prayag,

I disabled the firewall by using "sudo ufw disable" and checked the status as well.

But still not able to access. :(

Thanks in Advance,
SSuman185#SS185

aluvalassuman185 10-14-2010 06:55 AM

Quote:

Originally Posted by sem007 (Post 4126978)
You can flush firewall using

Code:

sudo iptables -F
Are you able to ping your proxy server or gateway?

what is your ubuntu's IP address ?

Regards,

Hi,

I tried this as well, still not able to access internet.

Thanks in Advance,
SSuman185#SS185

sem007 10-14-2010 07:04 AM

Quote:

Originally Posted by aluvalassuman185 (Post 4126999)
Hi,

I tried this as well, still not able to access internet.

Thanks in Advance,
SSuman185#SS185

what about ip address?

what is ip address of Ubuntu machine?

Are you able to ping proxy/gateway or another machine from Ubuntu?

Regards,

prayag_pjs 10-14-2010 07:18 AM

Disable selinux (search on google how to disable selinux on ubuntu)

and please show us the output of

Quote:

ifconfig

shahsaifi 02-21-2011 08:25 AM

Hi Guys,

I also faced similar issue with Ubuntu 10.04 x86_64: my host ip is 192.168.1.2 and vmnet8 got ip 192.168.1.1 from vm-dhcpd. It seems to be clashed with my lan network so every time when it is looking to connect with it. it gets failed and web is not accessible from host machine. In my case i changed ip address of vm-dhcpd at /etc/vmware/vmnet8/dhcpd/dhcpd.conf from 192.168.1.0 network to other e.g. 192.168.10.0 and modify /etc/vmware/networking "answer VNET_8_HOSTONLY_SUBNET 192.168.1.0 to answer VNET_8_HOSTONLY_SUBNET 192.168.10.0". Restart "sudo /etc/init.d/vmware restart" after running this you would be able to connect web and lan as well. I hope this might help.

Thanks,
Shah


All times are GMT -5. The time now is 05:29 PM.