LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 02-22-2014, 07:32 PM   #1
duttocal
LQ Newbie
 
Registered: May 2011
Posts: 9

Rep: Reputation: Disabled
intel4000 + nvidia760 multiseat acceleration troubles: indirect intel rendering


after some days of hard work, my multiseat actually partially works! kinda.

some basic info
nvidia 760 and intel 4000 (motherboard+cpu) graphics
>i forget its exact name (crossfire?) but all my components support this intel+nvidia interaction.
some things i tried beforehand:
reinstalled drivers in general
swap "intel" with "i965"
almost every google-able guide to fixing intels direct rendering. im led to believe this specific form is caused nvidia-intel interactions.


the trouble now is that graphics are only running on the left side, the right side is using indirect rendering.
i cant find a suspect in my log or .conf's.

it gets stranger. KInfocenter reports that the left side is being accelerated with the intel card but is being run by the nvidia driver. in any case that side HAS opengl support and can run high-fps games as the nvidia card should do.
i jotted down what Kinfocenter is reporting, (the tool has no copy-paste functionality nor can i copy from the other side):
(the left nvidia 760 side)
Quote:
Direct Rendering
3D Accelerator
Vendor Intel Coorporation
Device Xeon E3-1200 ... Graphics Controller
Driver
Vendor NVIDIA Corporation
Renderer GeForce GTX 760
Kernel module i915
Indirect Rendering
(same nvidia info except its capped at opengl 2.1.2)
(the right intel 4000 side)
Quote:
Indirect Rendering
Driver
Vendor Intel Open Source Technology Center
Renderer Mesa DRI Intel(R) Ivybridge Desktop
OpenGL/ES version 1.4(3.0 Mesa 10.2.0-devel)
intel 4000's xorg.log.0
http://pastebin.com/u7c0rN1Y

nvidia 760's xorg.log.1
http://pastebin.com/hsFD54X4

from the visual side, the intel side displays first, it shows the kde loading splash for a split second before the nvidia side starts up and the intel side goes blank, switching to tty7 (ctrl-alt-f7) will bring the intel side back up.
> to me this feels like the second the nvidia side starts up, and strips away intel's rendering. hence the reason to tty7 back to it

things im going to test after this post:
-if disabling the nvidia side will give the intel side direct rendering
-changes in what Kinfocenter is reporting when i start up the nvidia side only. intel side only.
-delete xorg.log.2 and make sure thats not recurring, or else i secretly have 3 desktops.

KDE is indeed acting up a bit, i am using 2 different accounts but nevertheless there are all sorts of tiny quirks. im not going to post about this until my graphics troubles go away first though.

Steam also denys to start on the nvidia side unless you copy-in the nvidia 32 bit libraries...

Last edited by duttocal; 02-22-2014 at 07:40 PM.
 
Old 03-01-2014, 01:08 PM   #2
duttocal
LQ Newbie
 
Registered: May 2011
Posts: 9

Original Poster
Rep: Reputation: Disabled
i could not get a fix so far

here's some extra info:
-the accelerator is "unknown" from the nivida side when i disable the intel side, but besides that there is no change and the nvidia side is still running fine.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[solved] Direct rendering (3D acceleration) issues for linux kernel 2.6.29+ (Debian) gringer Linux - Hardware 1 03-30-2009 01:26 PM
no OpenGL Driect Rendering or 3D Acceleration for ATI X300 jsworth Linux - Hardware 3 01-15-2006 11:04 PM
Reverting to (slow) indirect rendering IGP 340M xslider Linux - Software 7 12-21-2004 07:08 AM
radeon 9000 pro... "direct rendering: yes" but no 3D acceleration in fact cpukiller Linux - Hardware 0 08-08-2004 09:34 PM
Direct Rendering Troubles Ansur Linux - Games 1 08-02-2004 10:44 AM


All times are GMT -5. The time now is 01:37 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration