LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 07-21-2007, 03:42 AM   #1
jaanus
LQ Newbie
 
Registered: May 2005
Location: Estonia
Distribution: Ubuntu
Posts: 10

Rep: Reputation: 0
Intel 830M drivers stopped working after upgrading from Ubuntu 6.10 to 7.04


Here we go...

The upgrade ran smoothly, but after the first restart, all I could see was the black screen although I could hear a sound and log in.

I figured out perhaps Ubuntu 7.04 had altered my xorg.conf somehow, but soon I realized my backup files were identical to the xorg.conf file. So I read somewhere that there were new drivers available so I installed xserver-xorg-video-intel, removed xserver-xorg-video-i810 and replaced "i810" with "intel" in my xorg.conf under video card section.

Also I have tried combinations of

dpkg-reconfigure -plow xserver-xorg
dpkg-reconfigure -pmedium xserver-xorg
dpkg-reconfigure -phigh xserver-xorg

several times with no result.

So now my laptop (HP Omnibook XE3) is running with "vesa" drivers. I wouldn't whine if the maximum resolution of these drivers weren't 800x600 and if they started properly after each startx. Right now things are rather unstable.

Oh and here's my xorg.conf:

Code:
Section "Files"
        FontPath        "/usr/share/fonts/X11/misc"
        FontPath        "/usr/share/fonts/X11/cyrillic"
        FontPath        "/usr/share/fonts/X11/100dpi/:unscaled"
        FontPath        "/usr/share/fonts/X11/75dpi/:unscaled"
        FontPath        "/usr/share/fonts/X11/Type1"
        FontPath        "/usr/share/fonts/X11/100dpi"
        FontPath        "/usr/share/fonts/X11/75dpi"
        # path to defoma fonts
        FontPath        "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
        Load    "bitmap"
        Load    "ddc"
        Load    "dri"
        Load    "extmod"
        Load    "freetype"
        Load    "glx"
        Load    "int10"
        Load    "vbe"
EndSection

Section "InputDevice"
        Identifier      "Generic Keyboard"
        Driver          "kbd"
        Option          "CoreKeyboard"
        Option          "XkbRules"      "xorg"
        Option          "XkbModel"      "pc105"
        Option          "XkbLayout"     "ee"
        Option          "XkbOptions"    "lv3:ralt_switch"
EndSection

Section "InputDevice"
        Identifier      "Configured Mouse"
        Driver          "mouse"
        Option          "CorePointer"
        Option          "Device"                "/dev/input/mice"
        Option          "Protocol"              "ImPS/2"
        Option          "ZAxisMapping"          "4 5"
        Option          "Emulate3Buttons"       "true"
EndSection

Section "InputDevice"
        Identifier      "Synaptics Touchpad"
        Driver          "synaptics"
        Option          "SendCoreEvents"        "true"
        Option          "Device"                "/dev/psaux"
        Option          "Protocol"              "auto-dev"
        Option          "HorizScrollDelta"      "0"
EndSection

Section "InputDevice"
        Driver          "wacom"
        Identifier      "stylus"
        Option          "Device"        "/dev/input/wacom"
        Option          "Type"          "stylus"
        Option          "ForceDevice"   "ISDV4"         # Tablet PC ONLY
EndSection

Section "InputDevice"
        Driver          "wacom"
        Identifier      "eraser"
        Option          "Device"        "/dev/input/wacom"
        Option          "Type"          "eraser"
        Option          "ForceDevice"   "ISDV4"         # Tablet PC ONLY
EndSection

Section "InputDevice"
        Driver          "wacom"
        Identifier      "cursor"
        Option          "Device"        "/dev/input/wacom"
        Option          "Type"          "cursor"
        Option          "ForceDevice"   "ISDV4"         # Tablet PC ONLY
EndSection

Section "Device"
        Identifier      "Intel Corporation 82830 CGC [Chipset Graphics Controller]"
        Driver          "vesa"
        BusID           "PCI:0:2:0"
EndSection

Section "Monitor"
        Identifier      "Generic Monitor"
        Option          "DPMS"
EndSection

Section "Screen"
        Identifier      "Default Screen"
        Device          "Intel Corporation 82830 CGC [Chipset Graphics Controller]"
        Monitor         "Generic Monitor"
        DefaultDepth    24
        SubSection "Display"
                Depth           1
                Modes           "1024x768"
        EndSubSection
        SubSection "Display"
                Depth           4
                Modes           "1024x768"
        EndSubSection
        SubSection "Display"
                Depth           8
                Modes           "1024x768"
        EndSubSection
        SubSection "Display"
                Depth           15
                Modes           "1024x768"
        EndSubSection
        SubSection "Display"
                Depth           16
                Modes           "1024x766"
        EndSubSection
        SubSection "Display"
                Depth           24
                Modes           "1024x768"
        EndSubSection
EndSection

Section "ServerLayout"
        Identifier      "Default Layout"
        Screen          "Default Screen"
        InputDevice     "Generic Keyboard"
        InputDevice     "Configured Mouse"
        InputDevice     "stylus"        "SendCoreEvents"
        InputDevice     "cursor"        "SendCoreEvents"
        InputDevice     "eraser"        "SendCoreEvents"
        InputDevice     "Synaptics Touchpad"
EndSection

Section "DRI"
        Mode    0666
EndSection
lspci:

Code:
00:00.0 Host bridge: Intel Corporation 82830 830 Chipset Host Bridge (rev 03)
00:02.0 VGA compatible controller: Intel Corporation 82830 CGC [Chipset Graphics Controller] (rev 03)
00:02.1 Display controller: Intel Corporation 82830 CGC [Chipset Graphics Controller]
00:1d.0 USB Controller: Intel Corporation 82801CA/CAM USB (Hub #1) (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801CA/CAM USB (Hub #2) (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801CA/CAM USB (Hub #3) (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 41)
00:1f.0 ISA bridge: Intel Corporation 82801CAM ISA Bridge (LPC) (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801CAM IDE U100 (rev 01)
00:1f.3 SMBus: Intel Corporation 82801CA/CAM SMBus Controller (rev 01)
02:02.0 Communication controller: ESS Technology ES2838/2839 SuperLink Modem (rev 01)
02:03.0 Multimedia audio controller: ESS Technology ES1988 Allegro-1 (rev 12)
02:04.0 CardBus bridge: O2 Micro, Inc. OZ6933/711E1 CardBus/SmartCardBus Controller (rev 01)
02:04.1 CardBus bridge: O2 Micro, Inc. OZ6933/711E1 CardBus/SmartCardBus Controller (rev 01)
02:08.0 Ethernet controller: Intel Corporation 82801CAM (ICH3) PRO/100 VE (LOM) Ethernet Controller (rev 41)
03:00.0 Network controller: ZyDAS Technology Corp. ZyDAS ZD1202 (rev 02)
Edit: I have also tried to boot up with different kernels, no luck

Thank you in advance,

J

Last edited by jaanus; 07-21-2007 at 07:18 AM.
 
Old 09-09-2007, 04:29 AM   #2
pporo
LQ Newbie
 
Registered: Sep 2007
Posts: 1

Rep: Reputation: 0
Same problem here

Hi there,

I'm raising this thread up since I'm having exactly the same problem (HP Omnibook XE3 display remains black after upgrading from 6.10 to 7.04)

Have you got any further solutions to the problem or any ideas from others how to proceed?

--
Tuomas
 
Old 09-12-2007, 02:15 PM   #3
otoomet
Member
 
Registered: Oct 2004
Location: Tartu, Ċrhus,Nürnberg, Europe
Distribution: Debian, Ubuntu, Puppy
Posts: 588

Rep: Reputation: 45
Have you checked a tool called '915resolution'? Some people have good experience with it (although not me).

Best, Ott
 
Old 09-17-2007, 10:45 AM   #4
lonehacker
LQ Newbie
 
Registered: Sep 2007
Distribution: Debian
Posts: 6

Rep: Reputation: 0
Post X log output pls

What is output into the X server's log files when you startx with the driver set to the intel driver instead of vesa?
On my machine this file is /var/log/Xorg.0.log.

Also, if the intelfb requires kernel-side support (I can't remember), is that enabled in the kernel and loaded? Use lsmod, /boot/config-2.6.whatever, 'dmesg' command to find out.

FWIW I previously had an intel 845gm running great with the kernel framebuffer driver, so I had a penguin at boot :-P and accelerated X using the Xorg driver, and all open source, under 2.6.1[89] or so.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound has stopped working in Ubuntu 6.10 gregorian Linux - Newbie 1 04-23-2007 01:00 PM
Intel 830M Motherboard Hardware Sensors jrtayloriv Linux - Hardware 3 01-10-2007 12:30 PM
OpenGL stopped working after upgrading from testing to unstable tuxedo-notebook Debian 4 11-10-2004 12:41 PM
Problems with agpgart--> Intel 830M video cellist Linux - Laptop and Netbook 2 03-28-2004 02:02 AM
Intel 830M video Help! Ricio Linux - Hardware 0 10-20-2003 02:59 PM


All times are GMT -5. The time now is 10:57 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration