LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Desktop (http://www.linuxquestions.org/questions/linux-desktop-74/)
-   -   installed kubuntu desktop. Now computer grub and all IS kubuntu (http://www.linuxquestions.org/questions/linux-desktop-74/installed-kubuntu-desktop-now-computer-grub-and-all-is-kubuntu-909601/)

swright007 10-22-2011 06:39 PM

installed kubuntu desktop. Now computer grub and all IS kubuntu
 
I currently run Ubuntu and was unhappy with Unity. I had read about being able to have more than 1 "flavor" of Ubuntu and being able to select which desktop to use during start-up. I wanted to test kubuntu. I found an 2 articles. I used apt-get install kubuntu-desktop. I then tried apt-get remove kubuntu-desktop and then found an article that said I needed to go to Synaptic to and select kubuntu-standard. For some reason, now, the start Grub2 and when you shut the computer down it thinks it IS Kubuntu. Also, it now treats Ubuntu like it is a session in that I no longer have the option to shut down while logged into Ubuntu. HOWEVER, when I am logged into Kubuntu, I get all options including shut-down. How do I get my computer to thinking it is Ubuntu with Kubuntu sessions? One further piece of info, the system is dual booted with Windows 7. Thank you in advance for any advice.

zootboy 10-22-2011 06:57 PM

I think you're mixing up your terms. Let me clarify some things for you.

Ubuntu is a Linux distribution (or distro). It is the Linux kernel and a bunch of other software packages all wrapped up nice and neat.

Within Ubuntu (and any desktop-based Linux distro), there are desktop environments. Gnome and KDE are the two most popular choices. You can put Gnome or KDE (or XFCE or LXDE or Fluxbox or any other desktop environment) on any distro of Linux. The desktop environment is not what defines the distro.

Kubuntu is a spin of Ubuntu. A spin is a derivative of a distro. The core software is mostly the same, but in the case of Kubuntu, the desktop environment is KDE instead of Gnome. It's still Ubuntu underneath no matter what.

So now we get to the part I don't quite understand. Ubuntu can't "think it's Kubuntu," nor can the opposite happen. If I understand what you're saying (I may not, seeing as I never use Ubuntu), you're just seeing the branding of the desktop environment. That shouldn't make a difference AFAIK.

In summary, Kubuntu and Ubuntu are the same OS. My question is: Is there an issue? Does KDE load up properly?

swright007 10-22-2011 07:52 PM

KDE loads fine.. Gnome loads fine also.. (Thank you for asking) However, it was Ubuntu with all the Ubuntu splashes and it would say "Ubuntu" when you shut it down.... now it says "Kubuntu" when you shut it down. The main grub used to be the Ubuntu black grub menu and now it is the KDE/Kubuntu blue... It is acting like it has somehow become Kubuntu and the Gnome/Ubuntu is just a desktop environment (as opposed to the original starting operating system). It should be the other way around.

zootboy 10-22-2011 10:42 PM

To re-iterate, it has always been Ubuntu. Kubuntu is Ubuntu.

As for your issue, I'm afraid I'm not of much help. I disable all splash screens, so I never deal with them. But here's a link that may be of some help:

http://embraceubuntu.com/2006/02/20/...buntu-install/

Honestly, the pretty pictures have never mattered to me. I prefer the "traditional Linux wall of text" boot screen.

k3lt01 10-22-2011 10:54 PM

Lets cut through the confusion before we start.

Ubuntu is Ubuntu (used to be Gnome 2.x now it is Gnome 3 with Unity as the main interface).
Kubuntu is Kubuntu (KDE) the packages are not always the same as Ubuntu because KDE has different defaults.
Lubuntu is Lubuntu (LXDE) like Kubuntu the packages are not always the same as Ubuntu.
Xubuntu is Xubuntu (XFCE) like Kubuntu and Lubuntu the packages are not always the same as Ubuntu.

When you installed Kubuntu Desktop you may have installed KDM the KDE login screen and that may be why you think you have lost your old look. There will be a setting somewhere that you will need to adjust to get GDM etc back so it looks like it used to, or you could just re-install ubuntu-desktop and it should all go back to the Ubuntu flavour you are used to.

andrewthomas 10-22-2011 10:57 PM

When you installed kubuntu-desktop, it pulled in plymouth-theme-kubuntu-logo.


http://packages.ubuntu.com/oneiric/p...e-kubuntu-logo

Updating, update-alternatives to provide the kubuntu plymouth theme.

You can reinstall plymouth-theme-ubuntu-logo


http://packages.ubuntu.com/oneiric/p...me-ubuntu-logo

and you will have the ubuntu bootsplash, not the kubuntu version.

You can also reinstall (reconfigure) gdm to accomplish the same with your dm.

swright007 10-24-2011 02:30 AM

Thank you for your suggestions. I tried the things mentioned... changing the bootsplash and re-installing Ubuntu-desktop. Neither of those seemed to fix the issue. I even tried with a bootsplash theme manager going in to set the theme I wanted and that didn't work either. However, it seems that my problem is purely cosmetic in nature. My login screen didn't change, it was never part of the problem. Just the grub, the bootsplash screen, and also when shutting down, the exit text saying that it is closing Kubuntu when the system shuts down. I found a way to go in and alter the grub menu's colors, so at least that is better. If anyone knows of anything I haven't tried, please let me know. Otherwise, I will surrender this battle. It is just mildly annoying, not really a problem of function. Thank you all, again, for jumping in and trying to help.

Scott

zootboy 10-24-2011 08:23 AM

If andrewthomas is right, then you have to install plymouth-theme-ubuntu-logo and uninstall plymouth-theme-kubuntu-logo. Try that.

swright007 10-25-2011 04:58 PM

Thank you for all your help. It turns out that Ubuntu appears to have been corrupt. Some of the programs I had weren't acting correctly so I booted up with a live-cd and tested the same task and was able to do them just fine. I believe reinstalling from scratch will fix all this and other problems I was having too.


All times are GMT -5. The time now is 05:42 AM.