LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 02-05-2013, 12:08 AM   #1
vignesh4sh
Member
 
Registered: Oct 2012
Posts: 69

Rep: Reputation: Disabled
initramfs-tools-bin installation issue (Dependency problems)


Hi,
Iam using ubuntu12.04.when i install any packages. I getting this error
Quote:
sudo apt-get install kompozer
eading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
initramfs-tools : Depends: initramfs-tools-bin (< 0.99ubuntu13.1~) but 0.99ubuntu13.1 is to be installed
kompozer : Depends: kompozer-data but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Then, I tried
Quote:
sudo apt-get install initramfs-tools-bin
Reading package lists... Done
Building dependency tree
Reading state information... Done
initramfs-tools-bin is already the newest version.
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
initramfs-tools : Depends: initramfs-tools-bin (< 0.99ubuntu13.1~) but 0.99ubuntu13.1 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
Then i tried
Quote:
sudo apt-get install initramfs-tools
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
libsm-dev liblaunchpad-integration1 xsltproc libice-dev gstreamer0.10-packagekit libxcb-event1 libindicator3 x11proto-kb-dev libx264-106
gcc-4.3-base nvidia-settings gir1.2-gdkpixbuf-2.0 libbluray0 libdbusmenu-glib3 ubufox gir1.2-json-glib-1.0 wine1.3 g++-4.4 g++-4.5
epiphany-browser-data libglew1.5 libevview3 scrollkeeper evince-common rarian-compat linux-headers-2.6.35-32-generic libnotify-bin
libwnck-common librpmio1 linux-headers-2.6.35-32 linux-headers-2.6.35-28 libstdc++6-4.4-dev libpoppler13 libkexiv2-9 libxdmcp-dev
libprocesscore4b xtrans-dev libwnck22 libxres1 x11proto-core-dev linux-headers-2.6.38-16 libmp3lame0 libgp11-0 libpackagekit-qt14 libgcr0
libcdio-cdda0 libkpathsea5 libt1-5 libavahi-gobject0 libdbusmenu-gtk1 dkms libdbusmenu-gtk3 libxt-dev gnome-doc-utils librarian0
libstdc++6-4.5-dev liblzo2-2 libevdocument3 libavfilter1 linux-headers-2.6.35-28-generic x11proto-input-dev gnome-user-guide
linux-headers-2.6.38-16-generic libpthread-stubs0-dev gnome-js-common libaudiofile0 libxau-dev libpthread-stubs0 libappindicator1
libsolidcontrolifaces4a libtinyxml2.5.3 yelp libexiv2-10 libcdio-paranoia0 libxdot4 python-wsgi-intercept screen-resolution-extra
libcheese-gtk18 libmaa2 cpp-4.3 libx11-dev libqt3-mt gir1.0-freedesktop yelp-xsl libgnome-desktop-2-17 libxcb1-dev libnautilus-extension1
libkdcraw9 libpoppler-glib5 libpoppler-glib6 libavdevice52
Use 'apt-get autoremove' to remove them.
The following packages will be upgraded:
initramfs-tools
1 upgraded, 0 newly installed, 0 to remove and 17 not upgraded.
13 not fully installed or removed.
Need to get 0 B/49.0 kB of archives.
After this operation, 1,024 B of additional disk space will be used.
dpkg: dependency problems prevent configuration of initramfs-tools:
initramfs-tools depends on initramfs-tools-bin (<< 0.99ubuntu13.1~); however:
Version of initramfs-tools-bin on system is 0.99ubuntu13.1.
dpkg: error processing initramfs-tools (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-image-3.2.0-35-generic-pae:
linux-image-3.2.0-35-generic-pae depends on initramfs-tools (>= 0.36ubuntu6); however:
Package initramfs-tools is not configured yet.
dpkg: error processing linux-image-3.2.0-35-generic-pae (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-image-3.2.0-36-generic:
linux-image-3.2.0-36-generic depends on initramfs-tools (>= 0.36ubuntu6); however:
Package initramfs-tools is not configured yet.No apport report written because MaxReports is reached already
No apport report written because MaxReports is reached already
No apport report written because MaxReports is reached already

dpkg: error processing linux-image-3.2.0-36-generic (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-image-3.2.0-36-generic-pae:
linux-image-3.2.0-36-generic-pae depends on initramfs-tools (>= 0.36ubuntu6); however:
Package initramfs-tools is not configured yet.
dpkg: error processing linux-image-3.2.0-36-generic-pae (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of ubuntu-minimal:
ubuntu-minimal depends on initramfs-tools; however:
Package initramfs-tools is not configured yet.
dpkg: error processing ubuntu-minimal (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of plymouth:
plymouth depends on initramfs-tools; however:
Package initramfs-tools is not configured yet.
dpkg: error processing plymouth (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuraNo apport report written because MaxReports is reached already
No apport report written because MaxReports is reached already
No apport report written because MaxReports is reached already
No apport report written because MaxReports is reached already
No apport report written because MaxReports is reached already
tion of plymouth-theme-ubuntu-text:
plymouth-theme-ubuntu-text depends on plymouth; however:
Package plymouth is not configured yet.
dpkg: error processing plymouth-theme-ubuntu-text (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-image-generic:
linux-image-generic depends on linux-image-3.2.0-36-generic; however:
Package linux-image-3.2.0-36-generic is not configured yet.
dpkg: error processing linux-image-generic (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-generic:
linux-generic depends on linux-image-generic (= 3.2.0.36.43); however:
Package linux-image-generic is not configured yet.
dpkg: error processing linux-generic (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-image-generic-pae:
linux-image-generic-pae depends on linux-image-3.2.0-35-generic-pae; however:
Package linNo apport report written because MaxReports is reached already
No apport report written because MaxReports is reached already
No apport report written because MaxReports is reached already
No apport report written because MaxReports is reached already
No apport report written because MaxReports is reached already
ux-image-3.2.0-35-generic-pae is not configured yet.
dpkg: error processing linux-image-generic-pae (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-generic-pae:
linux-generic-pae depends on linux-image-generic-pae (= 3.2.0.35.40); however:
Package linux-image-generic-pae is not configured yet.
dpkg: error processing linux-generic-pae (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of plymouth-label:
plymouth-label depends on plymouth (= 0.8.2-2ubuntu31); however:
Package plymouth is not configured yet.
dpkg: error processing plymouth-label (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of plymouth-theme-kubuntu-text:
plymouth-theme-kubuntu-text depends on plymouth; however:
Package plymouth is not configured yet.
plymouth-theme-kubuntu-text depends on plymouth-theme-ubuntu-text; however:
Package plymouth-theme-ubuntu-text is not configured yet.
dpkg: error processing plymouth-theme-kubuntu-text (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
initramfs-tools
linux-image-3.2.0-35-generic-pae
linux-image-3.2.0-36-generic
linux-image-3.2.0-36-generic-pae
ubuntu-minimal
plymouth
plymouth-theme-ubuntu-text
linux-image-generic
linux-generic
linux-image-generic-pae
linux-generic-pae
plymouth-label
plymouth-theme-kubuntu-text
E: Sub-process /usr/bin/dpkg returned an error code (1)
Pleas suggest me an idea. I am stucked

Thanks
 
Old 02-05-2013, 01:08 AM   #2
descendant_command
Member
 
Registered: Mar 2012
Posts: 846

Rep: Reputation: 187Reputation: 187
You have broken it by installing packages from incompatible repo's.

Remove everything from /etc/apt/sources.list except the stock 12.04 repo's and try to downgrade the initramfs packages (and anything else necessary).

Otherwise, you get to keep all the pieces
 
Old 02-05-2013, 02:30 AM   #3
vignesh4sh
Member
 
Registered: Oct 2012
Posts: 69

Original Poster
Rep: Reputation: Disabled
Thanks for reply.
This is my /etc/apt/source.list file
Quote:
sudo vi /etc/apt/source.list

deb http://us.archive.ubuntu.com/ubuntu/ precise main restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ precise main restricted

deb http://us.archive.ubuntu.com/ubuntu/ precise-updates main restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ precise-updates main restricted

deb http://us.archive.ubuntu.com/ubuntu/ precise universe
deb-src http://us.archive.ubuntu.com/ubuntu/ precise universe
deb http://us.archive.ubuntu.com/ubuntu/ precise-updates universe
deb-src http://us.archive.ubuntu.com/ubuntu/ precise-updates universe


deb http://us.archive.ubuntu.com/ubuntu/ precise multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ precise multiverse
deb http://us.archive.ubuntu.com/ubuntu/ precise-updates multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ precise-updates multiverse

deb http://us.archive.ubuntu.com/ubuntu/ precise-backports main restricted universe multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ precise-backports main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu precise-security main restricted
deb-src http://security.ubuntu.com/ubuntu precise-security main restricted
deb http://security.ubuntu.com/ubuntu precise-security universe
deb-src http://security.ubuntu.com/ubuntu precise-security universe
deb http://security.ubuntu.com/ubuntu precise-security multiverse
deb-src http://security.ubuntu.com/ubuntu precise-security multiverse

# deb http://download.webmin.com/download/repository sarge contrib # disabled on upgrade to natty
# deb http://webmin.mirror.somersettechsol....uk/repository sarge contrib # disabled on upgrade to natty
which one i need to remove?

Thanks
 
Old 02-05-2013, 02:54 AM   #4
descendant_command
Member
 
Registered: Mar 2012
Posts: 846

Rep: Reputation: 187Reputation: 187

Wow, why all the duplicates?

And why all the deb-src lines?
Do you actually build anything from source?

I don't use ubuntu so probably can't give definitive advice but...
Code:
initramfs-tools : Depends: initramfs-tools-bin (< 0.99ubuntu13.1~) but 0.99ubuntu13.1 is to be installed
Your version of initramfs-tools requires an earlier version of initramfs-tool-bin than you currently have installed.

Maybe try upgrading initramfs-tools to the one in the precise repo (which presumably should match your version of initramfs-tools-bin).

I would say either you have only partially upgraded at some stage, or you have installed that initramfs-tools package (maybe as a dependency of something else) from another source (I have heard that multiverse packages can be a bit variable in quality, and are not supported by Canonical).
edit: I don't think universe is either, but someone will correct me if I'm wrong.

Also maybe try using aptitude. It can be a bit smarter at resolving curly dependency chains.

Last edited by descendant_command; 02-05-2013 at 02:55 AM.
 
  


Reply

Tags
linux command


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
module-init-tools, initramfs-tools broken virgilhowardson Debian 1 03-08-2009 01:30 AM
Dependency problems with 'yum' installing xorg-x11-tools SirTristan Linux - Software 2 05-17-2008 02:39 PM
initrd-tools or initramfs-tools kushalkoolwal Debian 9 12-28-2006 10:11 PM
install new kernel problem with initramfs-tools arsham Linux - General 1 10-04-2006 03:53 PM
/tools/bin/env: /tools/bin/bash: No such file or directory DaZjorz Linux From Scratch 21 07-27-2005 08:11 AM


All times are GMT -5. The time now is 11:56 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration