LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 11-05-2008, 11:41 AM   #1
rickklaw
LQ Newbie
 
Registered: Apr 2006
Distribution: Ubuntu 8.10
Posts: 10

Rep: Reputation: 0
ICEauthority error in Ubuntu 8.10


I get this error whenever I begin the log in process:

Quote:
Could not update ICEauthority file /home/rick/.ICEauthority
Then it doesn't let me log on until I hit "OK"


I tried using this fix but it didn't work.

Quote:
Boot into recovery mode and choose to drop to a root shell. If you don't know how to do that, check out the first half of this tutorial.

Then type
Code:

chown rick:rick /home/rick/.ICEauthority
chmod 644 /home/rick/.ICEauthority
exit

and resume the normal boot. That should fix it.
Since this started, I can't get any sound from external devices (CD, DVD, nor Ipod) and GIMP doesn't work. I can't access any of the logout features using the Gnome desktop option. It all worked initially when I upgraded to 8.10 from 8.04.

(Oddly, internal sound works fine.)

Any help would be greatly appreciated!
 
Old 11-06-2008, 10:08 PM   #2
budword
Member
 
Registered: Apr 2003
Location: Wisconsin
Distribution: Switched to regualr Ubuntu, because I don't like KDE4, at all. Looks like vista on crack.....
Posts: 675

Rep: Reputation: 31
Can you give us the output of this command ?

ls -l /home/rick/.ICEauthority

The problem is that you don't have permissions to write to .ICEauthority, and those chown and chmod commands are trying to fix that. You have to run those commands as sudo or root, if you use root, and it doesn't look like you did run them as sudo, or root.

I've also had luck simply deleting it, as sudo or root, and then letting the system recreate it on reboot, but changing it is the better solution I think.

David
 
Old 11-11-2008, 05:26 PM   #3
arizonagroovejet
Senior Member
 
Registered: Jun 2005
Location: England
Distribution: SLED, openSUSE
Posts: 1,032

Rep: Reputation: 174Reputation: 174
Boot in to recovery mode?! Blimey, talk about over complicating an issue.

There is absolutely no need to use recovery mode. If you need to change the ownership of the file then all you need to do is run the chmod command as root. Boot as usual, hit ctrl-alt-f3 to get a text login prompt login as yourself and run

$ sudo chmod rick:rick /home/rick/.ICEauthority
$ exit

The press ctrl-alt-f7 to go back to the GUI login screen.

But I'd just delete the file. There's nothing in there that matters (unless you're actually logged in with a graphical session) and deleting it also deals with the potential situation that the file is somehow corrupt and that is preventing it being updated properly.

If the file is repeatedly ending up as being owned by a user other than yourself then you have a problem somewhere.
 
1 members found this post helpful.
Old 02-03-2009, 04:47 AM   #4
crazywalterke
LQ Newbie
 
Registered: Feb 2009
Posts: 1

Rep: Reputation: 0
Check your own permissions to your home folder

I was experiencing the same problem,
and after trying to change ownerchip and permissions on the file as said above, even deleting it,
the err. still existed.
So I checked my permissions on my home folder and I saw I could only r en x my files in /home/'username'

so after simple chmod to rwx for my own user name a simple loging created the file again and problem was solved
 
Old 11-01-2009, 09:01 AM   #5
krishnasut
LQ Newbie
 
Registered: Jan 2009
Posts: 14

Rep: Reputation: 0
Question Same Problem in ubuntu 9.10

I have installed ubuntu 9.10 and face the same problem.
My DVD drive is also being not work properly.
Help ...
 
Old 11-04-2009, 03:38 AM   #6
nealio
LQ Newbie
 
Registered: Nov 2009
Posts: 1

Rep: Reputation: 0
Hi,
I also recently had this problem with Ubuntu 8.10 after doing an update via UPdate Manager. I think whatever packages were updated may have inadvertantly screwed up my home directory ownership and made both the owner and group of my home directory as root!! However, the permissions for the .ICEauthority file were still correct and both owner and group were still set to my username. The fix that worked for me was:

Code:
mv ~/.ICEauthority ~/.ICEauthority.backup
sudo chown <user>:<user> /home/<user>
sudo reboot
By the way, this problem affected the sound system and prevented all sorts of sub-systems from starting normally. For example the volume control in the panel disappeared.

This kind of thing should NEVER happen and is a great example of "when-things-go-wrong" in Linux they really go wrong - and the average non-techie user will simply give up and go back to Windows.

Good luck!
 
1 members found this post helpful.
Old 05-12-2010, 11:52 AM   #7
walterbyrd
Member
 
Registered: Apr 2004
Posts: 572

Rep: Reputation: 30
Quote:
$ sudo chmod rick:rick /home/rick/.ICEauthority
This almost worked for me.

After I did this (with chown not chmod) I was able to log in, but I have lost all of my setting. JPGs to appear correctly on the desktop, and so on.
 
Old 09-05-2010, 10:40 AM   #8
arnygrape
LQ Newbie
 
Registered: Sep 2010
Distribution: Ubuntu - 10.04
Posts: 1

Rep: Reputation: 0
I had a similar solution to changing the permissions. I believe the cause of my problem was attempting to install veetle. My issue was it changed the permissions for my entire home directory and not just my .ICEauthority. Check if you have permissions for any file in your home directory, if not...restart in recovery and scroll down to root. type chown user:user /home/user make sure to use your login name in place of "user". Good luck.
 
Old 09-08-2010, 04:42 PM   #9
matpiast
LQ Newbie
 
Registered: Sep 2010
Posts: 1

Rep: Reputation: 0
maybe add it ?

I saw that problems with file .ICEauthority is very common.
So is there any plans to add similar instruction:

Code:
if exist .ICEauthority then
-----------------------------------
if error="error with accessing..." when try to acces .ICEauthority then
sudo chown...
counter=counter+1
if counter=(some value) then
show message "Something is wrong"
end if
end if
---------------------
else
touch .ICEauthority
end if
into KDE/GNOME or script which is executed on start
 
Old 11-15-2010, 03:44 AM   #10
socket478
LQ Newbie
 
Registered: Jun 2010
Posts: 2

Rep: Reputation: 0
Quote:
sudo chown <user>:<user> /home/<user>
it was worked for me, but when I tried to start Klamav from CLI using
Code:
sudo klamav
everything goes bad...

the .ICEAuthority appears again and my Klamav couldn't get some update...

Could anyone please help me...

thx
 
  


Reply

Tags
gnome, iceauthority


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ubuntu on USB flash drive - unable to lock ICEauthority ihaveebola Ubuntu 0 04-12-2007 12:56 AM
.ICEauthority barn63 Slackware 19 12-20-2006 11:19 PM
.ICEauthority Beads Suse/Novell 3 05-06-2006 12:43 PM
Samba and ICEauthority simeandrews Linux - General 1 01-16-2006 09:14 AM
.ICEAuthority error pureevil4 Slackware 2 08-13-2004 12:40 PM


All times are GMT -5. The time now is 07:35 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration