LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Desktop (http://www.linuxquestions.org/questions/linux-desktop-74/)
-   -   I can't keep xrandr setting permanent as ~/.xprofile is not being read. (http://www.linuxquestions.org/questions/linux-desktop-74/i-cant-keep-xrandr-setting-permanent-as-%7E-xprofile-is-not-being-read-4175454248/)

vectrum 03-15-2013 06:08 PM

I can't keep xrandr setting permanent as ~/.xprofile is not being read.
 
I can't make xrandr setting permanent.
I've created ~/.xprofile and, being root copy it to /etc/ and /etc/X11/xinit/. I've also appended xrandr setting in ~/.xinitrc but my slack14 suddenly stopped reading ~/.xprofile file.
The setting is xrandr -s 832x624 -r 75
It works only when I give it as a command.
Please help.
Thank you.

P.S I tried here http://www.linuxquestions.org/questi...d.php?t=707202 but couldn't
understand.

malekmustaq 03-16-2013 12:57 PM

I have experienced the same frustration. I have even tried written a script and placed it at /etc/rc.d/rc4.d (or even ini.d/) folders hoping init to catch it before loading the login screen but probably I needed more readings to have it work.

Having no such time I conceded to do it the dirty way by adding the lines into the /etc/profile, a place where slackware habitually goes after login. If your system has none you may try create one /etc/profile and get the luck if it is read after login.

The login screen is a bit ugly but when X loads the resolution is corrected to a pretty one. I did not want to put it ~/ because I wanted other users to enjoy the same resolution after the login.

Hope that helps.

Good luck.

vectrum 03-17-2013 10:36 AM

Quote:

Originally Posted by malekmustaq (Post 4912958)
I have experienced the same frustration. I have even tried written a script and placed it at /etc/rc.d/rc4.d (or even ini.d/) folders hoping init to catch it before loading the login screen but probably I needed more readings to have it work.

Having no such time I conceded to do it the dirty way by adding the lines into the /etc/profile, a place where slackware habitually goes after login. If your system has none you may try create one /etc/profile and get the luck if it is read after login.

The login screen is a bit ugly but when X loads the resolution is corrected to a pretty one. I did not want to put it ~/ because I wanted other users to enjoy the same resolution after the login.

Hope that helps.

Good luck.

Thank you for the suggestion. My problem's been solved but I don't know how :).
I have put xrandr setting in ~/.xprofile and, yes dropped a line in .bash_profile.
It's suddenly started working.
According to general opinions that are available on W3, xrandr should go on .xprofile and let all the users set/customize it accordingly.

Thank you.


All times are GMT -5. The time now is 11:31 AM.