LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Desktop (http://www.linuxquestions.org/questions/linux-desktop-74/)
-   -   Huge fonts problem with KDE4 and radeon driver (http://www.linuxquestions.org/questions/linux-desktop-74/huge-fonts-problem-with-kde4-and-radeon-driver-717016/)

Freex 04-05-2009 01:17 PM

Huge fonts problem with KDE4 and radeon driver
 
Hey,
I recently downloaded Linux Mint 6 KDE RC1, and immediately noticed a problem when it booted into KDE: the fonts are impossibly huge, making it nearly impossible to use any graphical application.
I used the command-line ftp tool to upload some screenshots:
http://vbogaert.infobyte.org/temp/snapshot1.png
http://vbogaert.infobyte.org/temp/snapshot2.png

The thing that irks me is that I've run into this problem before, alzays using KDE4 and the radeon driver. I usually bypass the issue by switching to the fglrx or vesa drivers, but right now I want a fix, largely because adding a line saying Driver "vesa" in the appropriate spot of my xorg.conf isn't working (something about no suitable vesa modes found). It occurs using the combination of the radeon drivers and KDE4, it doesn't see, to be a problem in KDE3 or gnome (but I'm a kde fan :-( )
My system is a fujitsu siemens laptop with a Radeon Xpress 1250 chipset that contains(?) a Radeon 200M graphical chipset.
I apologise if I've made any spelling errors or left anything out; posting to this website from lynx using a wrongly configured keyboard is not very easy.
Any help (even just suggestions on how to get VESA drivers working) would be greatly appreciated :-)
freex

Robhogg 04-05-2009 04:59 PM

Strangely, I'd just been reading about a similar problem in the "Ask Klaus" column in Linux magazine. He suggested directly altering the dots-per-inch settings, but this Ubuntu wiki post suggests a better way to solve this (found it through launchpad.net) - scroll down to "Hardcoding a fixed DPI".

Hope this helps,
Rob

Freex 04-06-2009 11:33 AM

Quote:

Originally Posted by Robhogg (Post 3499398)
Strangely, I'd just been reading about a similar problem in the "Ask Klaus" column in Linux magazine. He suggested directly altering the dots-per-inch settings, but this Ubuntu wiki post suggests a better way to solve this (found it through launchpad.net) - scroll down to "Hardcoding a fixed DPI".

Hope this helps,
Rob



Thanks :-)

Unfortunately, the solution you referred to wasn't enough, in the end I had to add two lines to my /etc/X11/xorg.conf:

Option "NoDDC" to section Device,

as well as

DisplaySize 331 208 to section Monitor


All times are GMT -5. The time now is 01:34 AM.