LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 02-18-2007, 02:01 AM   #1
ygloo
Member
 
Registered: Aug 2006
Distribution: slack
Posts: 323

Rep: Reputation: 30
howto disable firefox plugin - gxine?


hello,

read that deleting "gxineplugin.so" does the trick...

- loc gxineplugin.so <--'
/usr/lib/mozilla/plugins/gxineplugin.so

how to disable gxine without deleting this file??

- grep -r gxineplugin.so ~/.mozilla <--'
~/.mozilla/firefox/pluginreg.dat - "/usr/lib/gxine/gxineplugin.so:$"

i erased lines linked with gxine and made file read-only (r--------)
when i reload firefox gxine is still in "aboutlugins" page
and
~/.mozilla/firefox/pluginreg.dat
is modified

Last edited by ygloo; 02-18-2007 at 02:39 AM.
 
Old 02-18-2007, 07:51 AM   #2
David the H.
Bash Guru
 
Registered: Jun 2004
Location: Osaka, Japan
Distribution: Debian sid + kde 3.5 & 4.4
Posts: 6,823

Rep: Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950
The easiest thing to do is to simply go to Edit > Preferences > Content > Manage File Types and change the default action for the mime types you don't want the plugin to handle.

There used to be a control to deactivate plugins from the preferences panel, but it looks like they've removed that. Perhaps there's an extension out there somewhere that adds that functionality back into the browser?

I don't know if making the plugin read-only is enough to disable it. For all I know, reading may be all that's required for it to work. Also, the Firefox plugin finder can look in several places for plugins, so even if you delete one, it may still be finding it in others. To find out exactly which plugin your browser is using, open up about:config, find the line "plugin.expose_full_path" and change it to true. Now about:plugins should show the full path to the plugins being used.

Last edited by David the H.; 02-18-2007 at 07:58 AM.
 
Old 02-18-2007, 09:40 PM   #3
ygloo
Member
 
Registered: Aug 2006
Distribution: slack
Posts: 323

Original Poster
Rep: Reputation: 30
there is no Edit > Preferences > Content > Manage File Types menu
in firefox 1.5.0.7

have to find another way
thank you
 
Old 02-18-2007, 10:03 PM   #4
David the H.
Bash Guru
 
Registered: Jun 2004
Location: Osaka, Japan
Distribution: Debian sid + kde 3.5 & 4.4
Posts: 6,823

Rep: Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950
Then you'll find it under the downloads tab or somesuch. I don't remember now exactly where it was in 1.5, but I know it's there somewhere. Just search around the preferences.
 
Old 02-18-2007, 10:17 PM   #5
ygloo
Member
 
Registered: Aug 2006
Distribution: slack
Posts: 323

Original Poster
Rep: Reputation: 30
there is
Edit > Downloads > View & Edit Actions
inside i see 1 action about vector graphics
 
Old 03-20-2009, 11:23 AM   #6
trist007
Senior Member
 
Registered: May 2008
Distribution: Slackware
Posts: 1,004

Rep: Reputation: 67
In Firefox, go to Add-ons and disable the start gxine plugin.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Gxine firefox plugin error simcox1 Slackware 1 09-23-2006 01:01 PM
removing gxine plugin roninja Slackware 1 09-20-2005 10:16 AM
Gxine plugin trick slackwarefan General 1 07-24-2004 01:13 PM
gxine browser plugin moger Slackware 18 05-20-2004 02:46 PM
Gxine plugin not leaving jorisb Linux - Software 0 03-16-2004 10:28 PM


All times are GMT -5. The time now is 03:48 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration