LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 09-05-2011, 07:23 PM   #1
haiyuan_victor
LQ Newbie
 
Registered: Jul 2010
Posts: 22

Rep: Reputation: 0
how to use ibus in urxvt in fvwm


Hi,all,
I use fedora 15,my shortcut key for ibus is shift+space,when i in gnome, i press this key in urxvt, i can use ibus;
but , when i switch to fvwm,when i use urxvt, i press this shortcut key, but I cannot use ibus!there is something that when i use chrome and gnome-terminal in fvwm,when i press this key i can use ibus!
i've try my best to do the flowing:
1、in .Xresource,i add Rxvt.inputMethod: ibus
2、in .bashrc i add
export GTK_IM_MODULE="ibus"
export QT_IM_MODULE="ibus"
export XMODIFIERS=”@im=ibus”
3、in .xinitrc i add the same as .bashrc too
but i still can't use ibus in urxvt!
is there any other method?
thanks!
 
Old 09-06-2011, 06:00 AM   #2
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
I'm not using Fedora, or Gnome. The iBus post install instructions with Gentoo state:
Code:
Set the following in your user startup scripts
such as .xinitrc, .xsession or .xprofile:
     export XMODIFIERS="@im=ibus"
     export GTK_IM_MODULE="ibus"
     export QT_IM_MODULE="xim"
     ibus-daemon -d -x
You do not have:
Code:
ibus-daemon -d -x
That is required for Fluxbox. Maybe it is required for fvwm also. If you try those
changes, logout of X and then restart X for them to take effect.

The following attachments show my settings for iBus to use Chinese Pinyin input.

If this doesn't solve your problem you might have a bug with iBus. Please contact
the iBus Project. The developers work for RedHat and can help you.

Maybe try the iBus Startup Trouble Shooting page.
Attached Images
File Type: png ibus-01.png (51.3 KB, 3 views)
File Type: png ibus-02.png (41.2 KB, 2 views)
File Type: png ibus-03.png (24.9 KB, 3 views)
 
1 members found this post helpful.
Old 09-07-2011, 12:52 AM   #3
haiyuan_victor
LQ Newbie
 
Registered: Jul 2010
Posts: 22

Original Poster
Rep: Reputation: 0
thanks!
I only add "ibus-daemon &" in my .bash_profile before, then I replace this with "ibus-daemon -d -x",now ,i can use ibus in urxvt in fvwm!

Last edited by haiyuan_victor; 09-07-2011 at 12:54 AM.
 
Old 09-07-2011, 05:13 AM   #4
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
非常好!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
pinyin and ibus Pedroski Linux - Software 15 10-21-2010 06:36 AM
fvwm & fvwm-crystal? festhead Linux - Desktop 1 09-23-2007 09:49 AM
transparency not correct with fvwm + fvwm-crystal + radeon hedpe Linux - Desktop 0 01-30-2007 07:59 PM
clock not working in fvwm with fvwm-crystal hedpe Linux - Software 0 09-13-2005 08:04 PM
2 fvwm processes with 2 displays, only want one fvwm enzo250gto Linux - Software 0 01-27-2005 04:50 PM


All times are GMT -5. The time now is 07:14 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration