LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Desktop (http://www.linuxquestions.org/questions/linux-desktop-74/)
-   -   how to use ibus in urxvt in fvwm (http://www.linuxquestions.org/questions/linux-desktop-74/how-to-use-ibus-in-urxvt-in-fvwm-901307/)

haiyuan_victor 09-05-2011 08:23 PM

how to use ibus in urxvt in fvwm
 
Hi,all,
I use fedora 15,my shortcut key for ibus is shift+space,when i in gnome, i press this key in urxvt, i can use ibus;
but , when i switch to fvwm,when i use urxvt, i press this shortcut key, but I cannot use ibus!there is something that when i use chrome and gnome-terminal in fvwm,when i press this key i can use ibus!
i've try my best to do the flowing:
1、in .Xresource,i add Rxvt.inputMethod: ibus
2、in .bashrc i add
export GTK_IM_MODULE="ibus"
export QT_IM_MODULE="ibus"
export XMODIFIERS=”@im=ibus”
3、in .xinitrc i add the same as .bashrc too
but i still can't use ibus in urxvt!
is there any other method?
thanks!

Bruce Hill 09-06-2011 07:00 AM

3 Attachment(s)
I'm not using Fedora, or Gnome. The iBus post install instructions with Gentoo state:
Code:

Set the following in your user startup scripts
such as .xinitrc, .xsession or .xprofile:
    export XMODIFIERS="@im=ibus"
    export GTK_IM_MODULE="ibus"
    export QT_IM_MODULE="xim"
    ibus-daemon -d -x

You do not have:
Code:

ibus-daemon -d -x
That is required for Fluxbox. Maybe it is required for fvwm also. If you try those
changes, logout of X and then restart X for them to take effect.

The following attachments show my settings for iBus to use Chinese Pinyin input.

If this doesn't solve your problem you might have a bug with iBus. Please contact
the iBus Project. The developers work for RedHat and can help you.

Maybe try the iBus Startup Trouble Shooting page.

haiyuan_victor 09-07-2011 01:52 AM

thanks!
I only add "ibus-daemon &" in my .bash_profile before, then I replace this with "ibus-daemon -d -x",now ,i can use ibus in urxvt in fvwm!

Bruce Hill 09-07-2011 06:13 AM

非常好!


All times are GMT -5. The time now is 03:59 AM.