LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Desktop (http://www.linuxquestions.org/questions/linux-desktop-74/)
-   -   How to stop thumbnails being generated? (http://www.linuxquestions.org/questions/linux-desktop-74/how-to-stop-thumbnails-being-generated-4175453437/)

Geoff_L 03-09-2013 04:12 PM

How to stop thumbnails being generated?
 
OS is Debian Squeeze, desktop is Gnome 2.

Is there a way to stop thumbnails from being created? ...

Background: The machine in question is in use as a media server (so has thousands of photos etc. stored) as well as a workstation. I back the machine up each night to an NTFS partition on an external hard drive. Unfortunately, even though I've elected to disable all thumbnailers in the Configuration Editor, I only have to browse a few folders of photos and several thousand thumbnails appear in ~/.thumbnails/normal and several hundred in ~/.thumbnails/fail/gnome-thumbnail-factory! This causes a problem because I have a set of backups (/media/usb0/backup; /media/usb0/backup2; /media/usb0/backup3;...). Before backing up, I use rm -fr to delete the oldest backup and then mv to rename the backups, thus 'shuffling' them along. However, rm can't delete all those thumbnails from the oldest backup, so the oldest backup isn't fully deleted, which makes things a little messy!

FWIW, I've got a workaround, which is to have my cron job delete all those thumbnails before starting the backup routine proper, but I'd rather find a way to stop Gnome, Nautilus, or whatever's doing it, from creating the thumbnails in the first place.

All help gratefully received.

Philip Lacroix 03-10-2013 09:39 AM

Hi,

this is not an elegant solution as it won't prevent thumbnails from being created, but you could redirect them to /tmp, replacing ~/.thumbnails/normal and ~/.thumbnails/fail/gnome-thumbnail-factory with symbolic links.

Code:

# rm -r ~/.thumbnails/normal
# ln -s -T /tmp ~/.thumbnails/normal

Code:

# rm -r ~/.thumbnails/fail/gnome-thumbnail-factory
# ln -s -T /tmp ~/.thumbnails/fail/gnome-thumbnail-factory

You could also exclude ~/.thumbnails from your backups.

Philip

John VV 03-10-2013 03:26 PM

in the gnome2 config tool
edit / preferences
click on the "preview" tab
select "never" for local and remote files
set the "only for files smaller than" to 0 kb

Geoff_L 03-14-2013 03:05 PM

Thanks for the help guys -- it's much appreciated.

FWIW, I'm uneasy about "dev-nulling" a folder as I've read somewhere that should only be done to a stream or a single file. Also, that doesn't prevent the thumbnailers from firing up, which is what I'd really like to achieve.

I guess that I've got a different Gnome Config app than John as I don't have the same options he describes. I suspect that each distro has it's own front end for a lot of stuff, and that this is one such case.

Thanks again,

Geoff

John VV 03-14-2013 04:36 PM

you do not have the standard gnome2 Nautilus
upper left click "edit" in that menu preferences
see screen shot

Geoff_L 03-15-2013 12:54 AM

Ah! I thought you meant Gnome Configuration Editor (gconf-editor, which on Debian you get to via Applications -> System Tools -> Configuration Editor) rather than Nautilus Options. Your earlier post now makes sense -- thanks.

bloody 03-15-2013 01:45 AM

I use the "link-to-tmpfs" solution, too. The thumbnail generation doesn't consume huge amounts of CPU power, and if i happen to re-visit the same image folder - plop, all thumbnails appear even faster. But when i'm done (shutdown/reboot), all thumbnails are gone, as it should be. I don't want that junk in my backups either. Also a privacy issue.


All times are GMT -5. The time now is 09:27 AM.