Latest LQ Deal: Linux Power User Bundle
Go Back > Forums > Linux Forums > Linux - Desktop
User Name
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.


  Search this Thread
Old 05-16-2013, 08:48 AM   #1
Registered: Nov 2010
Posts: 87

Rep: Reputation: 0
how to show mounted drives/filesystems on desktop


I used to have two external drives connected by USB with filesystems on them (one NTFS on ext3). Upon reboot both drives showed up on desktop. I also had them mounted in /mount with appropriate records in /etc/fstab.
I installed an expansion eSATA card and reconnected both drives through eSATA, added a couple new external eSATA drives, and added internal drives. All drives are now formatted as separate ext3 systems with mount points in /mount and new records entered into /etc/fstab.

While all drives/filesystems mount in /mount as expected, none of them shows up on desktop upon reboot. I made links and placed them on desktop. However, the nuisance is that while I can access filesystems directly from desktop now, every time I want to delete something there, an error "Not on the same filesystem" pops out. I have to go directly through mount points in /mount to do this.

How to make these drives/filesystems to mount automatically on desktop like USB drives did before?

RHEL 5.8 Gnome GUI
Old 05-16-2013, 12:41 PM   #2
Registered: Apr 2013
Location: Massachusetts
Distribution: Debian
Posts: 304

Rep: Reputation: 121Reputation: 121
I wonder if your links are breaking because the device letters (/dev/sdb, /dev/sdc, and so on) are not always the same, as sometimes happens with external drives. Mounting by label or by UUID may be part of the solution.

I have two external USB drives mounted by UUID. I found the UUIDs by looking in /dev/disk/by-uuid:
tony@peshobi:~> cd /dev/disk/by-uuid
tony@peshobi:/dev/disk/by-uuid> ls -1
tony@peshobi:/dev/disk/by-uuid> file *
003c0b79-e7d6-4af4-816b-fa34481ac327: symbolic link to `../../sdb1'
0993-CB32:                            symbolic link to `../../sdc1'
80ca8e57-c355-4416-8216-b9e2223c0019: symbolic link to `../../sda1'
d8c6a024-1249-42d9-a5e0-d2d1f47f731d: symbolic link to `../../sda2'
fef42ba4-9cb5-47e1-bd6b-ad1dc80e9841: symbolic link to `../../sda3'
My fstab, for example, includes these two lines:
UUID=003c0b79-e7d6-4af4-816b-fa34481ac327 /media/max1tb        ext4       defaults 0 0
UUID=0993-CB32 /media/sea2tb        vfat       users,gid=users,umask=0002,utf8=true,nofail 0 0
Mounting by label is another option, but I have not tried it.
Old 05-17-2013, 08:04 AM   #3
Registered: Nov 2010
Posts: 87

Original Poster
Rep: Reputation: 0
I do not feel it is a problem. When I had two USB external drives this indeed was happening occasionally, but both drives always showed up on desktop with whatever labels were assigned, and also mounted in /media. Mislabeled filesystems in /media were simply empty under orphaned names. I used UUID in /etc/fstab and this fixed the issue.

Now all new drives always mount in /media as the same devices (sdb, sdc, sdd, sde, sdf, sdg), but neither of them ever shows on desktop. I think this has something to do with differences between USB and eSATA, as any USB stick with a recognizable file system always shows on desktop when inserted. I wonder what controls this in Gnome or Nautilus.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Thunar in XFCE does not show drives mounted at startup in fstab CWood Linux - Software 29 05-19-2012 03:30 PM
Debian 5.0 - show mounted items on desktop Mithrilhall Linux - Newbie 2 03-14-2009 05:18 PM
usb mounted on ltsp client does not show on desktop lievendp Linux - Server 2 12-17-2008 07:17 AM
using Elive Gem - don't know how to show mounted USB (and other) drives on desktop bluecog6 Linux - General 0 09-16-2007 06:27 PM
FC: don't show mounted drives on desktop psychobyte Fedora 1 11-03-2006 07:50 PM

All times are GMT -5. The time now is 04:48 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration