LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Desktop (http://www.linuxquestions.org/questions/linux-desktop-74/)
-   -   how to show mounted drives/filesystems on desktop (http://www.linuxquestions.org/questions/linux-desktop-74/how-to-show-mounted-drives-filesystems-on-desktop-4175462223/)

yaximik 05-16-2013 09:48 AM

how to show mounted drives/filesystems on desktop
 
Hi,

I used to have two external drives connected by USB with filesystems on them (one NTFS on ext3). Upon reboot both drives showed up on desktop. I also had them mounted in /mount with appropriate records in /etc/fstab.
I installed an expansion eSATA card and reconnected both drives through eSATA, added a couple new external eSATA drives, and added internal drives. All drives are now formatted as separate ext3 systems with mount points in /mount and new records entered into /etc/fstab.

While all drives/filesystems mount in /mount as expected, none of them shows up on desktop upon reboot. I made links and placed them on desktop. However, the nuisance is that while I can access filesystems directly from desktop now, every time I want to delete something there, an error "Not on the same filesystem" pops out. I have to go directly through mount points in /mount to do this.

How to make these drives/filesystems to mount automatically on desktop like USB drives did before?

RHEL 5.8 Gnome GUI

Beryllos 05-16-2013 01:41 PM

I wonder if your links are breaking because the device letters (/dev/sdb, /dev/sdc, and so on) are not always the same, as sometimes happens with external drives. Mounting by label or by UUID may be part of the solution.

I have two external USB drives mounted by UUID. I found the UUIDs by looking in /dev/disk/by-uuid:
Code:

tony@peshobi:~> cd /dev/disk/by-uuid
tony@peshobi:/dev/disk/by-uuid> ls -1
003c0b79-e7d6-4af4-816b-fa34481ac327
0993-CB32
80ca8e57-c355-4416-8216-b9e2223c0019
d8c6a024-1249-42d9-a5e0-d2d1f47f731d
fef42ba4-9cb5-47e1-bd6b-ad1dc80e9841
tony@peshobi:/dev/disk/by-uuid> file *
003c0b79-e7d6-4af4-816b-fa34481ac327: symbolic link to `../../sdb1'
0993-CB32:                            symbolic link to `../../sdc1'
80ca8e57-c355-4416-8216-b9e2223c0019: symbolic link to `../../sda1'
d8c6a024-1249-42d9-a5e0-d2d1f47f731d: symbolic link to `../../sda2'
fef42ba4-9cb5-47e1-bd6b-ad1dc80e9841: symbolic link to `../../sda3'

My fstab, for example, includes these two lines:
Code:

UUID=003c0b79-e7d6-4af4-816b-fa34481ac327 /media/max1tb        ext4      defaults 0 0
UUID=0993-CB32 /media/sea2tb        vfat      users,gid=users,umask=0002,utf8=true,nofail 0 0

Mounting by label is another option, but I have not tried it.

yaximik 05-17-2013 09:04 AM

I do not feel it is a problem. When I had two USB external drives this indeed was happening occasionally, but both drives always showed up on desktop with whatever labels were assigned, and also mounted in /media. Mislabeled filesystems in /media were simply empty under orphaned names. I used UUID in /etc/fstab and this fixed the issue.

Now all new drives always mount in /media as the same devices (sdb, sdc, sdd, sde, sdf, sdg), but neither of them ever shows on desktop. I think this has something to do with differences between USB and eSATA, as any USB stick with a recognizable file system always shows on desktop when inserted. I wonder what controls this in Gnome or Nautilus.


All times are GMT -5. The time now is 05:59 PM.