LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 04-28-2008, 12:09 PM   #1
debianlam
LQ Newbie
 
Registered: Jan 2007
Posts: 21

Rep: Reputation: 0
Exclamation how to install ethernet modem HUAWEI SmartAX MT880


hi
i connected my ethernet modem HUAWEI SmartAX MT880 to my machine that turned on debian i want to know how can i install this modem
and how can i connect to internet

any help is welcome
best regards
debianlam
 
Old 04-28-2008, 12:58 PM   #2
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
Consult your modem documentation ...

Usually, you configure your network card for DHCP, and log-in to the modem using a browser. The modem's IP is usually 10.1.1.1 or 192.168.1.1
 
Old 04-28-2008, 02:11 PM   #3
debianlam
LQ Newbie
 
Registered: Jan 2007
Posts: 21

Original Poster
Rep: Reputation: 0
thanks for answer
- the documentation available that i have is on windows operating system

- but the modem is configured on windows and it have ip adress 192.168.1.1
i want to know wich steps to follow for create a new internet connection

thanks
debianlam
 
Old 04-28-2008, 10:50 PM   #4
deepclutch
Member
 
Registered: Nov 2004
Distribution: Debian Testing+Sid
Posts: 699
Blog Entries: 1

Rep: Reputation: 32
use bridge mode to connect.use pppoeconf .
 
Old 04-29-2008, 12:15 AM   #5
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
Networks are normally set up for DHCP by default - have you tried just browsing?
From a terminal, enter "ping 192.168.1.1" - what happens?

Did you run an install CD to get it to work in windows, or did it work out of the box?
The windows documentation will tell you if you need a static IP or if it uses DHCP. It will tell you how to change it in the part where it describes the setup interface.

Use the setup interface in windows to verify that it is using DHCP rather than "bridge" mode. (Though that can be got working too...)

In linux - set your nic to use DHCP - use whatever network tool you have installed - look in your menus!

Open firefox:
It the address bar, enter "192.168.1.1" to access the setup interface.
You shouldn't need to - just browse.
 
Old 04-29-2008, 05:06 AM   #6
debianlam
LQ Newbie
 
Registered: Jan 2007
Posts: 21

Original Poster
Rep: Reputation: 0
Thumbs up thanks

thanks for all

finally the problem has solved
i used pppoeconf and i wrote the necessary configuration ( phone number , password )
and when the configuration finished l internet is availbale

best regards
debianlam
 
Old 03-11-2011, 01:53 AM   #7
Jamie148
LQ Newbie
 
Registered: Mar 2011
Posts: 6

Rep: Reputation: 0
Same problem same router on Ubuntu

Hi Debianlam and everyone else,

Do i need to post another thread for the same? If so, sorry.

yes, I saw that it's been well over six months but I have the same router SmartAX MT880d with ethernet, and the exact same problem, that is no internet even though I can successfully reach the modem settings page by entering 192.168.1.1 in Firefox. Sorry if I don't use the right (technical) terminology to express my issue. English is not my mother tongue.

I'm a total noob in ubuntu. My internet works great in Windows but does not work in ubuntu.

For 2 weeks, I've kept reading on the web and forums and the ubuntuguide.org to name a few but to no avail. Now I see no other solution but to ask for help.

My problem is that as a noob, I can't find a way to put the right digits in the right place because I don't know what numbers I need to put in what files (eg: do i need to use dhcp? or a static ip address?...No clue whatsoever... I'm confused between putting figures in the wrong spaces. For example, is the modem/router's IP exactly 192.168.1.1 for Huawei Smart AXMT880d modem?? Is the subnet 255.255.255.0? Gateway 192.168.1.1.

I'm confused as I can also see a different IP starting with 155131***** (is it an account number? no clue again) on my contract with Huawei (a Chinese ISP).
Apart from calling 911, what other numbers do i need to put in and where? How do I check that all the numbers have been entered correctly in every appropriate space before trying to connect the Internet??

Could anyone help me out with my ignorance?

many thx!

J
 
Old 03-14-2011, 05:27 PM   #8
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
have you tried using pppoeconf as suggested in post #4? (this is the program that puts the right digits in the right place - you don't normally need this because Ubuntu is pretty good at autodetecting the right settings)

otherwise you just have to hunt through the configuration, make sure your modem is set to use DHCP to automatically assign IP addresses and that there is nothing in there restricting its operation to windows only. Hopefully debianlam is still watching and can be specific about the configuration screens but same worthy just ran pppoeconf and followed the instruction it gave.
 
Old 03-15-2011, 04:46 AM   #9
Jamie148
LQ Newbie
 
Registered: Mar 2011
Posts: 6

Rep: Reputation: 0
Hi

Hi Simon Bridge, I'll let you know asap. I'm at work. Cheers
 
Old 03-15-2011, 09:59 PM   #10
Jamie148
LQ Newbie
 
Registered: Mar 2011
Posts: 6

Rep: Reputation: 0
Still not solved

Hi Simon Bridge,

Just to tell you that I used ppoeconf as per the post above and could successfully install it. But it unfortunately didn't work for me. Just didn't return anything. No network connection after that.

fyi, I also have this post on:
http://askubuntu.com/questions/30172...auto-detection

I've been testing all possible actions by now I guess.
But it has to be a matter of a button that I haven't come across or pressed so far.

I'll keep you posted. And if you have any suggestion, please do get back to me.
Many thanks for your reply,
 
Old 03-15-2011, 10:04 PM   #11
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
Jamie, Your last post makes contradictory-seeming statements. Please be specific.

<reads askubuntu link>
You appear to have DHCP enabled according to Windows, which will be why you have been able to talk to the modem.
There was a suggestion to disable IPv6 - did you try this?

Your last post seems to indicate you had a hang/crash - to check your onboard ethernet enter ifconfig in a terminal.
If you have disabled selinux, apparmour and do not use ipv6, and you can talk to the modem, then the problem does not exist at the modem end - either the modem or your DSL provider is blocking you. An interesting approach is to try a different modem/router ... borrow one ... or use someone elses provider.

Last edited by Simon Bridge; 03-15-2011 at 10:17 PM.
 
Old 03-16-2011, 01:53 AM   #12
Jamie148
LQ Newbie
 
Registered: Mar 2011
Posts: 6

Rep: Reputation: 0
update

Jamie, Your last post makes contradictory-seeming statements. Please be specific.

<reads askubuntu link>
You appear to have DHCP enabled according to Windows, which will be why you have been able to talk to the modem.
There was a suggestion to disable IPv6 - did you try this?

Your last post seems to indicate you had a hang/crash - to check your onboard ethernet enter ifconfig in a terminal.
If you have disabled selinux, apparmour and do not use ipv6, and you can talk to the modem, then the problem does not exist at the modem end - either the modem or your DSL provider is blocking you. An interesting approach is to try a different modem/router ... borrow one ... or use someone elses provider.


"""""""""""""""""""""""""""""""""""

You're right Simon, the confusion comes from there (I think):

Before I disabled IPv6, ipconfig /all in Windows showed: DHCP is on for Ethernet Adapter Local Area Connection
After I disabled IPv6 today, ipconfig /all in Windows shows: DHCP is off for Ethernet Adapter Local Area Connection.

I'll post back about your second paragraph above. I need to check that on Ubuntu. Cheers
 
Old 03-16-2011, 02:31 AM   #13
Jamie148
LQ Newbie
 
Registered: Mar 2011
Posts: 6

Rep: Reputation: 0
Arppamor is uninstalled. IPv6 uninstalled. Selinux still installed.

Do you mean I have to uninstall selinux?

If so, is it sudo apt-get remove selinux? Selinux didn't want to uninstall earlier because it has dependencies.
 
Old 03-17-2011, 09:51 AM   #14
Jamie148
LQ Newbie
 
Registered: Mar 2011
Posts: 6

Rep: Reputation: 0
I just managed to get it working with pppoeconf. Many thanks to all of you.
Here is the solution:
http://askubuntu.com/questions/30172...on/30763#30763
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Trouble connecting to internet using BSNL ADSL SmartAX MT841 (HUAWEI) modem. atriya Linux - Networking 5 11-21-2007 03:03 PM
huawei mt880 router-other users can hack into mine?! deepclutch Linux - Networking 2 05-18-2007 10:45 AM
SmartAX MT2 ethernet modem connection problem tm2383 Mandriva 1 04-08-2007 05:24 PM
Huawei SmartAX MT-882 ADSL router works well jimux LinuxQuestions.org Member Success Stories 0 03-22-2007 06:52 AM
The Modem "HUAWEI SmartAX MT810" doesn't work pevets Linux - Hardware 2 01-11-2007 03:27 PM


All times are GMT -5. The time now is 09:15 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration