LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices



Reply
 
Search this Thread
Old 07-29-2009, 10:47 AM   #1
wanas
Member
 
Registered: Aug 2008
Location: Alexandria, Egypt
Distribution: Ubuntu 10.10
Posts: 158

Rep: Reputation: 16
Question how to fix this > guest session allow opening my drives ?


I use guest session to let others use my computer without opening my personal data on my drives, it was working okay on ubuntu 9.04 till one day when I open the guest session I see my drives mounted on the desktop and allowed to be opened , I tried to make unprivileged user the same problem accure

Is there a way to make the guest session works like before ?
 
Old 07-30-2009, 08:49 AM   #2
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655
Does Ubuntu use PolicyKit? If so look at "polkit-auth --user guest". There are a couple policies about mounting drives. One for fixed partitions, and the other for removable media. There is also a gnome tool for managing policies: polkit-gnome-authorization

Also what are the permissions of your home directory. Look at "ls -ld /home/*". What is your default group?
What are the permissions of "other". If you have a partition with your personal data that isn't in /home, you could mount it inside your home directory. Remember that even if the mount point isn't visiable on the desktop, they can still enter it and read files if the permissions allow it.
 
Old 08-05-2009, 01:14 AM   #3
wanas
Member
 
Registered: Aug 2008
Location: Alexandria, Egypt
Distribution: Ubuntu 10.10
Posts: 158

Original Poster
Rep: Reputation: 16
I didnt know how to use what you said :S, thanks for trying to help me
any other suggestions
 
Old 08-05-2009, 06:58 PM   #4
blackhole54
Senior Member
 
Registered: Mar 2006
Posts: 1,896

Rep: Reputation: 61
I am not clear what drives you are talking about that the guest can see. If you are concerned about the guest seeing the files in your home directory, you can change permissions on your home directory to prevent that. The guest may still see icons on his desktop, but he won't be able to access your home directory. This would be a good idea anyway, because as jschiwal pointed out, the guest doesn't need icons to be able to access your home directory if permissions allow it (unless the guest account is in a chroot jail).

You can restrict permissions on your home directory from the command line with:

Code:
chmod 700 ~
To do it with a GUI, open up your file manager, click the up arrow in the tool bar and right click the folder for your account. Select properties and go to the tab that says permissions. Under "folder access" for both "group" and "other" select "none".

Either of these methods will prevent the guest from accessing your home directory regardless of absence/presence of icons. I can't help you with the other things jschiwal talked about since I don't have a current enough installation of Ubuntu. But you can probably find out what he meant by doing an Internet search on the terms he used.
 
Old 08-05-2009, 08:13 PM   #5
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655
Could you indicate which drives. What filesystem did you use when you formatted their partitions, and where they are mounted? Are they external or internal drives? If they don't contain system directories, you can: mount them inside your home directory so they can't reach the mount points, and change the ownership & permissions so you have exclusive access.

It they are external drives, using the UUID or LABEL of the filesystem instead of the device with user option, you can restrict access to them. For FAT32 & NTFS filesystem, also use the "uid", "gid" and "user" mount options. Then "your" system will always mount them with the same ownership & permissions, giving you exclusive access on your system.
 
  


Reply

Tags
gnome, guest, session, ubuntu


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Is there a Guest session in debian like the one on ubuntu? wanas Debian 8 02-07-2009 12:04 AM
Kanotix in VMplayer, guest drives are missing stoppage Linux - General 2 10-19-2007 11:58 AM
Strange X session - need to fix it Thaidog Linux - General 1 12-21-2006 04:43 PM
Opening new session from Fluxbox... pAn1k Linux - Software 3 12-19-2004 08:16 AM
Netscape only session for guest rvilarl Linux - General 2 10-05-2003 02:38 PM


All times are GMT -5. The time now is 01:05 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration