LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Desktop (http://www.linuxquestions.org/questions/linux-desktop-74/)
-   -   How to enhance responsiveness? (http://www.linuxquestions.org/questions/linux-desktop-74/how-to-enhance-responsiveness-580395/)

Uqbar 08-28-2007 08:00 AM

How to enhance responsiveness?
 
Hi all.
Everytime I need to do some heavier load task the system becomes unresponsive even to do simple text editing.
For eaxmple, rebuilding large indexes in a DB, copying large files, burning optical media (thus non interactive tasks) make all other interactive task not responding even for minutes.
Now, as modern hardware has plenty of CPU cycldes, memory and disk space.
Interactive processes use a very small amount of CPU cycles and other system resources and a common expectation is to have a good responsiveness provided decent hardware.
Is there a way to enhance the responsiveness by, say, teaking some /proc or /sys parameter?
Infact I wouldn't mind if a file copy takes 1 hour or 1 hour and 15 seconds. But I'd like to be able to edit my source code during the DB indexes rebuild or DVD backup process.

Many thanks in advance.

MS3FGX 08-28-2007 08:14 AM

What distribution and kernel are you running?

Generally speaking, some distributions are simply "heavier" than others, and require some tweaking to get full responsiveness. For example, Ubuntu would perform much slower than Slackware when installed on the same machine, simply because Ubuntu has so much going on by default, while Slackware keeps only to the basics.

As for the kernel, you will generally get a big performance boost by compiling your own kernel for your own hardware. This will give you a much more efficient operating system over using the stock kernels which are designed to be widely compatible rather than efficient.

Uqbar 08-28-2007 09:26 AM

Yes, I run KUbuntu 7.04 (Feisty Fawn).
The point is that low responsiveness seems to be related to the skeduler itself rather than the bloat of processes.
Even if I switch XWindows off, I don't solve my problems.
So I would say the problem is in the schedules.
When I don't need the intyeractive processes like the shell+vi, the systems is very fast in my perception.
The troubles come with interactive tasks.

choogendyk 08-28-2007 09:43 AM

You've also mentioned "modern hardware" without giving any of your specifics. What is your hardware configuration. Is it possible it needs something more? Or that something is not configured correctly? Or entirely compatible? Do the system log files show anything? Repeated hardware errors for example?

Shell and vi should be very fast.

Uqbar 08-28-2007 10:43 AM

Modern hardware means 1GB RAM, Core Duo T2400@1.83GHz.
All hardware is working accordingly to the dmesg output.
In any case, if I install Windows XP I get a system that is much more responsive. So i would exclude the hardware.

gampy 08-29-2007 05:49 AM

Are basics covered, like DMA mode for your drives? Maybe that's irrelevant if you're using SATA drives.

Uqbar 08-29-2007 08:04 AM

Maybe you hit the spot.
I had set the configuration files but it seems it's not working:

root@home:/home/enzo# hdparm /dev/sda

/dev/sda:
IO_support = 0 (default 16-bit)
readonly = 0 (off)
readahead = 256 (on)
geometry = 14593/255/63, sectors = 234441648, start = 0
root@home:/home/enzo# hdparm -c 1 -d 1 /dev/sda

/dev/sda:
setting 32-bit IO_support flag to 1
HDIO_SET_32BIT failed: Invalid argument
setting using_dma to 1 (on)
HDIO_SET_DMA failed: Inappropriate ioctl for device
IO_support = 0 (default 16-bit)


So now I need to face this other problem with Ubuntu Feisty!

Thanks gampy.

auxsvr 09-05-2007 09:44 AM

Are you using a 64 bit kernel? If yes, it's a well-known currently unresolved problem with the scheduler.

Uqbar 09-05-2007 09:52 AM

I'd be using 32-bit code:
Linux version 2.6.20-16-generic (root@terranova) (gcc version 4.1.2 (Ubuntu 4.1.2-0ubuntu4)) #2 SMP Fri Aug 31 00:55:27 UTC 2007

Maybe it's another bug!


All times are GMT -5. The time now is 07:20 PM.