LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
LinkBack Search this Thread
Old 02-19-2008, 10:01 PM   #1
jaredhanks
LQ Newbie
 
Registered: May 2006
Posts: 23

Rep: Reputation: 15
How to disable F1 (yelp) in X (gnome)


Hello,

I would like to disable Help from coming up when pressing F1 on the X screen (I'm using gnome). I've found a few solutions for gnome-terminal, but when I have no applications open I can press F1 and up comes a Help window that says "Desktop". I'm using this screen as a

Any help is appreciated.

Thanks,
Jared
 
Old 02-20-2008, 06:30 AM   #2
Su-Shee
Member
 
Registered: Sep 2007
Location: Berlin
Distribution: Slackware
Posts: 509

Rep: Reputation: 41
Open the keyboard-shortcut config dialog and just disable all keyboard shortcuts you don't like.

I've forgotten how this tool is actually called, but it's somewhere in the usal gnome menu where all other click-me config stuff like theme and background color etc. is listed.

Possibly it can also be disabled from within the gconf-stuff - via gconf edtior or directly in the XML files.
 
Old 02-20-2008, 12:58 PM   #3
jaredhanks
LQ Newbie
 
Registered: May 2006
Posts: 23

Original Poster
Rep: Reputation: 15
I checked gconf-editor and found a few "help" keys, but none of them were set to F1. Any other spots I can check?
 
Old 02-21-2008, 04:03 AM   #4
Su-Shee
Member
 
Registered: Sep 2007
Location: Berlin
Distribution: Slackware
Posts: 509

Rep: Reputation: 41
As mentioned, klick it in the keyboard configuration dialogue - the actual application is called "gnome-keybinding-properties" and "launch help browser" is the keyword to look for.

I simply have forgotten how the menu entry is called, so call "gnome-keybinding-properties" on the command line in some xterminal and the little GUI configuration application will pop up.
 
Old 05-04-2010, 09:13 AM   #5
shrewmouse
LQ Newbie
 
Registered: Oct 2006
Posts: 2

Rep: Reputation: 1
Disable help in terminal not gnome

I'm posting this in order to provide an answer to all of you that are searching for the answer to Su-Shee's original question.

If you're sick of seeing the "help" dialog pop up every time you accidental hit the F1 key (especially when you move from a standard key board to an IBM/Lenovo key board) then you need to disable the "Keyboard Shortcuts" defined in your gnome terminal, not the system wide "Keyboard Shortcuts".

1. Bring up a terminal
2. From your terminal's menu system Edit->Keyboard Shortcuts...
3. Set Help->Contents to "Disabled"

Done
 
1 members found this post helpful.
Old 12-04-2010, 02:03 PM   #6
giraffedata
LQ Newbie
 
Registered: Oct 2010
Location: San Jose, California
Distribution: custom
Posts: 6

Rep: Reputation: 0
use gconf-editor

1. Bring up a terminal
2. From your terminal's menu system Edit->Keyboard Shortcuts...
3. Set Help->Contents to "Disabled"



This didn't work for me. I got stuck at Step 3, where though I can see F1 is set to Help->Contents, I see no way to change it. If I click a few times, I get a text entry box, but typing in it has no visible effect. The help for this dialogue does not acknowledge that it is possible to change the bindings.

Maybe the change function is missing on some systems. I have a Ubuntu 10.04 Netbook remix.

But I found another way:

1. Run gconf-editor, by typing its name at a shell prompt in a terminal window (any terminal window -- the effect is system-wide).

2. Navigate to apps->gnome-terminal->keybindings.

3. Find "help" in the list and click on it, whereupon it lets me type "disabled" to replace "F1".


By the way, the F1 binding is much worse than just an annoyance when you accidentally hit F1. Many programs running in a terminal understand F1 themselves, and with F1 intercepted by Gnome, there is no way at all to get F1 to the application. And it's inconsistent with all the other F keys, which pass through to the application. As far as I'm concerned, F1 should always be disabled in Terminal.
 
Old 12-04-2010, 04:14 PM   #7
Latios
Member
 
Registered: Dec 2010
Distribution: Arch
Posts: 115

Rep: Reputation: 21
Try to set something else to F1. In KDE (and maybe gnome too ?) it would come up with a notice that it conflicts with an existing key shortcut, and give option to disable the existing one. Do it and then disable the new shortcut too
 
Old 12-05-2010, 07:07 PM   #8
giraffedata
LQ Newbie
 
Registered: Oct 2010
Location: San Jose, California
Distribution: custom
Posts: 6

Rep: Reputation: 0
It isn't clear what that solves. Anyone who can set something else to F1 or disabled could also, more simply, set HELP to something other than F1 or disabled, right?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to disable gnome-keyring? fannymites Linux - Software 19 12-12-2012 08:40 AM
Disable F1 in Gnome? tvmaly Linux - General 0 04-20-2005 03:02 PM
how to disable GNOME on Linux? htm Linux - Software 12 08-19-2004 09:56 AM
Disable Gnome? cmoloney Linux - General 2 06-03-2003 03:13 AM
Disable Start-here in gnome???? Satriani Linux - Newbie 2 05-29-2003 05:17 PM


All times are GMT -5. The time now is 04:53 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration