LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 09-27-2006, 03:44 PM   #1
dravenloft
Member
 
Registered: Jun 2005
Distribution: Debian
Posts: 68

Rep: Reputation: 15
How do I fix Alt-Tab in KDE?


I'm running Debian etch with latest KDE 3.5.4. At some point instead of the lovely traditional box with the list of open windows when I press alt+tab or atl+shift+tab, it simply switches me immediately back and forth between the two most recently used windows.

I'd really prefer to actually fix this if anyone knows how it might possibly be done. I really hate deleting ~/.kde and then having to set my desktop up (a fix I've discovered works well for KDE issues when I'm too impatient/lazy to find a real solution).
 
Old 09-27-2006, 06:39 PM   #2
theNbomr
LQ 5k Club
 
Registered: Aug 2005
Distribution: OpenSuse, Fedora, Redhat, Debian
Posts: 5,395
Blog Entries: 2

Rep: Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903
Quote:
Originally Posted by dravenloft
I'd really prefer to actually fix this if anyone knows how it might possibly be done. I really hate deleting ~/.kde and then having to set my desktop up (a fix I've discovered works well for KDE issues when I'm too impatient/lazy to find a real solution).
Well, how about a compromise? What has worked for me in the past is to create a temporary user, and stratup KDE as that user. Do just a bit of configuration, and then cut & paste the appropriate parts of whatever config file into your own working configuration. Then just delete all traces tof the temporary

--- rod.
 
Old 09-27-2006, 07:37 PM   #3
dravenloft
Member
 
Registered: Jun 2005
Distribution: Debian
Posts: 68

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by theNbomr
Well, how about a compromise? What has worked for me in the past is to create a temporary user, and stratup KDE as that user. Do just a bit of configuration, and then cut & paste the appropriate parts of whatever config file into your own working configuration. Then just delete all traces tof the temporary

--- rod.
I can just delete the dir as quickly. I was hoping for an alternative. thanks though.
 
Old 09-29-2006, 04:52 AM   #4
noranthon
Member
 
Registered: Apr 2006
Location: Australia
Distribution: PCLinuxOS with Xfce
Posts: 301

Rep: Reputation: 30
Are you allowed to use the gui tools if you're a Debian user?

If so, keyboard shortcuts are in the accessibility section of the Kde part of the System configuration menu. Perhaps you have the kde control centre?

Edit: Quite by chance, I came across a reference which may be preferred by people who like to do things the difficult and time-consuming way: man:/xmodmap

Last edited by noranthon; 09-29-2006 at 05:12 AM.
 
Old 09-29-2006, 07:25 AM   #5
dravenloft
Member
 
Registered: Jun 2005
Distribution: Debian
Posts: 68

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by noranthon
Are you allowed to use the gui tools if you're a Debian user?

If so, keyboard shortcuts are in the accessibility section of the Kde part of the System configuration menu. Perhaps you have the kde control centre?

Edit: Quite by chance, I came across a reference which may be preferred by people who like to do things the difficult and time-consuming way: man:/xmodmap
No, the problem isn't what the window cycle hotkey is. That Ihave changed in the past for amusement. The problem is that the window cycle function isn't cycling windows... it's just swapping between the two most recently used windows.
 
Old 09-29-2006, 07:06 PM   #6
noranthon
Member
 
Registered: Apr 2006
Location: Australia
Distribution: PCLinuxOS with Xfce
Posts: 301

Rep: Reputation: 30
The keybindings are stored in ~/.kde/share/config/kdeglobals but that probably contains the correct assignment. FWIW, I would try a different assignment until the next reboot, then change back.

Have you by any chance de-selected the option on the Window behaviour module "Traverse windows on all desktops"? That would result in alt+tab only traversing windows on the visible desktop.

Kde also has a keyboard layout module with a tab Xkboptions.

Last edited by noranthon; 09-29-2006 at 07:30 PM.
 
Old 01-13-2007, 10:34 PM   #7
nym
LQ Newbie
 
Registered: Oct 2006
Distribution: SuSE 10.1, Ubuntu 6.10
Posts: 4

Rep: Reputation: 0
I'd like to reopen this thread as I am experiencing the (mostly^1) same problem as the OP: 'walking' through open applications on one desktop with "alt-tab" only toggles between the current and most recently used applications. (I have only one desktop in use.)

KDE version 3.5.5, Kubuntu 6.10, kernel 2.6.27-10-generic.

I expected "alt-tab" to popup a small window with the apps list, highlighting the 'next' open app. Pressing "alt-tab" again would highlight/select the 2nd 'next' open app, etc.

^1: This actually works on the REVERSE action "shift-alt-tab", but not on the forward action. Having two or ten apps open makes no difference.

As for keyboard shortcuts, the defaults are in place, as listed below. I added the "Win+Tab" 2nd/alternative method as part of troubleshooting (it makes no difference).

from: /home/<user>/.kde/share/config/kdeglobals
Code:
Walk Through Windows=default(Alt+Tab);Win+Tab         <--this FAILS
Walk Through Windows (Reverse)=default(Alt+Shift+Tab) <--this WORKS
I've found nothing at the KDE Bugs site (http://bugs.kde.org/) and have browsed through every item in the KDE Control Center (I think).

Any suggestions or solutions?

Thx for reading.
 
Old 03-28-2007, 01:17 PM   #8
gdiebel
LQ Newbie
 
Registered: Mar 2007
Posts: 1

Rep: Reputation: 0
same issue except with walk through desktops

I experience the same behavior as well under 3.5.6 kubuntu edgy, except in my case with walk through desktops.

Quote:
Originally Posted by nym
I'd like to reopen this thread as I am experiencing the (mostly^1) same problem as the OP: 'walking' through open applications on one desktop with "alt-tab" only toggles between the current and most recently used applications. (I have only one desktop in use.)

KDE version 3.5.5, Kubuntu 6.10, kernel 2.6.27-10-generic.

I expected "alt-tab" to popup a small window with the apps list, highlighting the 'next' open app. Pressing "alt-tab" again would highlight/select the 2nd 'next' open app, etc.

^1: This actually works on the REVERSE action "shift-alt-tab", but not on the forward action. Having two or ten apps open makes no difference.

As for keyboard shortcuts, the defaults are in place, as listed below. I added the "Win+Tab" 2nd/alternative method as part of troubleshooting (it makes no difference).

from: /home/<user>/.kde/share/config/kdeglobals
Code:
Walk Through Windows=default(Alt+Tab);Win+Tab         <--this FAILS
Walk Through Windows (Reverse)=default(Alt+Shift+Tab) <--this WORKS
 
Old 09-19-2007, 02:56 PM   #9
_sc_
LQ Newbie
 
Registered: Sep 2007
Posts: 3

Rep: Reputation: 0
one thing i've learned about this is that people who notice the problem are people who like to use the right alt-key when they are performing their Alt+Tab key combination

my keyboard, like many others, has two alt keys, a left and a right, and they do not act the same when being used to create an Alt+Tab combination -- in KDE (3.5.5) the [left]alt-tab cycles through all windows but [right]alt-tab flips between the last two only

some idiot somewhere decided it would be cool to make the two act different, simply because he could

i will continue looking for a way to make [right]alt-tab cycle through all windows -- if i find one i will post it here -- please do the same for me...

sc
 
Old 10-20-2007, 05:06 PM   #10
wakusrgh
LQ Newbie
 
Registered: Oct 2007
Posts: 1

Rep: Reputation: 0
I had the same problem... Deleting the following line from your ~/.kde/share/config/kwinrc should restore your switch box!
Code:
AltTabStyle=CDE
 
Old 10-21-2007, 06:00 AM   #11
dravenloft
Member
 
Registered: Jun 2005
Distribution: Debian
Posts: 68

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by wakusrgh View Post
I had the same problem... Deleting the following line from your ~/.kde/share/config/kwinrc should restore your switch box!
Code:
AltTabStyle=CDE
cool. thanks.
 
Old 10-28-2007, 04:11 PM   #12
nostracosa
LQ Newbie
 
Registered: Aug 2005
Posts: 24

Rep: Reputation: 15
You have to have selected "Click on focus" or "Focus under mouse" option on windows behaviour menu in order to have the windows list menu shown. Otherwise, use the ALT + F5 shortcut.

Last edited by nostracosa; 10-28-2007 at 04:13 PM.
 
Old 03-10-2008, 08:21 PM   #13
roguetr
LQ Newbie
 
Registered: Mar 2008
Posts: 2

Rep: Reputation: 0
It's in Settings -> Desktop -> Window Behavior -> Navigation ... listed as "Show window list while switching windows".

Enabling this will allow alt+tab window previews to be displayed while switching.
 
Old 05-12-2008, 11:03 PM   #14
bforbes
LQ Newbie
 
Registered: Apr 2006
Posts: 27

Rep: Reputation: 15
I'm using Gutsy Gibbon, and I don't get the window list when I hit Alt-Tab. In window behavior, "Show window list while switching windows" is checked, but is greyed out. Is there another option I can try?
 
Old 05-14-2008, 12:02 AM   #15
roguetr
LQ Newbie
 
Registered: Mar 2008
Posts: 2

Rep: Reputation: 0
Does it switch applications when hitting alt+tab?

If not, make sure you are using an applicable keyboard shortcut scheme.

I generally don't change much in KDE except to disable all effects and load compiz-fuzion and emerald. Selecting the keyboard scheme and ticking that box are about all the post-modifications I make.

I use ArchLinux http://www.archlinux.org
 
  


Reply

Tags
desktop, kde, kubuntu


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
FC 4. Modify ALT+TAB behaviour to CTRL+TAB xtracto Linux - Software 1 09-22-2005 02:06 PM
KDE borderless app, that ALT F3 wont fix meshsmooth Linux - General 0 07-15-2004 07:24 PM
KDE task switching (alt-tab) problem, also KDE XMMS problem (seperate problems) Cohobin Linux - Software 4 06-26-2004 05:47 AM
alt tab in kde? windsok Slackware 10 11-30-2003 02:56 AM
Change size of icons on Alt+tab for KDE via RH9 robertmarkbram Linux - Software 0 10-13-2003 08:48 PM


All times are GMT -5. The time now is 01:42 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration