LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Desktop (http://www.linuxquestions.org/questions/linux-desktop-74/)
-   -   How do I fix Alt-Tab in KDE? (http://www.linuxquestions.org/questions/linux-desktop-74/how-do-i-fix-alt-tab-in-kde-487501/)

dravenloft 09-27-2006 03:44 PM

How do I fix Alt-Tab in KDE?
 
I'm running Debian etch with latest KDE 3.5.4. At some point instead of the lovely traditional box with the list of open windows when I press alt+tab or atl+shift+tab, it simply switches me immediately back and forth between the two most recently used windows.

I'd really prefer to actually fix this if anyone knows how it might possibly be done. I really hate deleting ~/.kde and then having to set my desktop up (a fix I've discovered works well for KDE issues when I'm too impatient/lazy to find a real solution).

theNbomr 09-27-2006 06:39 PM

Quote:

Originally Posted by dravenloft
I'd really prefer to actually fix this if anyone knows how it might possibly be done. I really hate deleting ~/.kde and then having to set my desktop up (a fix I've discovered works well for KDE issues when I'm too impatient/lazy to find a real solution).

Well, how about a compromise? What has worked for me in the past is to create a temporary user, and stratup KDE as that user. Do just a bit of configuration, and then cut & paste the appropriate parts of whatever config file into your own working configuration. Then just delete all traces tof the temporary

--- rod.

dravenloft 09-27-2006 07:37 PM

Quote:

Originally Posted by theNbomr
Well, how about a compromise? What has worked for me in the past is to create a temporary user, and stratup KDE as that user. Do just a bit of configuration, and then cut & paste the appropriate parts of whatever config file into your own working configuration. Then just delete all traces tof the temporary

--- rod.

I can just delete the dir as quickly. I was hoping for an alternative. thanks though.

noranthon 09-29-2006 04:52 AM

Are you allowed to use the gui tools if you're a Debian user? :D ;)

If so, keyboard shortcuts are in the accessibility section of the Kde part of the System configuration menu. Perhaps you have the kde control centre?

Edit: Quite by chance, I came across a reference which may be preferred by people who like to do things the difficult and time-consuming way: man:/xmodmap

dravenloft 09-29-2006 07:25 AM

Quote:

Originally Posted by noranthon
Are you allowed to use the gui tools if you're a Debian user? :D ;)

If so, keyboard shortcuts are in the accessibility section of the Kde part of the System configuration menu. Perhaps you have the kde control centre?

Edit: Quite by chance, I came across a reference which may be preferred by people who like to do things the difficult and time-consuming way: man:/xmodmap

No, the problem isn't what the window cycle hotkey is. That Ihave changed in the past for amusement. The problem is that the window cycle function isn't cycling windows... it's just swapping between the two most recently used windows.

noranthon 09-29-2006 07:06 PM

The keybindings are stored in ~/.kde/share/config/kdeglobals but that probably contains the correct assignment. FWIW, I would try a different assignment until the next reboot, then change back. :twocents:

Have you by any chance de-selected the option on the Window behaviour module "Traverse windows on all desktops"? That would result in alt+tab only traversing windows on the visible desktop.

Kde also has a keyboard layout module with a tab Xkboptions. :study:

nym 01-13-2007 10:34 PM

I'd like to reopen this thread as I am experiencing the (mostly^1) same problem as the OP: 'walking' through open applications on one desktop with "alt-tab" only toggles between the current and most recently used applications. (I have only one desktop in use.)

KDE version 3.5.5, Kubuntu 6.10, kernel 2.6.27-10-generic.

I expected "alt-tab" to popup a small window with the apps list, highlighting the 'next' open app. Pressing "alt-tab" again would highlight/select the 2nd 'next' open app, etc.

^1: This actually works on the REVERSE action "shift-alt-tab", but not on the forward action. Having two or ten apps open makes no difference.

As for keyboard shortcuts, the defaults are in place, as listed below. I added the "Win+Tab" 2nd/alternative method as part of troubleshooting (it makes no difference).

from: /home/<user>/.kde/share/config/kdeglobals
Code:

Walk Through Windows=default(Alt+Tab);Win+Tab        <--this FAILS
Walk Through Windows (Reverse)=default(Alt+Shift+Tab) <--this WORKS

I've found nothing at the KDE Bugs site (http://bugs.kde.org/) and have browsed through every item in the KDE Control Center (I think).

Any suggestions or solutions?

Thx for reading.

gdiebel 03-28-2007 01:17 PM

same issue except with walk through desktops
 
I experience the same behavior as well under 3.5.6 kubuntu edgy, except in my case with walk through desktops.

Quote:

Originally Posted by nym
I'd like to reopen this thread as I am experiencing the (mostly^1) same problem as the OP: 'walking' through open applications on one desktop with "alt-tab" only toggles between the current and most recently used applications. (I have only one desktop in use.)

KDE version 3.5.5, Kubuntu 6.10, kernel 2.6.27-10-generic.

I expected "alt-tab" to popup a small window with the apps list, highlighting the 'next' open app. Pressing "alt-tab" again would highlight/select the 2nd 'next' open app, etc.

^1: This actually works on the REVERSE action "shift-alt-tab", but not on the forward action. Having two or ten apps open makes no difference.

As for keyboard shortcuts, the defaults are in place, as listed below. I added the "Win+Tab" 2nd/alternative method as part of troubleshooting (it makes no difference).

from: /home/<user>/.kde/share/config/kdeglobals
Code:

Walk Through Windows=default(Alt+Tab);Win+Tab        <--this FAILS
Walk Through Windows (Reverse)=default(Alt+Shift+Tab) <--this WORKS



_sc_ 09-19-2007 02:56 PM

one thing i've learned about this is that people who notice the problem are people who like to use the right alt-key when they are performing their Alt+Tab key combination

my keyboard, like many others, has two alt keys, a left and a right, and they do not act the same when being used to create an Alt+Tab combination -- in KDE (3.5.5) the [left]alt-tab cycles through all windows but [right]alt-tab flips between the last two only

some idiot somewhere decided it would be cool to make the two act different, simply because he could

i will continue looking for a way to make [right]alt-tab cycle through all windows -- if i find one i will post it here -- please do the same for me...

sc

wakusrgh 10-20-2007 05:06 PM

I had the same problem... Deleting the following line from your ~/.kde/share/config/kwinrc should restore your switch box!
Code:

AltTabStyle=CDE

dravenloft 10-21-2007 06:00 AM

Quote:

Originally Posted by wakusrgh (Post 2931059)
I had the same problem... Deleting the following line from your ~/.kde/share/config/kwinrc should restore your switch box!
Code:

AltTabStyle=CDE

cool. thanks.

nostracosa 10-28-2007 04:11 PM

You have to have selected "Click on focus" or "Focus under mouse" option on windows behaviour menu in order to have the windows list menu shown. Otherwise, use the ALT + F5 shortcut.

roguetr 03-10-2008 08:21 PM

It's in Settings -> Desktop -> Window Behavior -> Navigation ... listed as "Show window list while switching windows".

Enabling this will allow alt+tab window previews to be displayed while switching.

bforbes 05-12-2008 11:03 PM

I'm using Gutsy Gibbon, and I don't get the window list when I hit Alt-Tab. In window behavior, "Show window list while switching windows" is checked, but is greyed out. Is there another option I can try?

roguetr 05-14-2008 12:02 AM

Does it switch applications when hitting alt+tab?

If not, make sure you are using an applicable keyboard shortcut scheme.

I generally don't change much in KDE except to disable all effects and load compiz-fuzion and emerald. Selecting the keyboard scheme and ticking that box are about all the post-modifications I make.

I use ArchLinux http://www.archlinux.org


All times are GMT -5. The time now is 01:42 AM.