LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices



Reply
 
Search this Thread
Old 08-05-2010, 08:36 AM   #1
Neyzan
Member
 
Registered: Jul 2010
Location: Thessaloniki, Greece
Distribution: Slackware, Arch, Bodhi.
Posts: 75

Rep: Reputation: 1
How do I change languages in Mint? (while using OpenOffice mainly)


I have recently installed Linux Mint (Isadora) on my old -but still functioning- rustbucket of a PC, and its flying again! (Why didn't I leave Windows sooner?) Although I generally don't have many difficulties getting the hang of it, the issue of changing languages has got me beat. I could only find how to change keyboard layouts, but I can't seem to add more than 4 to the list. Now, because I need already 2 layouts for Greek, I am unable to write in all the languages that I need, so I wondered if there exists a button that I could put somewhere to change languages while writing and, if so, how I can add languages and use different layouts for each. Can someone help me?
 
Old 08-05-2010, 08:46 AM   #2
MTK358
LQ 5k Club
 
Registered: Sep 2009
Posts: 6,443
Blog Entries: 3

Rep: Reputation: 714Reputation: 714Reputation: 714Reputation: 714Reputation: 714Reputation: 714Reputation: 714
What desktop environment?
 
Old 08-07-2010, 05:31 AM   #3
Neyzan
Member
 
Registered: Jul 2010
Location: Thessaloniki, Greece
Distribution: Slackware, Arch, Bodhi.
Posts: 75

Original Poster
Rep: Reputation: 1
Gnome.
 
Old 08-07-2010, 08:26 AM   #4
MTK358
LQ 5k Club
 
Registered: Sep 2009
Posts: 6,443
Blog Entries: 3

Rep: Reputation: 714Reputation: 714Reputation: 714Reputation: 714Reputation: 714Reputation: 714Reputation: 714
(Posting from Mint in VirtualBox)

I just checked and it does seem to gray out the Add button when there are 4 layouts. I see no obvious technical reason for this.

But I figured out a way to bypass this supposedly intentional limitation. Here's how:
  1. Run the command gconf-editor in a terminal. A window will come up.
  2. In the tree view in the left side of the window, select / -> desktop -> gnome -> peripherals -> keyboard -> kbd
  3. In the list in the top-right side of the window, double-click on the layouts item.
  4. Here you will be able to add/remove items to the list. Note that you have to know the 2-letter code for the layout.
  5. Click OK.
  6. Done! You can now close gconf-editor.

Note that the extra layouts will not be accessible by clicking on the layout icon in the tray. You have to right-click it and choose it from the pop-up menu.

Last edited by MTK358; 08-07-2010 at 08:28 AM.
 
1 members found this post helpful.
Old 08-09-2010, 04:33 AM   #5
Neyzan
Member
 
Registered: Jul 2010
Location: Thessaloniki, Greece
Distribution: Slackware, Arch, Bodhi.
Posts: 75

Original Poster
Rep: Reputation: 1
Thank you very much! Do you know if it is also possible to change languages (instead of layouts), so that while writing I can change from one language to another, each with its own layout(s)?
 
Old 08-09-2010, 08:22 AM   #6
MTK358
LQ 5k Club
 
Registered: Sep 2009
Posts: 6,443
Blog Entries: 3

Rep: Reputation: 714Reputation: 714Reputation: 714Reputation: 714Reputation: 714Reputation: 714Reputation: 714
...I thought that the layout changes the language you type in?
 
Old 08-19-2010, 10:59 AM   #7
Neyzan
Member
 
Registered: Jul 2010
Location: Thessaloniki, Greece
Distribution: Slackware, Arch, Bodhi.
Posts: 75

Original Poster
Rep: Reputation: 1
Well, yes and no. Some languages have more than one layout (e.g. Greek has one for monotonic and one for polytonic writing, Serbian one for Cyrillic and one for Latin alphabet, etc.). Although turning to a specific layout of course also changes the language, it would be much more easy and organised to be able to change languages and only see and be able to select between the layouts of the active language. In Windows this is standard (language bar), and it is one of the very few features of Windows that I like. Do you know if this is possible to be done in Mint (or any other edition of Linux)?
 
Old 08-19-2010, 11:05 AM   #8
MTK358
LQ 5k Club
 
Registered: Sep 2009
Posts: 6,443
Blog Entries: 3

Rep: Reputation: 714Reputation: 714Reputation: 714Reputation: 714Reputation: 714Reputation: 714Reputation: 714
Quote:
Originally Posted by Neyzan View Post
Do you know if this is possible to be done in Mint (or any other edition of Linux)?
I don't know.

And this has nothing to do with Linux, it has to do with the desktop environment (GNOME in your case).
 
1 members found this post helpful.
Old 08-20-2010, 08:01 AM   #9
Neyzan
Member
 
Registered: Jul 2010
Location: Thessaloniki, Greece
Distribution: Slackware, Arch, Bodhi.
Posts: 75

Original Poster
Rep: Reputation: 1
Thanks! There are probably ways to modify a desktop environment, do you know where I could find information about that?
 
Old 08-20-2010, 08:09 AM   #10
MTK358
LQ 5k Club
 
Registered: Sep 2009
Posts: 6,443
Blog Entries: 3

Rep: Reputation: 714Reputation: 714Reputation: 714Reputation: 714Reputation: 714Reputation: 714Reputation: 714
As I said, I don't know. Either wait for another member to post and/or do some Google searches.
 
Old 09-04-2010, 09:57 AM   #11
Neyzan
Member
 
Registered: Jul 2010
Location: Thessaloniki, Greece
Distribution: Slackware, Arch, Bodhi.
Posts: 75

Original Poster
Rep: Reputation: 1
I found out today (while trying to write in French) that while it is possible to add new keyboard layouts by using the bypass MTK358 suggested, unfortunately those new layouts (past the first four) do not work. Instead you just get one of the original four (in my case polytonic Greek). I don't understand why the developers of the Gnome version of Mint set such a limitation, and I hope that in future editions multilinguals will be considered and the limitation removed. Meanwhile, can anyone advise me if there is a way to break this limitation of Gnome; or alternatively, if some other edition of Linux does not have this limitation?
 
Old 09-04-2010, 11:36 AM   #12
MTK358
LQ 5k Club
 
Registered: Sep 2009
Posts: 6,443
Blog Entries: 3

Rep: Reputation: 714Reputation: 714Reputation: 714Reputation: 714Reputation: 714Reputation: 714Reputation: 714
I think that it's just a GNOME limitation, not Mint. And it's intentional.

And did you try switching using the right-click menu, not by left-clicking the icon?
 
Old 09-07-2010, 08:23 AM   #13
Neyzan
Member
 
Registered: Jul 2010
Location: Thessaloniki, Greece
Distribution: Slackware, Arch, Bodhi.
Posts: 75

Original Poster
Rep: Reputation: 1
Yes, I tried using the right-click menu, but when I clicked French, I got polytonic Greek instead. Possibly Gnome has a built in limitation of four layouts that can't be bypassed (I can't understand why). Maybe I should switch to the KDE version of Mint. Do you know if that hasn't this limitation?
 
Old 09-07-2010, 08:33 AM   #14
MTK358
LQ 5k Club
 
Registered: Sep 2009
Posts: 6,443
Blog Entries: 3

Rep: Reputation: 714Reputation: 714Reputation: 714Reputation: 714Reputation: 714Reputation: 714Reputation: 714
You don't need to "switch to the KDE version of mint", just install KDE using the package manager (the package is called "kde-full") and you will be able to choose between GNOME and KDE at the login screen.

Last edited by MTK358; 09-07-2010 at 08:35 AM.
 
1 members found this post helpful.
Old 09-07-2010, 08:55 AM   #15
craigevil
Senior Member
 
Registered: Apr 2005
Location: OZ
Distribution: Debian Sid
Posts: 4,734
Blog Entries: 12

Rep: Reputation: 457Reputation: 457Reputation: 457Reputation: 457Reputation: 457
You need the openoffice.org-l10n-xxx package for whatever language you want to use in OpenOffice,probably want the appropriate dictionary as well. you also need the appropriate fonts installed.

Choosing language settings - OpenOffice.org Wiki
http://wiki.services.openoffice.org/...guage_settings

For Gnome system>administration>language support you can define a shortcut key to switch languages, then you can do:

Put your mouse on the top panel and right click on 'Add to Panel'.
Next scroll down to Utilities and click on 'keyboard indicator'.
That will allow you to switch between foo and English, if both are set up.

Change the User Interface Language in Ubuntu - How-To Geek
http://www.howtogeek.com/howto/17528...age-in-ubuntu/

Last edited by craigevil; 09-07-2010 at 08:57 AM.
 
  


Reply

Tags
mint9


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
no response from scim when trying to change languages in slackware 13 mattington Slackware 5 11-13-2009 11:42 PM
how to add new languages in OpenOffice manolakis Debian 1 10-31-2007 06:08 PM
openoffice languages matrixon Linux - Software 1 04-05-2006 05:39 PM
How Do I Change Languages in KDE? aysiu Linux - Newbie 1 07-23-2005 10:39 PM
how do i install additional languages for OpenOffice.org? jogurt666 Linux - Software 2 01-28-2004 04:41 AM


All times are GMT -5. The time now is 12:18 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration