LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 07-19-2007, 12:02 PM   #1
calande
Member
 
Registered: Oct 2005
Distribution: Urubu
Posts: 159

Rep: Reputation: 15
How can I listen to audio CDs without audio cable?


I'm on a computer that I am not allowed to open, so I can't add an audio cable. There's already Linux with xine and KsCD. I don't have sound when I play an audio CD. How can I do?
 
Old 07-19-2007, 12:07 PM   #2
pljvaldez
Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Squeeze (x86)
Posts: 6,092

Rep: Reputation: 269Reputation: 269Reputation: 269
Ummm, magic?

If there's no cable attaching the CD to the soundcard, you're just sort of out of luck, I think.
 
Old 07-19-2007, 12:08 PM   #3
slakmagik
Senior Member
 
Registered: Feb 2003
Distribution: Slackware
Posts: 4,113

Rep: Reputation: Disabled
See if you can switch to 'digital audio extraction' in the preferences of your player. That may work, though I'm not positive.
 
Old 07-19-2007, 12:09 PM   #4
{BBI}Nexus{BBI}
Senior Member
 
Registered: Jan 2005
Location: Nottingham, UK
Distribution: Mageia 4
Posts: 4,297

Rep: Reputation: 205Reputation: 205Reputation: 205
Quote:
Originally Posted by calande
I'm on a computer that I am not allowed to open, so I can't add an audio cable. There's already Linux with xine and KsCD. I don't have sound when I play an audio CD. How can I do?
If you have a headphone socket on the drive use a pair of headphones or remove the speaker cable from the soundcard and plug it into the headphone socket.
 
Old 07-19-2007, 12:13 PM   #5
calande
Member
 
Registered: Oct 2005
Distribution: Urubu
Posts: 159

Original Poster
Rep: Reputation: 15
I don't have a head phone. But it works in Windows. It should work in Linux. I can't believe it... Should I request it at the xine developers to implement it? :|
 
Old 07-19-2007, 12:13 PM   #6
slakmagik
Senior Member
 
Registered: Feb 2003
Distribution: Slackware
Posts: 4,113

Rep: Reputation: Disabled
Or, if nothing else, just use cdparanoia and an encoder to rip the thing and play it back as a whatever form you encode it as. Don't have to play the cd to hear the cd.
 
Old 07-19-2007, 12:19 PM   #7
{BBI}Nexus{BBI}
Senior Member
 
Registered: Jan 2005
Location: Nottingham, UK
Distribution: Mageia 4
Posts: 4,297

Rep: Reputation: 205Reputation: 205Reputation: 205
Quote:
Originally Posted by calande
I don't have a head phone. But it works in Windows. It should work in Linux. I can't believe it... Should I request it at the xine developers to implement it? :|
You don't have a headphone socket or you don't have headphones? You did check the mixer volume for your cd, didn't you? Better still use digiots suggestion and eliminate disc juggling

BTW:If you're not allowed to open the computer, how do you know there's no cable attached?

Last edited by {BBI}Nexus{BBI}; 07-19-2007 at 12:21 PM.
 
Old 07-19-2007, 12:30 PM   #8
slackhack
Senior Member
 
Registered: Jun 2004
Distribution: Arch, Debian, Slack
Posts: 1,016

Rep: Reputation: 46
not sure about xine, but you can use a plugin like libcdaudio in xmms.
 
Old 07-19-2007, 03:20 PM   #9
dahveed3
Member
 
Registered: Mar 2007
Posts: 191

Rep: Reputation: 31
Have you tried Amarok? Install amarok, amarok-xine, libxine1, and libxine1-ffmpeg, libvisual, and libvisual-plugins, libmad, liblame, lame, toolame. It should automatically also install libtunepimp (something like that). Use whatever package manager your distro uses. On Debian, I use Aptitude.

Amarok puts itself into the KDE auto-run, so on my Debian Lenny system when I insert a cd the autorun has play in amarok as one of the choices.

For me, it used digital playback automatically. I do have that cable connected but the cd volume slider in KMix has no effect which means it is playing through the standard PCM/Wave IDE cable.

Since it's on digital, the EQ in Amarok and the visualizations will work. I usually (on my Audigy 2 ZS) change a few things only when I'll be listening to music. I use KMix and turn on the bass and treble controls and raise them to about 70%, turn on the 3D control and turn it up to the first notch, plug in my headphones and turn down my speaker volume (can't figure out how to mute that in the mixer like Windows would with the Creative AudioConsole), and set the Amarok EQ to my desired levels.

If you have a Music folder, the first time wizard in Amarok will let you browse to it and it will then setup your library. If you don't have jpeg album covers, you can later use it to search Amazon and add them for you so you can see them while playing. Just wait until the wizard finishes setting things up then you're all set.

I'm not sure, but I think Kaffeine can also use digital for cd playback. But I use Kaffeine for my video playback and Amarok for my music listening.
 
Old 07-20-2007, 06:49 AM   #10
{BBI}Nexus{BBI}
Senior Member
 
Registered: Jan 2005
Location: Nottingham, UK
Distribution: Mageia 4
Posts: 4,297

Rep: Reputation: 205Reputation: 205Reputation: 205
Quote:
Originally Posted by dahveed3
Have you tried Amarok? Install amarok, amarok-xine, libxine1, and libxine1-ffmpeg, libvisual, and libvisual-plugins, libmad, liblame, lame, toolame. It should automatically also install libtunepimp (something like that). Use whatever package manager your distro uses. On Debian, I use Aptitude.

Amarok puts itself into the KDE auto-run, so on my Debian Lenny system when I insert a cd the autorun has play in amarok as one of the choices.

For me, it used digital playback automatically. I do have that cable connected but the cd volume slider in KMix has no effect which means it is playing through the standard PCM/Wave IDE cable.

Since it's on digital, the EQ in Amarok and the visualizations will work. I usually (on my Audigy 2 ZS) change a few things only when I'll be listening to music. I use KMix and turn on the bass and treble controls and raise them to about 70%, turn on the 3D control and turn it up to the first notch, plug in my headphones and turn down my speaker volume (can't figure out how to mute that in the mixer like Windows would with the Creative AudioConsole), and set the Amarok EQ to my desired levels.

If you have a Music folder, the first time wizard in Amarok will let you browse to it and it will then setup your library. If you don't have jpeg album covers, you can later use it to search Amazon and add them for you so you can see them while playing. Just wait until the wizard finishes setting things up then you're all set.

I'm not sure, but I think Kaffeine can also use digital for cd playback. But I use Kaffeine for my video playback and Amarok for my music listening.
WOW , you do all this just to listen to audio cd's
 
Old 07-20-2007, 08:41 AM   #11
IBall
Senior Member
 
Registered: Nov 2003
Location: Perth, Western Australia
Distribution: Ubuntu, Debian, Various using VMWare
Posts: 2,088

Rep: Reputation: 61
Xine, Rhythmbox, Amarok, etc should all be able to play CD audio with no problems, even without the analog audio cable to your sound card.

Make sure you are using a recent version of each of these, and you should have no problems.

--Ian
 
Old 07-20-2007, 11:41 AM   #12
dahveed3
Member
 
Registered: Mar 2007
Posts: 191

Rep: Reputation: 31
Naah, I just get carried away sometimes. I figure as long as I'm suggesting a program, I might as well list the stuff that helps to get that program playing everything it can, not only cd's.

I think even good old Kscd has an options area where it can be set to either digital or analog. I just like EQ's and visualizations and stuff, so I appreciate the additional functions of the other programs.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot listen to audio in slackware..Help!!! lenson Linux - Newbie 9 08-21-2005 02:00 AM
Can't listen to Audio CD's bearwood Fedora 6 01-15-2005 07:04 PM
Audio CDs without analog cable skibud2 Linux - Newbie 1 12-27-2004 04:06 PM
Listen to audio CD without cable from CD-ROM to soundcard objorkum Linux - Software 1 01-19-2004 02:25 PM
How to listen to audio CDs on Suse7 using the command line? juszuf7 Linux - General 1 10-10-2002 07:17 PM


All times are GMT -5. The time now is 02:13 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration