LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices



Reply
 
Search this Thread
Old 03-02-2010, 09:02 PM   #1
AlP36
LQ Newbie
 
Registered: Sep 2007
Location: Western NC
Distribution: Ubuntu 9.10
Posts: 9

Rep: Reputation: 0
Grub2 not reading the menu


After a reinstall of win xp I had to reload grub2. I am using Karmic but now the multi-OS menu does not display, rather it drops into the grub> shell. Then I have to manually load the modules and boot into Linux.

Anyone have experience with this and how to get it to read "/boot/grub/grub.cfg"?

Thanks
 
Old 03-04-2010, 07:43 AM   #2
Maligree
Member
 
Registered: Mar 2008
Distribution: Gentoo, CentOS, Fedora, Arch
Posts: 231
Blog Entries: 1

Rep: Reputation: 42
Quote:
Anyone have experience with this and how to get it to read "/boot/grub/grub.cfg"?
For a start, it's actually grub.conf.
 
Old 03-04-2010, 04:27 PM   #3
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,038

Rep: Reputation: 373Reputation: 373Reputation: 373Reputation: 373
In my opinion, grub 1.97 ( "grub2" ) isn't fit for the purpose [ Eg: it falls over and dies, without any error messages if there are any lines with trailing spaces in grub.conf ], and it should never have been released other than as "testing".

grub2 is neat, has great potential, but is not stable or reliable yet.

Unless you are using an ext4 filesystem for your 'buntu 9.10 boot partion, you can easily revert to "grub legacy", which still works very well.

I think here are now some versions of 0.97 that have been patched to deal
with ext4 filesystems if you feel the need for ext4. I'll leave you to search on this.

See here: http://brettshaffer.com/blog/linux/downgrade-grub-2/
 
Old 03-04-2010, 08:20 PM   #4
AlP36
LQ Newbie
 
Registered: Sep 2007
Location: Western NC
Distribution: Ubuntu 9.10
Posts: 9

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Maligree View Post
For a start, it's actually grub.conf.
Beg you pardon, but in grub2 it is grub.cfg. Try looking at this page:

http://members.iinet.net/~herman546/....html#grub.cfg

I appreciate all the help.
 
Old 03-08-2010, 06:43 AM   #5
Laurens73
Member
 
Registered: Aug 2009
Location: Zeewolde, Flevoland NL
Distribution: Debian squeeze (Gnome) on netbooks; Debian Lenny on servers and Debian wheezy (XFCE) on new laptops
Posts: 144

Rep: Reputation: 23
Perhaps you could try the way it is done with the old Grub version:

Open a console window.
Code:
$Grub
Grub> root (hd0,0)
Grub> find /boot/grub/stage1
Grub> setup(hd0)
Grub> quit
$
And Grub should be looking into the files again. I haven't tested it on the new grub yet, so I'm curious if this still works.
 
Old 03-08-2010, 01:38 PM   #6
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,038

Rep: Reputation: 373Reputation: 373Reputation: 373Reputation: 373
Quote:
Perhaps you could try the way it is done with the old Grub version: .....
Sadly, NO!

grub2 (Strictly 1.97 Beta) is completely different from "grub legacy".

See here: http://members.iinet.net/~herman546/p20.html for a good introduction to / HOWTO for grub2 and many more links.
 
Old 03-08-2010, 03:13 PM   #7
ronlau9
Senior Member
 
Registered: Dec 2007
Location: In front of my LINUX OR MAC BOX
Distribution: Mandriva 2009 X86_64 suse 11.3 X86_64 Centos X86_64 Debian X86_64 Linux MInt 86_64 OS X
Posts: 2,369

Rep: Reputation: Disabled
Quote:
Originally Posted by AlP36 View Post
After a reinstall of win xp I had to reload grub2. I am using Karmic but now the multi-OS menu does not display, rather it drops into the grub> shell. Then I have to manually load the modules and boot into Linux.

Anyone have experience with this and how to get it to read "/boot/grub/grub.cfg"?

Thanks
If it is not solved yet , you stated that you can boot into linux.
Boot into linux
Run from the cli the command sudo update-Grub
It will generate a new menu
 
Old 03-09-2010, 10:26 PM   #8
AlP36
LQ Newbie
 
Registered: Sep 2007
Location: Western NC
Distribution: Ubuntu 9.10
Posts: 9

Original Poster
Rep: Reputation: 0
In reading the manual and all I found that the UUID command does not always work as it should. So I am using a work around until I learn more about doing a permanent fix.
When the menu appears I press e and get a >grub command line. Then you can tempararly change the commands. So I take out the reference to the disk UUID and put root=/dev/sdb1 with the linux load command.
 
Old 03-09-2010, 10:34 PM   #9
AlP36
LQ Newbie
 
Registered: Sep 2007
Location: Western NC
Distribution: Ubuntu 9.10
Posts: 9

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by ronlau9 View Post
If it is not solved yet , you stated that you can boot into linux.
Boot into linux
Run from the cli the command sudo update-Grub
It will generate a new menu
Sorry I didn't answer your suggestion. I tried that (A couple of times) and it still didn't work.
The way that the tutorial:
http://members.iinet.net/~herman546/....html#grub.cfg

show probably works best but my programming efforts stopped about 30 years ago and it wasn't my favorite job then so I am relearning a lot of stuff.
 
Old 03-09-2010, 10:49 PM   #10
ronlau9
Senior Member
 
Registered: Dec 2007
Location: In front of my LINUX OR MAC BOX
Distribution: Mandriva 2009 X86_64 suse 11.3 X86_64 Centos X86_64 Debian X86_64 Linux MInt 86_64 OS X
Posts: 2,369

Rep: Reputation: Disabled
Quote:
Originally Posted by AlP36 View Post
Sorry I didn't answer your suggestion. I tried that (A couple of times) and it still didn't work.
The way that the tutorial:
http://members.iinet.net/~herman546/....html#grub.cfg

show probably works best but my programming efforts stopped about 30 years ago and it wasn't my favorite job then so I am relearning a lot of stuff.
That is strange because in the link you provide us with told you that Sudo update-grub should make a new grub.cfg .
BTW do you have a GRUB.cfg
A a last effort we can edit that file but it is rather a rude way and
put the entry directly in that file.
 
Old 03-11-2010, 01:51 PM   #11
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,038

Rep: Reputation: 373Reputation: 373Reputation: 373Reputation: 373
Quote:
update-grub should make a new grub.cfg .
Yes, it should. But sometimes it doesn't, and fails without any error message.

The culprit is usually one of the scripts in /etc/grub.d/

If there is a trailing space on any of the lines in those scripts, update-grub fails, silently

Stupid, but, sadly, true.
 
Old 03-11-2010, 07:41 PM   #12
aus9
Guru
 
Registered: Oct 2003
Posts: 5,060

Rep: Reputation: Disabled
hi

if you do not like UUID in your grub.cfg.....use root powers to edit....../etc/default/grub and change line to read
GRUB_DISABLE_LINUX_UUID=true...........by removing #
save file and run ....update-grub to generate a new grub.cfg
 
  


Reply

Tags
grub, ubuntu


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot access bios or Grub2 menu with usb keyboard the trooper Linux - Hardware 11 09-01-2010 04:01 AM
Creating a Grub2 boot-cd with a (grub.cfg) menu ..my solution ssenuta Linux - General 3 02-04-2010 07:16 PM
LXer: Burg - Advanced menu for grub2 LXer Syndicated Linux News 0 11-25-2009 04:00 PM
Adding a menu entry to grub2 Jeff91 Linux - General 1 08-28-2009 07:12 PM
dvdbackup: Error reading MENU VOB overbored Linux - Software 0 02-12-2007 11:23 PM


All times are GMT -5. The time now is 05:07 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration