LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 09-02-2006, 11:21 AM   #1
Greebstreebling
Member
 
Registered: Nov 2005
Location: Swansea, Wales, UK
Distribution: debian
Posts: 235

Rep: Reputation: 30
Unhappy Grub Config - Windows fails to load


Dear Guys,

I have debian 3.1 which, with all your help I have configured and it works fine. I have now taken anothe step and wish to run the dreaded Windows xp on another hard drive. I configured grub but the entry I've made in menu.lst doesn't seem to do the job.

Here's what I did.

I have two hard drives, one with ebian linux and one empty. I unplugged the Linux drive and on the empty one I installed windows xp. Windows boots up fine no problems there.

I then connected the Debian drive back in, and when the machine started it booted windows, so I entered the bios and set things there so that it would boot 1st from the Debian disk. That worked fine, so my sytem now boots the Debian installation. I modified Menu .lst as shown below, but got these messages:

root (hd0,0)
filesystem type is extfs partition type 0x83
makeactive
chainloader + 1
error 13: Invalid or unsupported executable format press any key to continue

I've copied in the menu.lst file below. Again many thanks for your help on this.



# menu.lst - See: grub(8), info grub, update-grub(8)
# grub-install(8), grub-floppy(8),
# grub-md5-crypt, /usr/share/doc/grub
# and /usr/share/doc/grub-doc/.

## default num
# Set the default entry to the entry number NUM. Numbering starts from 0, and
# the entry number 0 is the default if the command is not used.
#
# You can specify 'saved' instead of a number. In this case, the default entry
# is the entry saved with the command 'savedefault'.
default 0

## timeout sec
# Set a timeout, in SEC seconds, before automatically booting the default entry
# (normally the first entry defined).
timeout 5

# Pretty colours
color cyan/blue white/blue

## password ['--md5'] passwd
# If used in the first section of a menu file, disable all interactive editing
# control (menu entry editor and command-line) and entries protected by the
# command 'lock'
# e.g. password topsecret
# password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/
# password topsecret

#
# examples
#
# title Windows 95/98/NT/2000
# root (hd0,0)
# makeactive
# chainloader +1
#
# title Linux
# root (hd0,1)
# kernel /vmlinuz root=/dev/hda2 ro
#

#
# Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST

### BEGIN AUTOMAGIC KERNELS LIST
## lines between the AUTOMAGIC KERNELS LIST markers will be modified
## by the debian update-grub script except for the default options below

## DO NOT UNCOMMENT THEM, Just edit them to your needs

## ## Start Default Options ##
## default kernel options
## default kernel options for automagic boot options
## If you want special options for specifiv kernels use kopt_x_y_z
## where x.y.z is kernel version. Minor versions can be omitted.
## e.g. kopt=root=/dev/hda1 ro
# kopt=root=/dev/hda1 ro

## default grub root device
## e.g. groot=(hd0,0)
# groot=(hd0,0)

## should update-grub create alternative automagic boot options
## e.g. alternative=true
## alternative=false
# alternative=true

## should update-grub lock alternative automagic boot options
## e.g. lockalternative=true
## lockalternative=false
# lockalternative=false

## altoption boot targets option
## multiple altoptions lines are allowed
## e.g. altoptions=(extra menu suffix) extra boot options
## altoptions=(recovery mode) single
# altoptions=(recovery mode) single

## controls how many kernels should be put into the menu.lst
## only counts the first occurence of a kernel, not the
## alternative kernel options
## e.g. howmany=all
## howmany=7
# howmany=all

## should update-grub create memtest86 boot option
## e.g. memtest86=true
## memtest86=false
# memtest86=true

## ## End Default Options ##

title Debian GNU/Linux, kernel 2.6.8-2-k7
root (hd0,0)
kernel /boot/vmlinuz-2.6.8-2-k7 root=/dev/hda1 ro
initrd /boot/initrd.img-2.6.8-2-k7
savedefault
boot

title Debian GNU/Linux, kernel 2.6.8-2-k7 (recovery mode)
root (hd0,0)
kernel /boot/vmlinuz-2.6.8-2-k7 root=/dev/hda1 ro single
initrd /boot/initrd.img-2.6.8-2-k7
savedefault
boot

title Debian GNU/Linux, kernel 2.4.27-2-386
root (hd0,0)
kernel /boot/vmlinuz-2.4.27-2-386 root=/dev/hda1 ro
initrd /boot/initrd.img-2.4.27-2-386
savedefault
boot

title Debian GNU/Linux, kernel 2.4.27-2-386 (recovery mode)
root (hd0,0)
kernel /boot/vmlinuz-2.4.27-2-386 root=/dev/hda1 ro single
initrd /boot/initrd.img-2.4.27-2-386
savedefault
boot

### END DEBIAN AUTOMAGIC KERNELS LIST

# my widows xp entry follows now
#
title Windows xp
root (hd1,0)
makeactive
chainloader +1
boot

# end of my windows 98 stanza
#
 
Old 09-02-2006, 12:12 PM   #2
xpromisex
Member
 
Registered: Apr 2004
Location: Statesboro, GA
Distribution: Arch Linux 2007.05 "Duke" (Kernel 2.6.21)
Posts: 447

Rep: Reputation: 30
I'm not all that sure but I know that my WindowsXP GRUB entry would look like this:

title WindowsXP
rootnoverify(hd1,0)
makeactive
chainloader+1

notice that the only two differences between mine and yours are the "rootnoverify", which I personally think you should try, and the "boot" option. The "boot" option doesn't make a difference I believe, but you may want to try my version of this if you can. Post back with feedback!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
GRUB 0.95 Config File, Won't Auto Load edooze Linux - Newbie 3 07-19-2006 09:20 PM
GRUB doesn't load Windows XP Vladk1000 Linux - Newbie 4 09-17-2005 03:08 AM
GRUB won't load Windows Norab Linux - Hardware 1 08-19-2005 01:33 PM
X windows fails to load [FC2, X11] phyrko Linux - Newbie 4 11-29-2004 05:39 PM
configuring GRUB to load windows merlin371 Linux - General 1 02-28-2004 10:38 AM


All times are GMT -5. The time now is 01:50 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration