LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 02-19-2012, 09:01 AM   #1
scottyanke
LQ Newbie
 
Registered: Dec 2010
Location: Delano, MN
Distribution: Fedora
Posts: 8

Rep: Reputation: 1
Gnome3, gnome-session and DEBUG(+) messages won't turn off


After upgrading to Fedora 16 (from 14) and by default, Gnome3, I have started getting debug messages in the /var/log/messages file that I can't get to stop. They begin like this -

systemd-logind[1151]: New session 1 of user gdm.
systemd-logind[1151]: Linked /tmp/.X11-unix/X0 to /run/user/gdm/X11/display.
gnome-session[1902]: DEBUG(+): Enabling debugging
gnome-session[1902]: DEBUG(+): GsmXsmpServer: SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1902,unix/unix:/tmp/.ICE-unix/1902#012
gnome-session[1902]: DEBUG(+): GsmShell: Not connected to the shell
gnome-session[1902]: DEBUG(+): GsmManager: setting client store 0x1faeb20
gnome-session[1902]: DEBUG(+): GdmSignalHandler: Adding handler 1: signum=4 (nil)
gnome-session[1902]: DEBUG(+): GdmSignalHandler: Registering for 4 signals
...
gnome-session[1902]: DEBUG(+): fill: *** Getting session 'gdm-shell'
gnome-session[1902]: DEBUG(+): fill: *** Looking if /var/lib/gdm/.config/gnome-session/sessions/gdm-shell.session is a valid session file
gnome-session[1902]: DEBUG(+): Cannot use session '/var/lib/gdm/.config/gnome-session/sessions/gdm-shell.session': non-existing or invalid file.
gnome-session[1902]: DEBUG(+): fill: *** Looking if /etc/xdg/gnome-session/sessions/gdm-shell.session is a valid session file
gnome-session[1902]: DEBUG(+): Cannot use session '/etc/xdg/gnome-session/sessions/gdm-shell.session': non-existing or invalid file.
...
gnome-session[1902]: DEBUG(+): GsmManager: disposing manager
gnome-session[1902]: DEBUG(+): GsmStore: Clearing object store
gnome-session[1902]: DEBUG(+): GsmStore: Unreffing object: 0x20119f0
gnome-session[1902]: DEBUG(+): GsmStore: Unreffing object: 0x2011830
gnome-session[1902]: DEBUG(+): GsmStore: Unreffing object: 0x2011910
gnome-session[1902]: DEBUG(+): GsmStore: emitting removed for /org/gnome/SessionManager/App2
gnome-session[1902]: DEBUG(+): GsmStore: emitting removed for /org/gnome/SessionManager/App1
gnome-session[1902]: DEBUG(+): GsmStore: emitting removed for /org/gnome/SessionManager/App3
gnome-session[1902]: DEBUG(+): GsmStore: Clearing object store
gnome-session[1902]: DEBUG(+): GsmStore: Clearing object store
systemd-logind[1151]: Removed session 1.
gdm-simple-slave[1628]: WARNING: Child process 1902 was already dead.

The messages show up whenever booting the machine, logging on or off.

I've tried setting up /etc/gdm/custom.conf as follows, but it still seems to ignore the debug setting. Note that for this cut-n-paste I removed the blank lines.
# GDM configuration storage
[daemon]
[security]
DisallowTCP=true
[xdmcp]
[greeter]
[chooser]
[debug]
Enable=false

I've looked for other configuration files that might be overriding the custom.conf file, but haven't been able to find one. I used the gconf tools to try and find any configuration settings that way, but with no luck on the debug setting.

It isn't a fatal problem, but it is very annoying. Until the upgrade to F16 and Gnome3 I never got these messages. Although I've switched to xfce4 as a result of Gnome3 being a different kind of pain than just the messages, I still keep some vestiges of Gnome on the system for certain programs so completely removing it isn't an option.

Any suggestions?
 
Old 02-22-2012, 06:14 PM   #2
scottyanke
LQ Newbie
 
Registered: Dec 2010
Location: Delano, MN
Distribution: Fedora
Posts: 8

Original Poster
Rep: Reputation: 1
After looking through the source for gdm-3.2.1.1, I found that gdm-greeter-session.c is hardcoded to start gnome-session in debug mode. The specific command it uses is "/gnome-session -f --debug". Compiling it myself, I get the debug stuff to shut off, although I've got lots of other issues in trying to get the configuration parameters correct...

Is it possible that this program was distributed with debugging forced on by accident?
 
Old 06-30-2012, 01:10 AM   #3
scottyanke
LQ Newbie
 
Registered: Dec 2010
Location: Delano, MN
Distribution: Fedora
Posts: 8

Original Poster
Rep: Reputation: 1
Solved

I hit this same debug message issue when I did a clean install to Fedora 17. It happened beginning with the very first boot after the OS was installed.

The solution to clearing it? I removed NetworkManager as a package. Since I don't need NetworkManager on a desktop machine I figured I'd get rid of it. The side effect was that the Gnome debug messages went away once NetworkManage was removed. I didn't even have to change anything in Gnome (I'm using XFCE by the way), and didn't need to remove any other Gnome packages to clear this.

It is annoying that even with F17 the debug messages were still there. They tend to fill the log in a spot where I'm trying find other issues.
 
Old 06-30-2012, 04:17 AM   #4
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 5,404

Rep: Reputation: 480Reputation: 480Reputation: 480Reputation: 480Reputation: 480
Although you've solved your problem, isn't debug turned on & off in grub?
Also don't forget to mark post as solved.
 
Old 06-30-2012, 11:09 PM   #5
scottyanke
LQ Newbie
 
Registered: Dec 2010
Location: Delano, MN
Distribution: Fedora
Posts: 8

Original Poster
Rep: Reputation: 1
Sorry about forgetting to mark it as solved.

No, the debug is not part of the grub configuration. It was GNOME specific, and seemed to only happen when the Gnome GDM was used. It happened to me on two machines with clean installs, and on both removing NetworkManager solved the problem for me. I've also switched to using SLIM, in part because it is simpler, and from a security point of view it prompts for an id, instead of telling you an id and just prompting for a password like GDM started doing a little while back.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Arch Linux + GNOME not gnome3 nor gnome-shell demencia Linux - Newbie 6 05-13-2011 09:10 AM
Turning on/off debug messages galapogos Linux - Kernel 0 07-20-2008 11:10 PM
CGI Perl problem with :session -debug craig467 Programming 2 07-20-2006 08:45 AM
how to turn on samba debug to troubleshoot printing nytcorp Linux - Newbie 1 04-26-2006 06:02 AM
Displaying system messages in Gnome session - How? kosh42 Linux - Newbie 1 05-22-2004 02:13 AM


All times are GMT -5. The time now is 01:26 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration