LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Desktop (http://www.linuxquestions.org/questions/linux-desktop-74/)
-   -   gnome-terminal:keyboard shortcut launches terminal with / directory default! (http://www.linuxquestions.org/questions/linux-desktop-74/gnome-terminal-keyboard-shortcut-launches-terminal-with-directory-default-814078/)

deepclutch 06-14-2010 12:35 PM

gnome-terminal:keyboard shortcut launches terminal with / directory default!
 
Hello ,
I ran this 'gconf-cleaner' just for the sake(:o) on My Debian Box.

If I launch "gnome-terminal" from Applications Menu or from a panel icon ,it works with default $HOME directory(default behaviour).
But ,with custom keyboard shortcut for Gnome Terminal in Gnome-2.30(Can set via menu System>Preferences>Keyboard Shortcuts),it opens in root directory.I mean in "/" directory.
The Easy fix is to assign 'gnome-terminal --working-directory=%f ' or something similar.

Is there a way to fix this Behaviour without adding any lines to ~/.bashrc etc ?

BTW ,$HOME variable is correct.rest everything is Fine.

DavidMcCann 06-21-2010 12:48 PM

One fix would be to use the configuration editor. Under Apps - Metacity - Global keybindings, you could unset run_command_terminal (which is clearly broken) and assign the keystroke you use to run_command_1. Then go to Global commands and set command_1 to gnome-terminal, with parameters if required.


All times are GMT -5. The time now is 11:47 AM.