LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Desktop (http://www.linuxquestions.org/questions/linux-desktop-74/)
-   -   gnome-shell 3.8 no shutdown option (http://www.linuxquestions.org/questions/linux-desktop-74/gnome-shell-3-8-no-shutdown-option-4175476893/)

z3nith 09-12-2013 01:01 PM

gnome-shell 3.8 no shutdown option
 
I am running gnome 3.8 on a minimal slackware install and have everything (almost) working nicely. Under the user menu (top right) there is no option to shutdown as a non privileged user. The only option is 'settings' and 'logout'. Logout functions as expected.

Hitting alt does not make the shutdown option appear. Installing the frippery shutdown extension does not make the option appear. Running:

gnome-session-quit --power-off

results in the popup dialog confirming shutdown. ck-list-session shows a consolekit session running and there is also a dbus-launch process running.

My guest user is a part of the power group. Any ideas where i can begin troubleshooting this? Thanks in anticipation.

z3nith 09-12-2013 01:17 PM

Some extra information. gnome-session-quit --power-off does not work although the popup menu appears. After choosing to poweroff /var/log/messages shows me this:

Code:

dbus[1618]: [system] Rejected send message, 2 matched rules; type="method_call", sender=":1.44" (uid=1000 pid=3375 comm="/usr/bin/gnome-shell ") interface="org.freedesktop.ConsoleKit.Manager" member="CanHibernate" error name="(unset)" requested_reply="0" destination=":1.10" (uid=0 pid=2845 comm="/usr/sbin/console-kit-daemon --no-daemon ")
I recompiled dbus which changed nothing.

z3nith 09-12-2013 09:12 PM

Downgrading ConsoleKit to 0.4.5 solved my problem. I now see the shutdown in the menu and it functions.


All times are GMT -5. The time now is 07:49 AM.