LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Desktop (http://www.linuxquestions.org/questions/linux-desktop-74/)
-   -   gnome-settings-daemon error (http://www.linuxquestions.org/questions/linux-desktop-74/gnome-settings-daemon-error-524334/)

adityavpratap 01-31-2007 07:37 AM

gnome-settings-daemon error
 
Hi,
I installed Dropline Gnome on my Slackware 11.0 today. Now, when I try to log in to Gnome, I get the following message -

Quote:

Unable to start the settings manager 'gnome-settings-daemon'.
Without the GNOME settings manager running, some preferences may not take effect. This could indicate a problem with Bonobo, or a non-GNOME (e.g. KDE) settings manager may already be active and conflicting with the GNOME settings manager.
Can any one suggest a solution?

zborgerd 01-31-2007 05:27 PM

Gnome-settings-daemon needs dbus-launch, which is only executed by GDM or the xinitrc.gnome. If you use KDM, XDM, or another runlevel 4 login manager (without some configuration on your side), it will not work.

I hope this solves the problem for you.

adityavpratap 01-31-2007 09:24 PM

Hi,
Here is what I did. Made changes to inittab to boot into text mode.
Copied xinitrc.gnome from /etc/X11/xinint/ to the home folder as .xinitrc.
Then started X with startx. But, still I am getting the same error message.
Here is the output of ps -A :
PID TTY TIME CMD
1 ? 00:00:06 init
2 ? 00:00:00 ksoftirqd/0
3 ? 00:00:00 events/0
4 ? 00:00:00 khelper
5 ? 00:00:00 kthread
7 ? 00:00:00 kblockd/0
8 ? 00:00:00 kacpid
80 ? 00:00:00 khubd
82 ? 00:00:00 kseriod
189 ? 00:00:00 pdflush
190 ? 00:00:00 pdflush
191 ? 00:00:00 kswapd0
192 ? 00:00:00 aio/0
193 ? 00:00:00 jfsIO
194 ? 00:00:00 jfsCommit
195 ? 00:00:00 jfsSync
196 ? 00:00:00 xfslogd/0
197 ? 00:00:00 xfsdatad/0
893 ? 00:00:00 ata/0
912 ? 00:00:00 exec-osm/0
917 ? 00:00:00 block-osm/0
924 ? 00:00:00 khpsbpkt
960 ? 00:00:00 kcryptd/0
965 ? 00:00:00 kjournald
1129 ? 00:00:00 udevd
2057 ? 00:00:00 shpchpd
2178 ? 00:00:00 kpsmoused
2219 ? 00:00:00 kjournald
2221 ? 00:00:00 kjournald
2272 ? 00:00:00 syslogd
2275 ? 00:00:00 klogd
2426 ? 00:00:00 inetd
2441 ? 00:00:00 cupsd
2495 ? 00:00:00 crond
2497 ? 00:00:00 atd
2500 ? 00:00:00 acpid
2526 ? 00:00:00 gpm
2533 ? 00:00:00 dbus-daemon
2543 ? 00:00:01 hald
2544 ? 00:00:00 hald-runner
2550 ? 00:00:00 hald-addon-acpi
2553 ? 00:00:00 hald-addon-keyb
2562 ? 00:00:00 hald-addon-stor
2564 ? 00:00:00 hald-addon-stor
2588 ? 00:00:00 avahi-daemon
2602 ? 00:00:00 avahi-dnsconfd
2607 ? 00:00:00 squid
2609 ? 00:00:00 squid
2611 tty1 00:00:00 login
2612 tty2 00:00:00 agetty
2613 tty3 00:00:00 agetty
2614 tty4 00:00:00 agetty
2615 tty5 00:00:00 agetty
2616 tty6 00:00:00 agetty
2627 ? 00:00:00 squid_redirect
2628 ? 00:00:00 squid_redirect
2629 ? 00:00:00 squid_redirect
2630 ? 00:00:00 squid_redirect
2631 ? 00:00:00 squid_redirect
2632 ? 00:00:00 unlinkd
2635 tty1 00:00:00 bash
2880 tty1 00:00:00 startx
2896 tty1 00:00:00 xinit
2897 tty7 00:00:06 X
2901 tty1 00:00:00 gnome-session
2905 ? 00:00:00 dbus-daemon
2906 tty1 00:00:00 dbus-launch
2908 tty1 00:00:00 gconfd-2
2911 ? 00:00:00 bonobo-activati
2918 ? 00:00:00 at-spi-registry
2920 tty1 00:00:00 gnome-keyring-d
2924 ? 00:00:00 esd
2930 ? 00:00:00 metacity
2932 ? 00:00:01 nautilus
2934 ? 00:00:00 gnome-panel
2936 ? 00:00:00 gnome-vfs-daemo
2938 ? 00:00:01 gnome-terminal
2952 ? 00:00:00 nm-applet
2953 ? 00:00:00 gnome-pty-helpe
2954 pts/0 00:00:00 bash
2963 ? 00:00:00 gnome-volume-ma
2976 ? 00:00:00 gnome-power-man
2978 ? 00:00:00 wnck-applet
2983 ? 00:00:03 deskbar-applet
2986 ? 00:00:00 clock-applet
2988 ? 00:00:00 gweather-applet
2995 ? 00:00:00 firefox
3006 ? 00:00:00 run-mozilla.sh
3014 ? 00:00:18 firefox-bin
3032 pts/0 00:00:00 ps


dbus-daemon and dbus-launch are running and neither xdm or kdm seem to be running.

adityavpratap 02-01-2007 10:37 AM

Got it!
I had not installed Multimedia and Office packages. After installing them the problem is sorted out.

zborgerd 02-05-2007 08:25 AM

Quote:

Originally Posted by adityavpratap
Got it!
I had not installed Multimedia and Office packages. After installing them the problem is sorted out.


Yeah. Unfortunately, some things build against rather unexpected libraries. If something like libgsf is missing, unexpected problems might occur. It's generally best to do a full install, as a result.


All times are GMT -5. The time now is 10:59 PM.