LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 07-28-2008, 10:25 AM   #1
devnull3d
LQ Newbie
 
Registered: Jul 2008
Posts: 2

Rep: Reputation: 0
Gnome refuses to run


I don't remember what I actually did, I just rebooted and after I logged on a popup came up saying;

Code:
Your session only lasted less than 10 seconds. If you have not logged out yourself, this could mean that there is some installation problem or that you may be out of diskspace. Try logging in with one of the failsafe sessions to see if you can fix this problem
The ~/.xsession-errors file;

Code:
/etc/gdm/PreSessionDefault: Registring your session with wtmp and utmp
/etc/gdm/PreSessionDefault: running: /usr/bin/sessreg -a -w /var/log/wtmp -u /var/run/utmp -x "/var/lib/gdm/:0.Xservers" -h "" -l ':0' 'username'
/etc/gdm/Xsession: Beginning session startup

(process:4794): Gtk-WARNING **: This process is currently running setuid or setgid
This is not a supported use for GTK+. You must create a helper program instead. For further detauls, see :

hwww[noturl]gtk[noturl]org/setuid.html

Refusing to initialize GTK+ur
Apart from that GTK error which I found out it's nothing serious and shouldn't be the issue for gnome to fail to load, there are no other errors.
I have tried removing the .ICEAuthority file in my ~ but it's pointless. Because I added a new user from console and even that user couldn't logged on, with the same error.

I have a gut feeling that this is because of CrossOver as CrossOver applications didn't run before I rebooted which is why I rebooted in the first place.

I can however logon to Gnome Failsafe but it logs on pretty slow, hanging on "Loading windows" but it does load
I also tried reconfiguring X but I believe it's not an X problem but rather Gnome.

Log outputs from /var/log/Xorg.0.log

Only warnings no errors
Code:
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(WW) `fonts.dir' not found (or not valid) in "/usr/X11R6/lib/X11/fonts/misc".
(WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
(WW) The directory "/usr/X11R6/lib/X11/fonts/cyrillic" does not exist.
(WW) The directory "/usr/X11R6/lib/X11/fonts/100dpi/" does not exist.
(WW) The directory "/usr/X11R6/lib/X11/fonts/75dpi/" does not exist.
(WW) The directory "/usr/share/fonts/X11/Type1" does not exist.
(WW) The directory "/usr/X11R6/lib/X11/fonts/Type1" does not exist.
(WW) The directory "/usr/X11R6/lib/X11/fonts/100dpi" does not exist.
(WW) The directory "/usr/X11R6/lib/X11/fonts/75dpi" does not exist.
(WW) The directory "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType" does not exist.
(WW) NVIDIA(0): No valid modes for "1200x800"; removing.
(WW) NVIDIA(0): No valid modes for "1152x768"; removing.
(WW) NVIDIA(0): Option "UseFBDev" is not used
As I see the only issues I have are some fonts, which I highly doubt are the cause of the problem.

Here are the diff's from logs I think are important of before and I after I login to Gnome

Code:
poobox:/var/log# cat messages > /root/messages_before
poobox:/var/log# cat user.log > /root/user.log_before
poobox:/var/log# cat Xorg.0.log > /root/xorg.log_before
# I logged on here
poobox:/var/log# cat messages > /root/messages_after
poobox:/var/log# cat Xorg.0.log > /root/xorg.log_after
poobox:/var/log# cat user.log > /root/user.log_after
poobox:/var/log# cd
poobox:~# diff xorg.log_after xorg.log_before
439,453d438
< (II) Open ACPI successful (/var/run/acpid.socket)
< (II) APM registered successfully
< (II) NVIDIA(0): Initialized AGP GART.
< (II) NVIDIA(0): Setting mode "1280x800"
< (II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
< (II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
< (**) NVIDIA(0): DPMS enabled
< (==) RandR enabled
< (II) Initializing extension GLX
<     xkb_keycodes             { include "xfree86+aliases(qwerty)" };
<     xkb_types                { include "complete" };
<     xkb_compatibility        { include "complete" };
<     xkb_symbols              { include "pc(pc105)+us" };
<     xkb_geometry             { include "pc(pc104)" };
< (II) Configured Mouse: ps2EnableDataReporting: succeeded
poobox:~# diff user.log_after user.log_before
poobox:~# diff messages_after messages_before
poobox:~#
Talking about /tmp I just noticed a lot of directories created with ownership root:myusername with naming scheme orbit-myusername-8_hex_chars_here All the directories are empty.
Code:
poobox:/tmp# ls -al | wc -l
1588
I can run ratbox and fluxbox with no problem but I really do need Gnome to finish a college assignment due in 2 days.

Any advice in short time manner would be greatly appreciated.

Please refrain from posting links as my bandwidth limit is exceeded, it took a lot of time to even get here and post this message.
Oh and I have plenty of diskspace.

Thank you.

Last edited by devnull3d; 07-28-2008 at 10:45 AM.
 
Old 07-29-2008, 12:07 PM   #2
b0uncer
Guru
 
Registered: Aug 2003
Distribution: CentOS, OS X
Posts: 5,131

Rep: Reputation: Disabled
It could be a Gnome configuration problem for all I know (and then again it might not be)..to test this, create a brand new user using useradd, then try to log onto Gnome as that user. If it works, the problem is in your other user's gnome settings and can be corrected by removing some or all of the Gnome-related configuration directories from within your user's home directory (list directories the names of which start with a dot, like .gnome and .gnome2). If the other user faces similar problems, it's probably not user-specific, but something system-wide..it cuts down the amount of possibilities a little if you try that. Removing the configuration directories should not harm the user in any way, unless you've done some really curious configurations; they are automatically re-created when Gnome (or whatever uses the configuration directories you delete) starts, and the specified settings are then reverted back to defaults. Actually it might be wiser to simply move or rename the directories rather than delete them, that way you'll get your configurations back in case you need to revert the changes..

To add user, as root (-m creates the home directory)
Code:
useradd -d /home/testuser -m -s bash testuser
passwd testuser
To remove the user, as root (-r removes the created home directory)
Code:
userdel -r testuser
 
Old 07-30-2008, 08:32 AM   #3
devnull3d
LQ Newbie
 
Registered: Jul 2008
Posts: 2

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by b0uncer View Post
It could be a Gnome configuration problem for all I know (and then again it might not be)..to test this, create a brand new user using useradd, then try to log onto Gnome as that user. If it works, the problem is in your other user's gnome settings and can be corrected by removing some or all of the Gnome-related configuration directories from within your user's home directory (list directories the names of which start with a dot, like .gnome and .gnome2). If the other user faces similar problems, it's probably not user-specific, but something system-wide..it cuts down the amount of possibilities a little if you try that. Removing the configuration directories should not harm the user in any way, unless you've done some really curious configurations; they are automatically re-created when Gnome (or whatever uses the configuration directories you delete) starts, and the specified settings are then reverted back to defaults. Actually it might be wiser to simply move or rename the directories rather than delete them, that way you'll get your configurations back in case you need to revert the changes..

To add user, as root (-m creates the home directory)
Code:
useradd -d /home/testuser -m -s bash testuser
passwd testuser
To remove the user, as root (-r removes the created home directory)
Code:
userdel -r testuser
Thank you but I've already tried that and I've posted that in my previous post
Quote:
I have tried removing the .ICEAuthority file in my ~ but it's pointless. Because I added a new user from console and even that user couldn't logged on, with the same error.
Thanks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Knetworkmanager-refuses to run soldier228 Linux - Software 5 06-25-2007 01:06 AM
Flash refuses to run when installed Apollofury Linux - Software 4 11-03-2006 09:15 AM
xmms [looks like] refuses to run nadroj Linux - Newbie 9 04-04-2005 11:55 PM
K3b refuses to run timelord726 Linux - Software 1 08-12-2004 04:04 PM
CVS WineX still refuses to run programs... young1024 Linux - Software 1 05-29-2004 08:49 PM


All times are GMT -5. The time now is 02:16 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration