LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
LinkBack Search this Thread
Old 11-12-2006, 11:23 AM   #1
BoredStudent
LQ Newbie
 
Registered: Oct 2006
Distribution: Red Hat 9
Posts: 8

Rep: Reputation: 0
glib


hi how do i get rid of destroy annihilate or uninstall glib 2.2.1 on a red hat 9 system or at least cripple it enough so it cant be found

please help
 
Old 11-12-2006, 07:35 PM   #2
IBall
Senior Member
 
Registered: Nov 2003
Location: Perth, Western Australia
Distribution: Ubuntu, Debian, Various using VMWare
Posts: 2,088

Rep: Reputation: 61
Why?

--Ian
 
Old 11-13-2006, 01:45 AM   #3
BoredStudent
LQ Newbie
 
Registered: Oct 2006
Distribution: Red Hat 9
Posts: 8

Original Poster
Rep: Reputation: 0
i need pkg-config to find glib 2.5.7 and up and all dependencies also upgrade gtk+ so i can install xmsn and when i try to configure atk it finds the latest version of glib it also finds my older version and all flashy lights going off saying it needs the upgraded version (ill get the error message to you later today.

Bored Student
 
Old 11-13-2006, 04:45 AM   #4
IBall
Senior Member
 
Registered: Nov 2003
Location: Perth, Western Australia
Distribution: Ubuntu, Debian, Various using VMWare
Posts: 2,088

Rep: Reputation: 61
I take it xmsn is an MSN client?

Why are you running Redhat 9 - this is very old now, and has been unsupported for about 2.5 years. Why not try upgrading to Fedora Core 6 (if you are happy with Redhat), or another distro such as Ubuntu? Both of these come with several chat clients such as Gaim, amsn and Kopete.

Most people have no reason to be running Redhat 9, and modern distros will give you a much better "experience"

--Ian
 
Old 11-13-2006, 05:56 AM   #5
BoredStudent
LQ Newbie
 
Registered: Oct 2006
Distribution: Red Hat 9
Posts: 8

Original Poster
Rep: Reputation: 0
I need it for college work since the practical session has to be done on redhat 9 so quit questioning my motives and help me
 
Old 11-13-2006, 08:11 AM   #6
weibullguy
ReliaFree Maintainer
 
Registered: Aug 2004
Location: Kalamazoo, Michigan
Distribution: Slackware-current, Cross Linux from Scratch, Gentoo
Posts: 2,676
Blog Entries: 1

Rep: Reputation: 204Reputation: 204Reputation: 204
Quote:
Originally Posted by BoredStudent
I need it for college work since the practical session has to be done on redhat 9 so quit questioning my motives and help me
Actually IBall was trying to help you. Simply explaining that you needed to use RH9 for school work would have been sufficient. The attitude and "you owe me help" mentality is neither required nor welcome. No one here owes you a helping hand; we all voluntarily offer our services.

Here are the manuals for RH9, http://www.redhat.com/docs/manuals/linux/RHL-9-Manual. The answer to your question is in one of them. Hint, use your package manager.
 
Old 11-13-2006, 11:06 AM   #7
BoredStudent
LQ Newbie
 
Registered: Oct 2006
Distribution: Red Hat 9
Posts: 8

Original Poster
Rep: Reputation: 0
im sorry that i came over demanding im just getting a bit frustrated and thanks for the help anyway i know you dont owe it me
(hope im forgiven) well heres the error message

checking for pkg-config... /usr/local/bin/pkg-config
checking for GLIB - version >= 2.5.7...
*** 'pkg-config --modversion glib-2.0' returned 2.12.0, but GLIB (2.2.1)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no
configure: error:
*** GLIB 2.5.7 or better is required. The latest version of
*** GLIB is always available from ftp://ftp.gtk.org/. If GLIB is installed
*** but not in the same location as pkg-config add the location of the file
*** glib-2.0.pc to the environment variable PKG_CONFIG_PATH.

i have tried to uninstall it with rpm but because alot of programs depend on it, it wont let me uninstall
 
Old 11-13-2006, 11:20 AM   #8
BoredStudent
LQ Newbie
 
Registered: Oct 2006
Distribution: Red Hat 9
Posts: 8

Original Poster
Rep: Reputation: 0
Any help would be appreciated
(almost forgot)
 
Old 11-13-2006, 03:02 PM   #9
BoredStudent
LQ Newbie
 
Registered: Oct 2006
Distribution: Red Hat 9
Posts: 8

Original Poster
Rep: Reputation: 0
ive managed to solve this problem and installed all the dependencies for gtk+ but now gtk+ doesnt detect them
please help!
 
Old 11-14-2006, 07:17 AM   #10
BoredStudent
LQ Newbie
 
Registered: Oct 2006
Distribution: Red Hat 9
Posts: 8

Original Poster
Rep: Reputation: 0
Theres no need for help anymore ive broken my machine and need tofix it first
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
conflicting glib versions and glib-config scius Linux - Software 5 06-03-2008 02:35 AM
xmms install (needs glib>1.22), just installed glib 2.4.8 and still get error message eskiled Linux - Software 2 12-19-2005 09:12 PM
can't install gtk 2.4.4: "Requested 'glib-2.0 >= 2.4.0' but version of GLib is 2.2.3 webazoid Linux - Software 0 07-15-2004 06:07 PM
Compiling GAIM says i need GLib 2.0, yet i have GLib 2.4 MadSkillzMan Linux - Newbie 3 07-10-2004 04:10 AM
Problems relating to glib 1.2.10 and glib 1.2.9 p3ngu!n Mandriva 10 05-23-2004 09:03 PM


All times are GMT -5. The time now is 06:52 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration