LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 04-02-2013, 02:34 AM   #1
1sweetwater!
Member
 
Registered: Nov 2011
Location: South Central Montana USA
Distribution: Debian derivitives switched to Mint from Ubuntu but play with them all time and brain permitting...
Posts: 173

Rep: Reputation: Disabled
Gigabyte BIOS clock is six 6 hours ahead of desktop clock.


BIOS clock is six 6 hours ahead of desktop clock?
I'm using a fresh new built pc and installed Mint Linux 14 Mate.
BUILD: Gigabyte A55M-DS2 ver 2.2/AMD A4-3400/8GB 2x4 Kingston pc3 1333/light-on cd\dvd/Seagate 1TB Barracuda/Antec 430w.
Upon receiving the board I reset cmos and took my time putting it together... several days. Install of Mint went without hitch but noticed BIOS time was 6 hours ahead of Desktop time. Change one and the other remains six hours different.
I think I had one boot blank/black screen event on the gigabyte build also. My memory is not the best today....
Weird thang is same thing happened with two previous Biostar motherboards on a different hardware build shown below: Biostar Ta75M ver 6./A83850/8GB 2x4 Mushkin Radioactive pc3 1333/1TB Seagate Barracuda/ASUS CD/DVD. The second RMA replacement board was just sent a week ago for second RMA should be getting third Biosatar back soon. First biostar had boot [all boot noises went as normal but sometimes monitor was black/blank and delaying boot seem to make this less of a problem] and other mouse keyboard and drive controller issues besides bios time being off by eight hours. Second Biostar had time issues as well as other stuff but drives seemed to function and no boot issues. These first two Biostars were powered by the same Mushkin Volta 500w PSU. Tried resetting BIOS and repacing CMOS battery on these Biostar units.
Hope this isn't too scrambled to understand...
 
Old 04-02-2013, 02:43 AM   #2
pan64
Senior Member
 
Registered: Mar 2012
Location: Hungary
Distribution: debian i686 (solaris)
Posts: 4,627

Rep: Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248
have you checked the timezone settings?
 
Old 04-02-2013, 04:28 AM   #3
eSelix
Senior Member
 
Registered: Oct 2009
Location: Wroclaw, Poland
Distribution: Arch, Kubuntu
Posts: 1,214

Rep: Reputation: 306Reputation: 306Reputation: 306Reputation: 306
This is normal. Time in BIOS is stored as UTC. And your system use your country local time, which is, as you see, 6 hours different. Windows systems store time in BIOS the same as on system clock, but Linux not by default (it can be configured if someone need that behavior), but storing time in UTC is the best approach.
 
Old 04-07-2013, 01:10 AM   #4
1sweetwater!
Member
 
Registered: Nov 2011
Location: South Central Montana USA
Distribution: Debian derivitives switched to Mint from Ubuntu but play with them all time and brain permitting...
Posts: 173

Original Poster
Rep: Reputation: Disabled
I don't know what to think? One reply [pan64] says It's a problem with Timezone settings, however correct TZ was set during installation and desktop time was off 6 hours. Correcting the Desktop time caused the hardware time to become off 6 hours.
TZ is MST.
Other responder [eSelix] says 6 hr difference is normal in hardware clock because of UTC. I don't remember having this problems on earlier versions of Linux. Not sure which to believe.

Computer also has a boot problem where by part of the time the boot process is invisible. bios splash appears following a brief single beep. Monitor Screen goes blank then shows this text ”Loading Operating System” with “Boot CD/DVD underneath”. There's a several more seconds of black blank screen with a desktop login chime and continued black/blank screen if login screen does not appear. Even with a blank/black screenafter login chime I may type my user name and password and get the desktop music playing as it loads but does not display.
If login screen does appear afte login chime then I am able to use the PC without having to reboot. There seems to be no set value for how many times I have to reboot to get a login screen but usually happens between one and three reboots. I'm curious why it's loading an OS before it boots to a cd or hard drive and why it sometimes requires reboots to get a visible desktop?
Could there be something wrong with motherboard or BIOS re: time and boot?
 
Old 04-07-2013, 02:02 AM   #5
pan64
Senior Member
 
Registered: Mar 2012
Location: Hungary
Distribution: debian i686 (solaris)
Posts: 4,627

Rep: Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248
probably it is a battery problem, looks like the bios settings are not stable.
 
Old 04-07-2013, 03:23 AM   #6
1sweetwater!
Member
 
Registered: Nov 2011
Location: South Central Montana USA
Distribution: Debian derivitives switched to Mint from Ubuntu but play with them all time and brain permitting...
Posts: 173

Original Poster
Rep: Reputation: Disabled
BIOS clock is six 6 hours ahead of desktop clock reply

Thanx for your efforts and please keep trying. Battery was replaced before writing this. I can change time to correct ie MST in bios and reboot to bios and time remains the same. When I boot to a desktop the bios time remains the same but desktop time is 6 hrs off hardware. If I change desktop time to reflect current then hardware clock changes by 6 hrs.
The other Sr. member said this is normal for Linux but I cannot remember Linux ever being this way. Anyway if bios time isn't as important as desktop time I could maybe live with it. However I'm still out there as to what's correct.
I thought since I was having boot issues someting might also be goofy in bios regarding the time difference?
 
Old 04-07-2013, 05:09 AM   #7
michaelk
Moderator
 
Registered: Aug 2002
Posts: 11,856

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
The BIOS clock can be either local time or UTC. If you are dual booting it should be local and if only linux can be either but must be configured correctly in the (depends on distribution) /etc/default/rcS file or your system clock will be off by the UTC offset.

I would not expect the boot problem to be causing the time issues.
 
Old 04-07-2013, 08:07 AM   #8
eSelix
Senior Member
 
Registered: Oct 2009
Location: Wroclaw, Poland
Distribution: Arch, Kubuntu
Posts: 1,214

Rep: Reputation: 306Reputation: 306Reputation: 306Reputation: 306
You must decide if you want the hardware clock show you the same time that your desktop local time, which is not recommended for some reasons (minor for common desktop users). But if it really, really bother you - you can change option in "/etc/default/rcS" file to "UTC=no". Or leave it as you have now, where hardware clock is set in UTC and your desktop time is set as UTC-6 hours, this is your current local time in Montana (Mountain Daylight Time), because motherboards usually have no timezone setting.

As michaelk wrote, if you use Windows, you need to change config, because Windows (I am not aware of newest versions) cannot be configured to store time in BIOS as UTC.

If you never encouter this it is maybe because your BIOS has not been set in UTC or you did not used Timezone setting.

Quote:
Monitor Screen goes blank then shows this text ”Loading Operating System” with “Boot CD/DVD underneath”
Change in BIOS to first trying boot from hard drive. Check SMART status for example with application "gsmartcontrol" that you have no errors on disk.

Quote:
There's a several more seconds of black blank screen with a desktop login chime and continued black/blank screen if login screen does not appear.
If you use GRUB2 then set in file "/etc/default/grub.cfg" option "GRUB_TERMINAL=console" (by default it should be just commented by # on front). After this invoke command "update-grub" and reboot to check if you still have "black screen" issue. Some graphics cards have problems with new GRUB settings. It can be fixed by some "magic", but disabling graphic mode is simplest and give you answer if it is really that reason, also you will see if your PC is not doing something lenghty during bootup.

About later time black screen it may be a problems with graphics driver. Check that you have installed newest version and you have updated operating system. Check also logs "/var/log/syslog" and "/var/log/Xorg.*.log" after starting PC. It can also be a hardware problem with monitor or cable, can you check how behave another?

Quote:
There seems to be no set value for how many times I have to reboot to get a login screen
I think you did not reboot by pressing "reset" button. You should have option to change to text console by CTRL+ALT+F1, and switch back to X (which is usually on tty7) by CTRL+ALT+F7, if not then reboot by CTRL+ALT+DEL.

Last edited by eSelix; 04-07-2013 at 08:12 AM.
 
1 members found this post helpful.
Old 04-09-2013, 01:32 PM   #9
1sweetwater!
Member
 
Registered: Nov 2011
Location: South Central Montana USA
Distribution: Debian derivitives switched to Mint from Ubuntu but play with them all time and brain permitting...
Posts: 173

Original Poster
Rep: Reputation: Disabled
Thumbs up Gigabyte BIOS clock is six 6 hours ahead of desktop clock Reply

Quote:
Originally Posted by eSelix View Post
You must decide if you want the hardware clock show you the same time that your desktop local time, which is not recommended for some reasons (minor for common desktop users). But if it really, really bother you - you can change option in "/etc/default/rcS" file to "UTC=no". Or leave it as you have now, where hardware clock is set in UTC and your desktop time is set as UTC-6 hours, this is your current local time in Montana (Mountain Daylight Time), because motherboards usually have no timezone setting.

As michaelk wrote, if you use Windows, you need to change config, because Windows (I am not aware of newest versions) cannot be configured to store time in BIOS as UTC.

If you never encouter this it is maybe because your BIOS has not been set in UTC or you did not used Timezone setting.

=..=
I finally got/saw this UTC setting thang when I stumbled on it in Linux Mint 14.1 menus. [I'm in need of menus to prompt me mentally to be able to use a computer.] So I understand that I need to change that setting in the OS to be able to enable BIOS to use local time other than default UTC.
=..=

Change in BIOS to first trying boot from hard drive. Check SMART status for example with application "gsmartcontrol" that you have no errors on disk.
=..=
I tried this already and whether cd or hd was firt boot device it all still acted the same.
=..=

If you use GRUB2 then set in file "/etc/default/grub.cfg" option "GRUB_TERMINAL=console" (by default it should be just commented by # on front). After this invoke command "update-grub" and reboot to check if you still have "black screen" issue. Some graphics cards have problems with new GRUB settings. It can be fixed by some "magic", but disabling graphic mode is simplest and give you answer if it is really that reason, also you will see if your PC is not doing something lenghty during bootup.

About later time black screen it may be a problems with graphics driver. Check that you have installed newest version and you have updated operating system. Check also logs "/var/log/syslog" and "/var/log/Xorg.*.log" after starting PC. It can also be a hardware problem with monitor or cable, can you check how behave another?

I think you did not reboot by pressing "reset" button. You should have option to change to text console by CTRL+ALT+F1, and switch back to X (which is usually on tty7) by CTRL+ALT+F7, if not then reboot by CTRL+ALT+DEL.
I've got dementia and command line is impossible to remember so I just held the shift key down after system beep and got the recovery menu and chose to update grub. And guess what no more blank/black screen boot problem. So I also left hardware clock to UTC also. It sometimes takes me a while to catch on!!!! Thanx

Last edited by 1sweetwater!; 04-09-2013 at 06:45 PM. Reason: reporting fix incorrect still getting black blank screens on boot
 
Old 04-15-2013, 01:49 AM   #10
1sweetwater!
Member
 
Registered: Nov 2011
Location: South Central Montana USA
Distribution: Debian derivitives switched to Mint from Ubuntu but play with them all time and brain permitting...
Posts: 173

Original Poster
Rep: Reputation: Disabled
Gigabyte BIOS clock is six 6 hours ahead of desktop clock and boot blank screen

solved boot to black/blank screen issue by installing FGLRX.
 
Old 04-17-2013, 10:37 PM   #11
jACK-ah
LQ Newbie
 
Registered: Feb 2013
Posts: 27

Rep: Reputation: Disabled
You pc works on feauture lol.... jokes a part bro checkthe time zone If dosent work froam there so check the battery inside cpu Its a small battery round shape change that its gona be old
 
Old 04-18-2013, 12:00 AM   #12
1sweetwater!
Member
 
Registered: Nov 2011
Location: South Central Montana USA
Distribution: Debian derivitives switched to Mint from Ubuntu but play with them all time and brain permitting...
Posts: 173

Original Poster
Rep: Reputation: Disabled
not sure what you mean?
 
Old 04-18-2013, 07:21 AM   #13
michaelk
Moderator
 
Registered: Aug 2002
Posts: 11,856

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
I believe the poster actually meant your PC works in the future. However, you have already posted the BIOS battery was replaced.

You can mark this thread as solved under the thread tools pull down menu.
 
Old 04-18-2013, 12:48 PM   #14
1sweetwater!
Member
 
Registered: Nov 2011
Location: South Central Montana USA
Distribution: Debian derivitives switched to Mint from Ubuntu but play with them all time and brain permitting...
Posts: 173

Original Poster
Rep: Reputation: Disabled
gigabyte bios clock

still don't know what that means and I can't find where to mark it solved?
 
  


Reply

Tags
bios, linux, motherboard


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Clock jumps hours ahead after boot. JZL240I-U Linux - Software 6 11-18-2010 02:01 AM
Desktop clock not synced with system clock greenphreak Debian 5 08-22-2007 01:32 PM
Yast Time clock OK, but Desktop is off by 6 hours Cherock Linux - Newbie 1 10-29-2006 11:14 AM
Linux OS Clock/Timezone shows the clock off by 6 hours between OS's JBailey742 Linux - Software 9 04-06-2006 11:40 PM
clock changes hours by it self jct842 General 2 09-04-2002 10:26 PM


All times are GMT -5. The time now is 03:57 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration