LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Desktop (http://www.linuxquestions.org/questions/linux-desktop-74/)
-   -   Gentoo, Xorg, fglrx not working as intended (http://www.linuxquestions.org/questions/linux-desktop-74/gentoo-xorg-fglrx-not-working-as-intended-720738/)

b1f30 04-21-2009 02:49 PM

Gentoo, Xorg, fglrx not working as intended
 
Ugh.. I am such a Gentoo crackboi...

Trying to get fglrx working w/Xorg on Gentoo, and I get some really funky nonsense:

Code:

blackbox ~ # X -configure

X.Org X Server 1.5.3
Release Date: 5 November 2008
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.27-gentoo-r10 i686
Current Operating System: Linux blackbox 2.6.27-gentoo-r10 #1 SMP Tue Apr 21 10:36:54 EDT 2009 i686
Build Date: 21 April 2009  09:52:43AM
 
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Tue Apr 21 11:36:01 2009
List of video drivers:
        fglrx
(WW) fglrx: No matching Device section for instance (BusID PCI:0@5:0:1) found

Backtrace:
0: X(xorg_backtrace+0x38) [0x8127c7c]
1: X(xf86CallDriverProbe+0x210) [0x80a52d0]

Fatal server error:
Caught signal 11.  Server aborting

blackbox ~ # lspci | grep ATI
05:00.0 VGA compatible controller: ATI Technologies Inc RV370 5B64 [FireGL V3100 (PCIE)] (rev 80)
05:00.1 Display controller: ATI Technologies Inc RV370 5B64 [FireGL V3100 (PCIE)] (Secondary) (rev 80)

Linux blackbox 2.6.27-gentoo-r10 #1 SMP Tue Apr 21 10:36:54 EDT 2009 i686 Intel(R) Xeon(TM) CPU 3.00GHz GenuineIntel GNU/Linux


headrift 04-23-2009 11:07 AM

Quote:

Originally Posted by b1f30 (Post 3516542)
(WW) fglrx: No matching Device section for instance (BusID PCI:0@5:0:1) found

Check your xorg.conf -- comment out the BusID line if possible. I really don't think that "@" should be in there.

arckane 04-23-2009 05:04 PM

and give us your xorg.conf, it can be manually written.


All times are GMT -5. The time now is 11:26 AM.