LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Desktop (http://www.linuxquestions.org/questions/linux-desktop-74/)
-   -   gdm cannot get to login screen (http://www.linuxquestions.org/questions/linux-desktop-74/gdm-cannot-get-to-login-screen-822950/)

scottz 07-29-2010 06:51 PM

gdm cannot get to login screen
 
Hi,

We have been happily using VNC to access our CentOS 5.4 machine for a few months now. Today, when I tried to VNC in expecting the usual login prompt, only a mouse cursor showed up. My colleague, who has already logged on earlier in the day, had no problem using VNC, until he restarted the session and got the same problem as me. I went directly to the machine, and it also worked fine until I logged out and log back in. I got the same issue of having only a black background and a mouse cursor with the pointer and the blue circle rotating continuously (it's processing something).

I can still access the console via SSH. I couldn't find anything unusual in the /var/log/messages. I looked at /var/log/Xorg.0.log but it does not show any (EE).

I have tried rebooting normally, and everything started up fine until just before the login screen. I also tried rebooting into console mode and starting X (I tried both /usr/sbin/gdm and startx; the startx gave me the CentOS background instead of full black, but still no login screen), and reinstalling gdm. I am using an NVIDIA Quadro NVS 290 card and I heard that proprietary drivers are usually a problem, so I manually downloaded and installed the latest video driver. All gave the same result (except for startx as mentioned).

Are there any other logs I should look at? Anything else I can try? Any help would be greatly appreciated! Thanks!

irishbitte 07-29-2010 07:34 PM

Shot in the dark, this thread was started today, seems quite similar to yours? http://www.linuxquestions.org/questi...isplay-822623/

scottz 07-30-2010 07:44 AM

Thanks for the pointer, irishbitte. I tried removing all desktop and gnome related files, as suggested, for the user and root accounts, but I got the same result - black screen with a mouse cursor.

I have also tried turning chkconfig vncserver off and restarted.

Any other suggestions? A few hours before the problem appeared I had to play around with xhost as perhttp://centos.org/modules/newbb/view...24162&forum=37. I also immediately disabled xhost (xhost -) after the problem was discovered, hoping that would help. Could that be relevant?

scottz 07-30-2010 01:42 PM

Some additional info of interest: in /var/log/secure, this message started repeating several times a second whenever the black screen appear to be on.

Quote:

pam_succeed_if(gdm:auth): error retrieving user name: Conversation error
After a Google search, I tried to run the command in the [server-Standard] section of /usr/share/gdm/defaults.conf (as per the GDM manual troubleshooting section) to start the Xserver, with no errors. I also tried reinstalling mctrans. Still no luck. Can anyone help?

scottz 08-02-2010 09:14 AM

I combed through the list of files modified around the time the problem started occuring, and I found some .xsession-error files in users' folder similar to this:

Quote:

/etc/gdm/PreSession/Default: Registering your session with utmp
/etc/gdm/PreSession/Default: running: /usr/bin/sessreg -a -u /var/run/utmp -x "/var/gdm/localhost.localdomain:3.Xservers" -h "localhost.localdomain" -l "localhost.localdomain:3" "dbanisor"
localuser:dbanisor being added to access control list
No profile for user 'dbanisor' found
localhost being added to access control list
SESSION_MANAGER=local/mosdevelop1:/tmp/.ICE-unix/7205
Window manager warning: Log level 32: could not find XKB extension.
Passkey agent registration failed: Passkey agent already exists
I would appreciate any ideas of things to try. Thanks!


All times are GMT -5. The time now is 01:51 PM.