LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Desktop (http://www.linuxquestions.org/questions/linux-desktop-74/)
-   -   Font problems after kernel update (http://www.linuxquestions.org/questions/linux-desktop-74/font-problems-after-kernel-update-473918/)

tron_thomas 08-14-2006 11:11 PM

Font problems after kernel update
 
I am running Fedora Core 5 on an Intel Pentium IV system with a nVidia GeForce 3 video card. I recently updated to kernel 2.6.17-1.2174_FC5, and I had to rebuild the driver for my video card. I have the latest version of the driver. When I built the driver I got some errors. I believe this was because despite that I had already install it previously through yum, the kmod-nvidia module was not on the system. I reinstalled it and then I was able to build the driver.

Now that I am running the new with the latest driver, I have noticed that all the fonts on my system look terrible. I don't know if this has anything to do with the video driver or if it is caused by some other problem.

What can I do to diagnose and fix my font problems?

uselpa 08-16-2006 02:36 PM

"Terrible" is a little bit vague... can you post a screenshot somewhere?

tron_thomas 08-17-2006 11:34 PM

This link show how text is showing up in Kate after my update:
http://home1.gte.net/res0hi6f/BadText.png

This link was taken from my work machine running Fedora Core 2 and it is pretty consistent with the way things looked on my Fedora Core 5 system here at home before the update
http://home1.gte.net/res0hi6f/GoodText.png

The background and foreground colors aren't important. I use a different color scheme on both systems.

uselpa 08-18-2006 12:54 AM

I think that would be anti-aliasing (AA) that was switched OFF in the course of the update. Do you use KDE, GNOME, Fluxbox? In KDE, you can activate anti-aliasing in the System Settings, I guess for GNOME that's also true. Hunt for "Font Settings" and make sure AA is turned on.

If that doesn't work, you can also influence it with a config file in /etc/fonts (in Slackware, yours might be elsewhere). There's a fonts.conf and a local.conf. You can change the latter. Google for the details.

BTW - I prefer what you call "bad" and I hate AA, which is why you had to be more precise what you meant by "terrible".

tron_thomas 08-18-2006 09:57 PM

Okay, I disabled anti-aliased fonts. Re-enabled it, and then restarted the system. Now the fonts look like they used to.


All times are GMT -5. The time now is 10:55 PM.