Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back > Forums > Linux Forums > Linux - Desktop
User Name
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.


  Search this Thread
Old 01-23-2009, 08:40 PM   #1
LQ Newbie
Registered: Jan 2009
Location: Hungary
Distribution: Debian Lenny, Ubuntu Karmic Koala
Posts: 9

Rep: Reputation: 0
Flash doesn't work in Opera (or Iceweasel or Epiphany or anything else)

Flash hasn't been working on my computer since July or so, and I'm not sure why. It started the day I downloaded a sign language dictionary program to use with Wine, which never worked so I think I got rid of it and just kept the flv files that were included and intelligently named. I don't see why that would cause the problem, but I'm including it for completeness.

Most websites in Opera don't load the flash at all, i just see a white box.

I've tried uninstalling flash, reinstalling flash, upgrading to flash 10, nothing.

hannah@Hannah:~$ locate libflashplayer

I'm running Debian, Lenny. Use Awesome as my window manager (which is irrelevant to this post, but it's a nice window manager)
Old 01-24-2009, 12:49 AM   #2
LQ Guru
Registered: Oct 2003
Posts: 5,066

Rep: Reputation: Disabled

firstly a fast loading test page must see blue line going up and down in word = ultrasounds

2) since you have adobe...maybe its old?
this page will test what you have...assuming you have enable flash in your browser

when I d/load the latest I use the tar.gz from here

unpack it and move old flashplayer out of your plugin folder and move the new one

with browser closed...then restart to retest pls.

2) my pathway to a downloaded mozilla firefox (~ iceweasel) is

notice there is no dot folder pathway which may be your only issue?

of course I have no multiple uses so fox is downloaded to home folder and unpacked there....yours could be


but definately no dots in home folder ok?
Old 01-24-2009, 09:17 AM   #3
LQ Newbie
Registered: Jan 2009
Location: Hungary
Distribution: Debian Lenny, Ubuntu Karmic Koala
Posts: 9

Original Poster
Rep: Reputation: 0
Awesome, I was able to fix it. Following the troubleshooting steps you gave me, I was able to find something else that was causing the problem:

The problem was caused by /usr/lib/mozilla/plugins/, which was identifying itself as Flash 4.0 compatible. I got rid of that and put in that directory as well.

I can watch Youtube again! Yay!


flash, opera

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Adobe flash player Epiphany Iceweasel Iceape Pedroski Linux - Software 11 12-08-2008 01:07 PM
Epiphany -iceweasel not strating !! Only iceape does Vassos Linux - Software 1 08-20-2008 09:38 AM
Iceweasel and Epiphany both crash when they encounter flash Rehumanize Debian 1 02-26-2008 06:42 PM
Opera - Flash doesn't work NeccoWolf Linux - Software 2 01-16-2005 10:46 AM
Flash Plug-in in Opera doesn't seem to work... ako Linux - Newbie 6 12-30-2003 02:04 PM

All times are GMT -5. The time now is 06:36 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration