LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 08-23-2010, 11:14 AM   #1
SaintDanBert
Senior Member
 
Registered: Jan 2009
Location: Austin, TX
Distribution: Mint-15 with Cinnamon & KDE
Posts: 1,350
Blog Entries: 3

Rep: Reputation: 86
firefox v3.6.8 "forgets" google search and other settings


NOTE -- "Similar Threads" did not show anything that seemed appropriate.

I use FF v3.6.8 on Ubuntu Lucid. At the Google home page, I select the "settings" item and select things like which languages to search, number of items to display, open a fresh window(tab), disable filtering, etc.
I select the SaveSettings button and all works well.

... for a while ...

At some time later, all of those settings are gone and must be reset.
I believe that I have cookies enabled and that sort of security and privacy settings enabled.

Ideas,
~~~ 0;-Dan
 
Old 08-23-2010, 02:14 PM   #2
John VV
Guru
 
Registered: Aug 2005
Posts: 12,916

Rep: Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715
you might need to change the firefox settings
look in
edit / preferences /
and click on the "privacy "tab
turn off " privacy mode "
 
1 members found this post helpful.
Old 08-24-2010, 11:08 AM   #3
SaintDanBert
Senior Member
 
Registered: Jan 2009
Location: Austin, TX
Distribution: Mint-15 with Cinnamon & KDE
Posts: 1,350
Blog Entries: 3

Original Poster
Rep: Reputation: 86
I'll try these settings and report my results.
Thanks for the tip.
~~~ 0;-Dan

==========
Follow-up
==========
I tried all sorts of variations on the Edit-->Preferences settings
without any success.

On one hand, I feel like a lone ranger. If more were having this sort of forgetful troubles, there would be more screaming. Therefore, the trouble must be unique to my configuration.

On the other hand, I cannot believe that I am the only one who has seen this. Anyone else out there?

Stumpled,
~~~ 0;-< Dan

Last edited by SaintDanBert; 08-24-2010 at 12:25 PM.
 
Old 08-24-2010, 03:51 PM   #4
John VV
Guru
 
Registered: Aug 2005
Posts: 12,916

Rep: Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715
there are firefox settings that save cookies or DELETE the history and cookies when ff is shut down
there are also settings to save to save cookies for a set time ( life time of the cookie -- 2 weeks for google, never save cookies or keep them permanently
http://www.mozilla.com/en-US/firefox.../releasenotes/
http://support.mozilla.com/en-US/kb/
 
Old 08-29-2010, 01:41 PM   #5
SaintDanBert
Senior Member
 
Registered: Jan 2009
Location: Austin, TX
Distribution: Mint-15 with Cinnamon & KDE
Posts: 1,350
Blog Entries: 3

Original Poster
Rep: Reputation: 86
FOLLOW-UP: "Firefox settings" == "set plugged in"

Folks,
I appreciate all of the replies, but anything "firefox settings" does not seem to help. I admit that there are dozens (hundreds, thousands) of setting combinations -- any of which might resolve the issues -- but I continue to have troubles with FF v3.6.* editions.

The scenario
  • visit http://www.google.com
  • There is a link for "Search Settings" http://www.google.com/preferences?hl=en
  • configure several settings:
    • messages in English
    • search English and French
    • do not filter
    • open a new window
    • display 30 items
    • no search suggestions
    • ... Save Preferences ...
    • SAVED ... OK
  • everything seems to work for a while

I don't know if it is quit Firefox or reboot or something else, but
I must reset these preferences quite often. Specifically the desire for English & French search, 30 items, and open new window.

One posting on the net someone implied that there was an OPEN BUG with Firefox, but I cannot find those details.

Other than Firefox settings, does anyone know about other processing that might affect remembering of these settings -- something that Ubuntu (various editions) or Gnome (various editions) would do for me behind the scenes?

Thanks,
~~~ 0;-Dan
 
Old 08-29-2010, 04:37 PM   #6
craigevil
Senior Member
 
Registered: Apr 2005
Location: OZ
Distribution: Debian Sid
Posts: 4,733
Blog Entries: 12

Rep: Reputation: 456Reputation: 456Reputation: 456Reputation: 456Reputation: 456
Google settings are saved in a cookie. If you remove the Google cookie you lose the settings.
You can use the OptimizeGoogle extension to keep that from happening. Or use one of the many Cookie extensions so the Google cookie is never deleted.

Last edited by craigevil; 08-29-2010 at 04:42 PM.
 
Old 08-30-2010, 01:37 AM   #7
SaintDanBert
Senior Member
 
Registered: Jan 2009
Location: Austin, TX
Distribution: Mint-15 with Cinnamon & KDE
Posts: 1,350
Blog Entries: 3

Original Poster
Rep: Reputation: 86
As far as I know, my other cookies are working just fine. Does anyone know what could step on the Google cookie and leave others alone?

Is there any utility or extension that would "notify" or similar if
something tries to change the google cookie?

~~~ 0;-Dan
 
Old 09-07-2010, 12:45 AM   #8
kindofabuzz
Member
 
Registered: Mar 2010
Location: Memphis, TN
Distribution: Linux Mint 13, Ubuntu Server 10.04
Posts: 230

Rep: Reputation: 42
http://forums.mozillazine.org is a great place for all your Firefox questions and answers.
 
Old 09-07-2010, 01:42 AM   #9
John VV
Guru
 
Registered: Aug 2005
Posts: 12,916

Rep: Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715
SaintDanBert the default firefox settings should

ff3 now uses a database file for bookmarks and things
copy it or export to a html file
rename ~/.mozilla to ~/.mozilla.off and restart firefox
re import the bookmarks and see if that fixes it.
 
1 members found this post helpful.
Old 09-15-2010, 05:35 PM   #10
SaintDanBert
Senior Member
 
Registered: Jan 2009
Location: Austin, TX
Distribution: Mint-15 with Cinnamon & KDE
Posts: 1,350
Blog Entries: 3

Original Poster
Rep: Reputation: 86
This same issue -- firefox "forgets" -- happens under FF v3.6.9 as well as v3.6.8 This same issue DOES NOT happen under Ubuntu Jaunty (v9.04). It only appears under Ubuntu Lucid (v10.04 LTS)

I placed a support request with the firefox site, but since it happens
only for Ubuntu Lucid, it seems to me that is where the problem lies ... something about the distro running underneath FireFox.

Hoping for ideas,
~~~ 0;-Dan
 
Old 09-15-2010, 06:41 PM   #11
John VV
Guru
 
Registered: Aug 2005
Posts: 12,916

Rep: Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715
is it ONLY google ?
or yahoo also
and any other sites -- like this one

the only time mine change is when i dump everything ( a new .mozilla/firefox ) folder

it dose sound like a cookie issue
 
Old 09-17-2010, 05:57 PM   #12
SaintDanBert
Senior Member
 
Registered: Jan 2009
Location: Austin, TX
Distribution: Mint-15 with Cinnamon & KDE
Posts: 1,350
Blog Entries: 3

Original Poster
Rep: Reputation: 86
Quote:
Originally Posted by John VV View Post
...
it dose sound like a cookie issue
I would agree except that the same FF edition runs fine on Jaunty.
It only fails on Lucid. If it were an issue with FF storage
of cookies, wouldn't both editions fail the same way?

I would expect that the FF code -- Javascript or native -- that implements "save cookie" would fail in both places if it was FF at
fault.

Curious-er and curious-er,
~~~ 0;-Dan
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Telling people to use "Google," to "RTFM," or "Use the search feature" Ausar General 77 03-21-2010 11:26 AM
How might I restore kmail folders/mail/settings from a "badly" saved "home"? deh6 Linux - Software 5 03-08-2008 09:25 PM
"dig mx" and "ping google" do not work when bind9 runs.. why? alexxxis Linux - Software 4 01-07-2007 03:16 AM
system "forgets" how to connect to the internet hyrral Linux - Wireless Networking 1 03-23-2006 01:44 AM
firefox with suse 10, "connection refused" with google but... jimjamjahaa Linux - Newbie 3 10-24-2005 11:40 PM


All times are GMT -5. The time now is 07:57 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration