LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 12-10-2006, 01:20 PM   #1
sirgregsalot
LQ Newbie
 
Registered: Jul 2004
Location: MN, USA
Distribution: Gentoo, baby! Yeah!
Posts: 5

Rep: Reputation: 0
Firefox not emerging because of autoconf version - how to force older version?


When I try to emerge firefox, I get this output :

*snip*

* Requested autoconf 2.1
* Using autoconf (GNU Autoconf) 2.59
* Using autoheader (GNU Autoconf) 2.59
* Running autoconf ... [ !! ]

* Failed Running autoconf !
*
* Include in your bugreport the contents of:
*
* /var/tmp/portage/mozilla-firefox-1.5.0.8/temp/autoconf-16540.out


!!! ERROR: www-client/mozilla-firefox-1.5.0.8 failed.
Call stack:
ebuild.sh, line 1546: Called dyn_unpack
ebuild.sh, line 708: Called src_unpack
mozilla-firefox-1.5.0.8.ebuild, line 115: Called eautoreconf
autotools.eclass, line 85: Called eautoconf
autotools.eclass, line 158: Called autotools_run_tool 'autoconf'
autotools.eclass, line 242: Called die

-------------

So when I cat that file in /var, it says :

***** autoconf *****

build/autoconf/altoptions.m4:156: error: m4_defn: undefined macro: _m4_divert_diversion
build/autoconf/altoptions.m4:153: MOZ_READ_MOZCONFIG is expanded from...
build/autoconf/altoptions.m4:156: the top level
autom4te: /usr/bin/m4 failed with exit status: 1

I've heard that this can mean that I have to downgrade to an older version of autoconf, and I tried this with

emerge =autoconf-2.13

but I get the same problem.

I've also set WANT_AUTOCONF=2.1, but it still insists on using 2.59 during the emerge. How do I force emerge to use the older version?

Thanks,
-Greg
 
Old 12-11-2006, 12:25 PM   #2
z3r0.0v3rrid3
LQ Newbie
 
Registered: Sep 2006
Posts: 29

Rep: Reputation: 15
Can I ask what this is doing in the LFS section?

This a really dumb question but is autoconf 2.1 even installed? it reports you have autoconf 2.59
 
Old 12-11-2006, 02:07 PM   #3
sirgregsalot
LQ Newbie
 
Registered: Jul 2004
Location: MN, USA
Distribution: Gentoo, baby! Yeah!
Posts: 5

Original Poster
Rep: Reputation: 0
It's in the LFS section because I'm using gentoo (hence the problem with emerge) which is a linux from scratch. Am I mistaken?

And yes, it is installed - I can

"ls /usr/bin/autoconf*"

and see :

/usr/bin/autoconf /usr/bin/autoconf-2.13 /usr/bin/autoconf-2.60

Grounds enough to think so?
 
Old 12-11-2006, 03:37 PM   #4
johnson_steve
Senior Member
 
Registered: Apr 2005
Location: BrewCity, USA (Milwaukee, WI)
Distribution: Xubuntu 9.10, Gentoo 2.6.27 (AMD64), Darwin 9.0.0 (arm)
Posts: 1,152

Rep: Reputation: 46
Linux from scratch is another distro it is not gentoo and they don't have portage. whats the output of:

ls -l /usr/bin/autoconf*

I'm thinking /usr/bin/autoconf could be a symlink pointing to /usr/bin/autoconf-2.60
 
Old 12-11-2006, 04:21 PM   #5
sirgregsalot
LQ Newbie
 
Registered: Jul 2004
Location: MN, USA
Distribution: Gentoo, baby! Yeah!
Posts: 5

Original Poster
Rep: Reputation: 0
Oh shoot, sorry, someone feel free to move this to wherever it should be...



So, "ls -l /usr/bin/autoconf*" give me :

lrwxrwxrwx 1 root root 25 Dec 2 12:05 autoconf -> ../lib/misc/ac-wrapper.sh
-rwxr-xr-x 1 root root 4901 Dec 10 11:08 autoconf-2.13
-rwxr-xr-x 1 root root 13604 Dec 2 12:16 autoconf-2.60


and "file /usr/lib/misc/ac-wrapper.sh" says it's a BASH file, and in the comments it says that you can set that environment variable like I did...

So, this shed any light on things?
 
Old 12-11-2006, 06:37 PM   #6
johnson_steve
Senior Member
 
Registered: Apr 2005
Location: BrewCity, USA (Milwaukee, WI)
Distribution: Xubuntu 9.10, Gentoo 2.6.27 (AMD64), Darwin 9.0.0 (arm)
Posts: 1,152

Rep: Reputation: 46
No; You're right that should work. can you 'emerge www-client/mozilla-firefox-bin'? otherwise you may want to ask over at:

http://forums.gentoo.org/

as gentoo.org won't let us have a gentoo forum here on LQ
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Firefox 2.0 executable opens older installed version timothyb89 Linux - Software 6 10-15-2006 05:26 PM
Older Version Psycho(Clan) Linux - Newbie 3 04-02-2005 11:17 AM
Autoconf version 2.13 I need 2.52 for kde development ThePenguin Programming 5 09-05-2004 08:02 PM
A question about Autoconf version 2.52... Ausar Linux - Newbie 2 08-10-2004 03:44 PM
Can I install two version of autoconf on my RH8 with cd7809 Linux - Software 1 10-09-2003 04:39 AM


All times are GMT -5. The time now is 06:27 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration