LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
LinkBack Search this Thread
Old 08-22-2010, 01:51 PM   #1
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,345

Rep: Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945
fedora 13 automatically reenabling touchpad


Howdo,

Having not messed with desktop Linux for a little while, I'm a little stuck trying to disable a touchpad on a new Thinkpad. I can use xinput to disable it for about 20 seconds, but something seems to time out and reenable it. What would be doing that? hal? Xorg? the synaptic driver? Additionally, what is the most formal way to make this persist with the lack of persitent xorg.conf files?

Any clues?

Ta.
 
Old 08-22-2010, 11:26 PM   #2
pighunter
Member
 
Registered: May 2009
Posts: 32

Rep: Reputation: 15
You can disable the Touchpad through Mouse configuration in System, assuming you're using Gnome.

Jim
 
Old 08-23-2010, 01:29 AM   #3
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,345

Original Poster
Rep: Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945
No, you can't. You can disable the touchpad while typing, but that's it. Thanks.
 
Old 08-24-2010, 07:19 AM   #4
tredegar
Guru
 
Registered: May 2003
Location: London, UK
Distribution: Ubuntu 10.04, mostly
Posts: 6,007

Rep: Reputation: 366Reputation: 366Reputation: 366Reputation: 366
Did you get this fixed?

On laptop1 the touchpad is configured with synaptics options in xorg.conf, so it moves the pointer, but doesn't tap-to-click

On laptop2 (which has an ALPS touchpad) I disabled it completely with modprobe -r psmouse. My USB mouse still works perfectly though.
 
Old 08-24-2010, 09:03 AM   #5
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,345

Original Poster
Rep: Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945
Well the point (ba dum tish!) is that now there is no xorg.conf by default, I have no idea where this would be formally set. That's half the query, but also why it seems to disable for about 20 seconds with some tools and then leap back into live, as if hal flushes out settings or something.

Still certainly after tips.
 
Old 08-24-2010, 10:56 AM   #6
tredegar
Guru
 
Registered: May 2003
Location: London, UK
Distribution: Ubuntu 10.04, mostly
Posts: 6,007

Rep: Reputation: 366Reputation: 366Reputation: 366Reputation: 366
I don't know which distro you are running on that laptop, but I can get X to generate an xorg.conf.new by stopping X and then running Xorg -configure as root.

You can then edit that file (if your touchpad is using the synaptics driver) and move it to /etc/X11/xorg.conf then restart X. Anything appearing in xorg.conf will override Xorg's defaults

If it's an ALPS touchpad, you can just remove its module.

I don't know why your xinput command is being reset. Maybe it is Xorg input hotplugging ? Scroll down to "I don't want this c--p, how do I turn it off?"

Last edited by tredegar; 08-24-2010 at 10:57 AM. Reason: bad link
 
Old 08-24-2010, 05:15 PM   #7
pighunter
Member
 
Registered: May 2009
Posts: 32

Rep: Reputation: 15
Check your Software Manager for TouchPad Toggle. If it is available then it will disable your touchpad.

Jim
 
Old 08-25-2010, 03:07 AM   #8
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,345

Original Poster
Rep: Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945
Ahh, I think I sussed it finally. So disabling the mouse on typing, which is all you can do with the fedora mouse settings tool, means that on key press the disable command is triggered by the syndaemon tool, but then after the timeout the enable command is sent to reenable the touchpad. So if that option is on AND you try and permanently disable it using other methods, then it will be reenabled regardless when that enable comes through. So by unchecking the option to disable whilst typing, it can be permanently disabled. Wonder if that's worth a bug report, as it's fscking confusing to me at least. Thanks for the pointers guys.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dis- and reenabling SATA drives on the fly jalexxi Linux - Hardware 1 10-05-2009 05:38 PM
Touchpad & fedora Zen alsory Linux - Laptop and Netbook 0 07-28-2009 12:01 AM
fedora 8 : keyboard and touchpad not working. neo8307 Linux - Newbie 1 12-26-2007 12:35 PM
Turn off touchpad automatically Lunar_Lamp Linux - Laptop and Netbook 1 06-15-2006 08:22 PM
touchpad on fedora core 2(test3) anandj Linux - Laptop and Netbook 20 06-11-2004 12:48 AM


All times are GMT -5. The time now is 08:27 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration