LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Desktop (http://www.linuxquestions.org/questions/linux-desktop-74/)
-   -   fedora 13 automatically reenabling touchpad (http://www.linuxquestions.org/questions/linux-desktop-74/fedora-13-automatically-reenabling-touchpad-827837/)

acid_kewpie 08-22-2010 01:51 PM

fedora 13 automatically reenabling touchpad
 
Howdo,

Having not messed with desktop Linux for a little while, I'm a little stuck trying to disable a touchpad on a new Thinkpad. I can use xinput to disable it for about 20 seconds, but something seems to time out and reenable it. What would be doing that? hal? Xorg? the synaptic driver? Additionally, what is the most formal way to make this persist with the lack of persitent xorg.conf files?

Any clues?

Ta.

pighunter 08-22-2010 11:26 PM

You can disable the Touchpad through Mouse configuration in System, assuming you're using Gnome.

Jim

acid_kewpie 08-23-2010 01:29 AM

No, you can't. You can disable the touchpad while typing, but that's it. Thanks.

tredegar 08-24-2010 07:19 AM

Did you get this fixed?

On laptop1 the touchpad is configured with synaptics options in xorg.conf, so it moves the pointer, but doesn't tap-to-click

On laptop2 (which has an ALPS touchpad) I disabled it completely with modprobe -r psmouse. My USB mouse still works perfectly though.

acid_kewpie 08-24-2010 09:03 AM

Well the point (ba dum tish!) is that now there is no xorg.conf by default, I have no idea where this would be formally set. That's half the query, but also why it seems to disable for about 20 seconds with some tools and then leap back into live, as if hal flushes out settings or something.

Still certainly after tips.

tredegar 08-24-2010 10:56 AM

I don't know which distro you are running on that laptop, but I can get X to generate an xorg.conf.new by stopping X and then running Xorg -configure as root.

You can then edit that file (if your touchpad is using the synaptics driver) and move it to /etc/X11/xorg.conf then restart X. Anything appearing in xorg.conf will override Xorg's defaults

If it's an ALPS touchpad, you can just remove its module.

I don't know why your xinput command is being reset. Maybe it is Xorg input hotplugging ? Scroll down to "I don't want this c--p, how do I turn it off?"

pighunter 08-24-2010 05:15 PM

Check your Software Manager for TouchPad Toggle. If it is available then it will disable your touchpad.

Jim

acid_kewpie 08-25-2010 03:07 AM

Ahh, I think I sussed it finally. So disabling the mouse on typing, which is all you can do with the fedora mouse settings tool, means that on key press the disable command is triggered by the syndaemon tool, but then after the timeout the enable command is sent to reenable the touchpad. So if that option is on AND you try and permanently disable it using other methods, then it will be reenabled regardless when that enable comes through. So by unchecking the option to disable whilst typing, it can be permanently disabled. Wonder if that's worth a bug report, as it's fscking confusing to me at least. Thanks for the pointers guys.


All times are GMT -5. The time now is 05:27 PM.