LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Desktop (http://www.linuxquestions.org/questions/linux-desktop-74/)
-   -   Evolution-EWS and Exchange 2007 (http://www.linuxquestions.org/questions/linux-desktop-74/evolution-ews-and-exchange-2007-a-881661/)

metallica1973 05-19-2011 03:23 PM

Evolution-EWS and Exchange 2007
 
I have a need to install evolution-ews to connect to my companies exchange 2007 email server and after using this how to

http://osdir.com/ml/evolution-list/2.../msg00047.html

I am not stuck on setting up PKG_CONFIG_PATH and or GNOME_PLATFORM_CFLAGS variables. Here is the errors

PHP Code:

checking for GNOME_PLATFORM... configureerrorPackage requirements (glib-2.0 >= 2.16.1
    gtk
+-2.0 >= 2.20.0
    gconf
-2.0 >= 2.0.0were not met:

No package 'gtk+-2.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable 
if you
installed software in a non
-standard prefix.

Alternativelyyou may set the environment variables GNOME_PLATFORM_CFLAGS
and GNOME_PLATFORM_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details

I have both packages and every other package on gods earth:

PHP Code:

ii  libgconf2-4                           2.28.1-0ubuntu1                                       GNOME configuration database system (shared libraries)
ii  libgconf2-dev                         2.28.1-0ubuntu1                                       GNOME configuration database system (development)
ii  libgconf2.0-cil                       2.24.1-6ubuntu1                                       CLI binding for GConf 2.24
un  libgconf2.24
-cil                      <none>                                                (no description available

and
PHP Code:

ii  libgtk-vnc-1.0-0                      0.3.10-2ubuntu2                                       A VNC viewer widget for GTK+ (runtime libraries)
ii  libgtk2-imageview-perl                0.05-1                                                Perl bindings for the GtkImageView image viewer 
ii  libgtk2
-perl                          1:1.221-4ubuntu2                                      Perl interface to the 2.x series of the Gimp Too
un  libgtk2
-perl-doc                      <none>                                                (no description available)
ii  libgtk2.0-0                           2.20.1-0ubuntu2                                       The GTKgraphical user interface library
ii  libgtk2.0
-bin                         2.20.1-0ubuntu2                                       The programs for the GTKgraphical user interfa
ii  libgtk2.0
-cil                         2.12.9-4                                              CLI binding for the GTKtoolkit 2.12
ii  libgtk2.0
-common                      2.20.1-0ubuntu2                                       Common files for the GTKgraphical user interfa
un  libgtkada2
-bin                        <none>                                                (no description available)
ii  libgtkhtml-editor-common              1:3.30.3-0ubuntu1~ppa0                                HTML rendering/editing library editor widget d
ii  libgtkhtml
-editor0                    1:3.30.3-0ubuntu1~ppa0                                HTML rendering/editing library editor widget
un  libgtkhtml3.14                        
<none>                                                (no description available)
ii  libgtkhtml3.14-19                     1:3.30.3-0ubuntu1~ppa0                                HTML rendering/editing library runtime files
un  libgtkhtml3.14
-dbg                    <none>                                                (no description available)
ii  libgtkimageview0                      1.6.1-2                                               image viewer widget for GTK+
un  libgtkmm-2.4-1                        <none>                                                (no description available)
un  libgtkmm-2.4-1c2                      <none>                                                (no description available)
ii  libgtkmm-2.4-1c2a                     1:2.20.3-0ubuntu1                                     C++ wrappers for GTK+ (shared libraries)
ii  libgtksourceview2.0-0                 2.10.4-0ubuntu1                                       shared libraries for the GTKsyntax highlightin
ii  libgtksourceview2.0
-common            2.10.4-0ubuntu1                                       common files for the GTKsyntax highlighting wi
un  libgtksourceview2.0
-dev               <none>                                                (no description available)
ii  libgtkspell0                          2.0.16-1                                              a spell-checking addon for GTKs TextView widget 

I tried:

PHP Code:

export LIBGCONF2_LIBS=/usr/lib/libgconf2-

PHP Code:

export LIBGCONF2_CFLAGS=/usr/lib/libgconf2-

Help??

metallica1973 05-19-2011 03:51 PM

It appears that I didnt have all the packages that I though were on the system. After I installed the packages I am running into compling errors referencing glib and other stuff. This is what I did

PHP Code:

sudo apt-get install evolution-data-server1.2 libedata-cal1.2-dev libedata-cal1.2-dev
libecal1.2
-dev libebackend1.2-dev libedataserverui1.2-dev libedataserver1.2-dev evolution-data-server-dev libgtk2.0-dev libedata-book1.2-dev camel libgtk2.0-dev libgconf-dev 

PHP Code:

export EVOLUTION_SHELL_CFLAGS=/usr/libEVOLUTION_SHELL_LIBS=/usr/libEVOLUTION_PLUGIN_LIBS=/usr/libEVOLUTION_PLUGIN_CFLAGS=/usr/libCAMEL_CFLAGS=/usr/libCAMEL_LIBS=/usr/libLIBEDATABOOK_LIBS=/usr/libLIBEDATABOOK_CFLAGS=/usr/libLIBBOOK_CFLAGS=/usr/libLIBBOOK_LIBS=/usr/libLIBEDATACAL_LIBS=/usr/libLIBEDATACAL_CFLAGS=/usr/libLIBECAL_CFLAGS=/usr/libLIBECAL_LIBS=/usr/libLIBEBACKEND_LIBS=/usr/libLIBEBACKEND_CFLAGS=/usr/libLIBEDATASERVERUI_CFLAGS=/usr/libLIBEDATASERVERUI_LIBS=/usr/libLIBEDATASERVER_LIBS=/usr/libLIBEDATASERVER_CFLAGS=/usr/libEVOLUTION_DATA_SERVER_LIBS=/usr/libEVOLUTION_DATA_SERVER_CFLAGS=/usr/lib

Then when running ./autogen.sh or ./configure I see these error codes referencing:

PHP Code:

Running glib-gettextize... Ignore non-fatal messages.
Copying file mkinstalldirs
Copying file po
/Makefile.in.in

Please add the files
  codeset
.m4 gettext.m4 glibc21.m4 iconv.m4 isc-posix.m4 lcmessage.m4
  progtest
.m4
from the 
/aclocal directory to your autoconf macro directory
or directly to your aclocal.m4 file.
You will also need config.guess and config.subwhich you can get from
ftp
://ftp.gnu.org/pub/gnu/config/.

checking for GLIB version >= 2.26.0... no
*** Could not run GLIB test programchecking why...
*** 
The test program failed to compile or linkSee the file config.log for the
*** exact error that occuredThis usually means GLIB is incorrectly installed

and

PHP Code:

checking for Win32... no
checking 
for supported compiler flags...  -DG_DISABLE_DEPRECATED -DPANGO_DISABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED -DGDK_PIXBUF_DISABLE_DEPRECATED -DGTK_DISABLE_DEPRECATED -DGNOME_DISABLE_DEPRECATED -DGSEAL_ENABLE -Wall -Wextra -Wno-missing-field-initializers -Wno-sign-compare -Wno-unused-parameter -Wdeclaration-after-statement -Werror-implicit-function-declaration -Wformat-nonliteral -Wformat-security -Winit-self -Wmissing-declarations -Wmissing-include-dirs -Wmissing-noreturn -Wnested-externs -Wpointer-arith -Wundef -Wwrite-strings -Werror 

?


All times are GMT -5. The time now is 11:08 AM.