LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Desktop (http://www.linuxquestions.org/questions/linux-desktop-74/)
-   -   Evolution calendar displays wrong time for appointments (http://www.linuxquestions.org/questions/linux-desktop-74/evolution-calendar-displays-wrong-time-for-appointments-4175459295/)

Jlove130 04-23-2013 11:39 AM

Evolution calendar displays wrong time for appointments
 
I'm running Fedora 18 with Evolution 3.6.4-1.
Often when I accept a meeting invite the time written in the calendar is wrong. It's off by 6-7 hours (GMT?). My time zone is set as America/Boise which is correct (Mountain Time).
For example, today I have (in Outlook) a meeting scheduled at 10:30am but in Evolution calendar it shows that the meeting is at 5:30pm (7 hours off). I have another that is at 2:00pm on Thursday but the Evolution Calendar shows 8:00pm (6 hours off).
Anybody have any ideas. I'm very frustrated as I need my calendar to remind me of events and it needs to be reliable so I can finally rid myself of the necessity of Outlook.

unSpawn 04-23-2013 02:50 PM

Maybe see the "Similar Threads" section: http://www.linuxquestions.org/questi...ss-4175446997/ ?

Jlove130 04-23-2013 05:02 PM

That post is several years old and doesn't exactly touch on my problem. I'm not moving time zones, etc. I've not had issues in the past with Evolution scheduling them incorrectly. I've tried a few times to delete the profile and setup Evolution again which didn't seem to help.
I don't feel like editing the .ics file is any kind of solution. If Outlook stores the calendar item right, so should Evolution. Something else is missing.
I do appreciate the reply though.

unSpawn 04-24-2013 01:25 AM

Quote:

Originally Posted by Jlove130 (Post 4937516)
That post is several years old and doesn't exactly touch on my problem. I'm not moving time zones, etc.

IMHO the core issue, and you'll find that too if you search the 'net, is how the ICS format(s) allow one to store TZ nfo and how that affects calendar entries.


Quote:

Originally Posted by Jlove130 (Post 4937516)
I've not had issues in the past with Evolution scheduling them incorrectly.

Then file a bug report with the Evolution developers?


Quote:

Originally Posted by Jlove130 (Post 4937516)
If Outlook stores the calendar item right, so should Evolution.

That unfortunately is not compelling reasoning as products from that particular vendor aren't known for their strict adherence to Standards...

Jlove130 04-25-2013 10:47 AM

unSpawn, I appreciate your points. Specifically the comment about how Outlook/Evolution aren't the same. I'm ashamed for having uttered (written) it. I chalk it up to being in a bad mood.
That said, I removed my profile completely again, removed Evolution packages rebooted. Then Installed Evolution again but this time I used Evolution-ews rather than Evolution-mapi.
The strange thing is it went through the wizard but the email account did not show in Evolution. I ran out of time fighting with the settings and went home.
This morning, it just worked. I opened Evolution to begin fighting again, and the the account was there and working.
Who knows why. I don't even remember the Server Settings I used. I wish I had and I would put them here but I can't seem to get the dialog box back to show what I'm using.

If I get the settings Info dialog again, I'll post it to this thread.


All times are GMT -5. The time now is 06:56 PM.