LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 05-14-2007, 02:23 AM   #1
user0815
LQ Newbie
 
Registered: May 2007
Posts: 2

Rep: Reputation: 0
etch does not poweroff - suse10.1 did


hi

i installed debian etch on an old msi motherboard (dont know the exact model right now) with a p3

it does not power down when i run /sbin/poweroff, just prints "System halted."

no extra kernel options did NOT work
acpi=force did NOT work
acpi=off apm=power_off did NOT work
acpi=off apm=on did NOT work
and adding stuff like pci=usepirqmask or noapic to the above didnt change anything either.

it DID work on Suse 10.1 out of the box!
and funnily, if i type "halt" into grub's shell, it powers down, too

btw, etch has 2.6.18, suse101 had a 2.6.16 kernel

has anyone had the same experience / knows a fix?
 
Old 05-14-2007, 04:59 AM   #2
theYinYeti
Senior Member
 
Registered: Jul 2004
Location: France
Distribution: Arch Linux
Posts: 1,897

Rep: Reputation: 61
What about "acpi=ht" or "apm=on apm=power-off" ?
Or you may want to try and add module "apm" to your /etc/modprobe.preload file; but before doing that, do the test: start the PC, su to root, execute "modprobe apm", then halt the PC, it should power off.

Yves.
 
Old 05-14-2007, 07:22 AM   #3
user0815
LQ Newbie
 
Registered: May 2007
Posts: 2

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by theYinYeti
What about "acpi=ht" or "apm=on apm=power-off" ?
Or you may want to try and add module "apm" to your /etc/modprobe.preload file; but before doing that, do the test: start the PC, su to root, execute "modprobe apm", then halt the PC, it should power off.

Yves.
thanks for your reply.

i already tried modprobing apm before poweroff, it didnt work.
i'll try your options when i have time.

btw. is it power-off or power_off?
 
Old 05-14-2007, 08:12 AM   #4
masonm
Senior Member
 
Registered: Mar 2003
Location: Following the white rabbit
Distribution: Slackware64 13.37 Android 4.0
Posts: 2,248

Rep: Reputation: 46
Have you tried issuing the command halt instead of poweroff?
 
  


Reply

Tags
acpi, apm, debian, kernel, poweroff


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
from Etch testing to Etch stable, or to Lenny Perquisitor Debian 7 04-13-2007 03:27 PM
suse10.2 50% slower than suse10.0 running Maven - The java build manager. bagpussnz Suse/Novell 0 04-11-2007 09:54 PM
update Debian testing etch RC1 to etch stable cccc Debian 11 01-08-2007 10:02 PM
SUSE10.1 did not auto poweroff? LinuxNewbie999 Linux - Newbie 2 11-14-2006 05:23 AM
how to set up pppoe in suse10... not able to acces adsl modem thru suse10 akshay_jp Suse/Novell 5 09-04-2006 10:39 PM


All times are GMT -5. The time now is 05:25 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration