LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 08-09-2006, 11:36 AM   #1
SJSpring90
LQ Newbie
 
Registered: Aug 2006
Posts: 2

Rep: Reputation: 0
Error using Make


I am trying to install ndiswrapper from source but I get an error when I type in make, it says:
Quote:
sspringer@sspringer-desktop:~$ cd Desktop
sspringer@sspringer-desktop:~/Desktop$ cd ndiswrapper-1.22
sspringer@sspringer-desktop:~/Desktop/ndiswrapper-1.22$ make
make -C driver
make[1]: Entering directory `/home/sspringer/Desktop/ndiswrapper-1.22/driver'
Can't find kernel build files in /lib/modules/2.6.15-23-386/build;
give the path to kernel build directory with
KBUILD=<path> argument to make
make[1]: *** [prereq_check] Error 1
make[1]: Leaving directory `/home/sspringer/Desktop/ndiswrapper-1.22/driver'
make: *** [all] Error 2
sspringer@sspringer-desktop:~/Desktop/ndiswrapper-1.22$
This is the first time I am doing this so i really have no clue. Thanks!
 
Old 08-09-2006, 07:08 PM   #2
shakumafu
LQ Newbie
 
Registered: Apr 2006
Distribution: ubuntu dapper
Posts: 14

Rep: Reputation: 0
you have to type the command "./configure" first

then after make is complete, you have will probably have to "make install" with root privilages

Last edited by shakumafu; 08-09-2006 at 07:09 PM.
 
Old 08-09-2006, 07:11 PM   #3
shakumafu
LQ Newbie
 
Registered: Apr 2006
Distribution: ubuntu dapper
Posts: 14

Rep: Reputation: 0
general compiling instructions

./configure
make
make install (with root priv)
 
Old 08-10-2006, 02:14 PM   #4
SJSpring90
LQ Newbie
 
Registered: Aug 2006
Posts: 2

Original Poster
Rep: Reputation: 0
I am using Ubuntu 6.06 and it doesn't come with any development packages I think so it says that ./configure is not a valid command. The program that I am trying to install is ndis wrapper so I can get the internet so using synaptics isn't an option but if anyone could please post a link to the package I need to use ./configure it would be very helpful, then I can burn it on to a disc and put it on my desktop. Thanks!
 
Old 08-10-2006, 02:27 PM   #5
psisquare
Member
 
Registered: Sep 2004
Location: Germany
Distribution: Gentoo
Posts: 164

Rep: Reputation: 31
Dunno if you need configure, but you definitely must have kernel sources installed to compile ndiswrapper. That's the Ubuntu package
Code:
linux-source-2.6.15
.

But it's probably easier to just install
Code:
ndiswrapper-modules-2.6.15-23-386
and
Code:
ndiswrapper-utils
, which spares you the hassle of compiling it yourself (especially since a standard Ubuntu installation isn't exactly well-equipped for such things).

I hope I got all the numbers right btw, the Ubuntu installation I have here is abit outdated.
 
Old 08-10-2006, 11:34 PM   #6
shakumafu
LQ Newbie
 
Registered: Apr 2006
Distribution: ubuntu dapper
Posts: 14

Rep: Reputation: 0
type in terminal

sudo apt-get install build-essential

those are the packages required to build things from source
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
make bzImage failure: make[1]: *** [init/version.o] Error 1 nmainak Linux - Kernel 2 07-16-2006 05:06 PM
Really, really Weird trouble with make (make error 2) flyeater Suse/Novell 5 06-20-2005 12:05 PM
lopster v1.2.2 make error: No rule to make target `m4/glibc21.m4' Kropotkin Fedora 0 10-31-2004 11:19 AM
make failing to make with this error. Help needed? vdemuth Linux - Software 4 06-20-2004 03:08 PM
make: cc: command not found make: *** [gzip.o]error 127 zyjk Linux - Newbie 5 02-08-2002 09:58 AM


All times are GMT -5. The time now is 12:53 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration