LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 11-21-2008, 04:04 PM   #1
TiDjY
LQ Newbie
 
Registered: Nov 2008
Posts: 3

Rep: Reputation: 0
Exclamation error: 'struct SDL_SysWMinfo' has no member named 'info'


when i compile avifile. I 've got a message

Quote:
/subtitles -Wall -Wno-unused -I../../include -O2 -mtune=i686 -march=i686 -ffast-math -fomit-frame-pointer -pipe -MT renderer.lo -MD -MP -MF .deps │
│/renderer.Tpo -c renderer.cpp -fPIC -DPIC -o .libs/renderer.o │
│-: renderer.cpp: In constructor 'avm::FullscreenRenderer::FullscreenRenderer(PlayerWidget*, Display*, int, int, bool)': │
│-: renderer.cpp:821: error: 'struct SDL_SysWMinfo' has no member named 'info' │
│-: renderer.cpp:822: error: 'struct SDL_SysWMinfo' has no member named 'info' │
│-: renderer.cpp: In member function 'virtual int avm::FullscreenRenderer:rawSubtitles(const subtitle_line_t*)': │
│-: renderer.cpp:1185: error: 'struct SDL_SysWMinfo' has no member named 'info' │
│-: renderer.cpp: In member function 'virtual int avm::FullscreenRenderer::SetPosition(int, int)': │
│-: renderer.cpp:1387: error: 'struct SDL_SysWMinfo' has no member named 'info' │
│-: renderer.cpp: In member function 'virtual int avm::FullscreenRenderer::SetFont(const char*)': │
│-: renderer.cpp:1418: error: 'struct SDL_SysWMinfo' has no member named 'info' │
│-: renderer.cpp: In member function 'virtual int avm::FullscreenRenderer::Lock() const': │
│-: renderer.cpp:1593: error: 'const struct SDL_SysWMinfo' has no member named 'info' │
│-: renderer.cpp: In member function 'virtual int avm::FullscreenRenderer::TryLock() const': │
│-: renderer.cpp:1602: error: 'const struct SDL_SysWMinfo' has no member named 'info' │
│-: renderer.cpp: In member function 'virtual int avm::FullscreenRenderer::Unlock() const': │
│-: renderer.cpp:1609: error: 'const struct SDL_SysWMinfo' has no member named 'info' │
│-: renderer.cpp: In member function 'virtual void avm::FullscreenRenderer::doGetPosition(int&, int&) const': │
│-: renderer.cpp:1864: error: 'const struct SDL_SysWMinfo' has no member named 'info' │
│-: renderer.cpp:1868: error: 'const struct SDL_SysWMinfo' has no member named 'info' │
│-: renderer.cpp:1869: error: 'const struct SDL_SysWMinfo' has no member named 'info' │
│-: renderer.cpp: In member function 'virtual int avm::YUVRenderer::Sync()': │
│-: renderer.cpp:2555: error: 'struct SDL_SysWMinfo' has no member named 'info' │
│-: make[2]: *** [renderer.lo] Error 1 │
│-: make[2]: Leaving directory `/var/alfs/build/avifile-0.7-0.7.45/lib/video' │
│-: make[1]: *** [all-recursive] Error 1 │
│-: make[1]: Leaving directory `/var/alfs/build/avifile-0.7-0.7.45/lib' │
│-: make: *** [all-recursive] Error 1
Have you got a solution for my problem.

thank you

ps : Sorry for my english, i'm french
 
Old 11-22-2008, 01:58 AM   #2
rylan76
Senior Member
 
Registered: Apr 2004
Location: Potchefstroom, South Africa
Distribution: Fedora 17 - 3.3.4-5.fc17.x86_64
Posts: 1,475

Rep: Reputation: 87
Seems you have an SDL version mismatch? AVIFile is looking for a member of a struct that your SDL version apparently does not have in its header files. Is there a recommendation for which SDL version to use with your version of AVIFile, or the reverse?

What usually works is to download the most recent SDL version - sounds like you have an older SDL??
 
Old 11-22-2008, 04:12 AM   #3
TiDjY
LQ Newbie
 
Registered: Nov 2008
Posts: 3

Original Poster
Rep: Reputation: 0
my version of SDL is 1.2.11

I am going to try with a more recent version

thank you
 
Old 11-23-2008, 05:51 AM   #4
TiDjY
LQ Newbie
 
Registered: Nov 2008
Posts: 3

Original Poster
Rep: Reputation: 0
The updating in version 1.2.13 changed nothing
 
Old 11-24-2008, 06:00 AM   #5
rylan76
Senior Member
 
Registered: Apr 2004
Location: Potchefstroom, South Africa
Distribution: Fedora 17 - 3.3.4-5.fc17.x86_64
Posts: 1,475

Rep: Reputation: 87
Hmm...

I've had these too. Sometimes you need a very specific version of one package to be able to compile a dependant package. Have you tried the SDL forums themselves?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
GCC compile problem:struct A have a member variable which is just a struct type name? leon.zcom Programming 3 04-18-2008 04:40 PM
error: ‘struct tcphdr’ has no member named ‘th_flags’ nasim751 Linux - Software 0 04-17-2008 05:55 AM
error: ‘struct inode’ has no member named ‘u’ PankajDS Linux - Kernel 0 02-25-2008 11:34 PM
access struct member error true_atlantis Programming 4 04-25-2006 05:00 PM
g++ and wrong struct member addresses / struct size misreporting sonajiso Linux - General 5 05-22-2004 10:16 PM


All times are GMT -5. The time now is 02:05 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration