LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Desktop (http://www.linuxquestions.org/questions/linux-desktop-74/)
-   -   Emacs Meta key conflict with LXTerminal (http://www.linuxquestions.org/questions/linux-desktop-74/emacs-meta-key-conflict-with-lxterminal-898550/)

shva 08-20-2011 09:13 PM

Emacs Meta key conflict with LXTerminal
 
Hi everyone,

When I was using Emacs in LXTerminal, I always had such a problem. The "Alt + some_key" combination could open up a LXTerminal menu. For example "Alt + F" would open up the "File" menu of LXTerminal, instead of being a "Meta +F" command in Emacs. In GNOME Terminal, I was able to disable "Alt" being a shortcut key to terminal menu, but I could not do the same thing to LXTerminal. Could please anyone help? Thanks.

Shva

psbagumba 08-21-2011 01:37 PM

In Edit -> Preferences under the Display tab, there is a checkbox for "Hide menu bar".
If you check it, your menu bar, and all of its keyboard shortcuts will go away.

If you want to change it back, you can to to home /.config/lxterminal/lxterminal.conf and reset the

hidemenubar=true

back to


hidemenubar=false

shva 08-21-2011 04:47 PM

Quote:

Originally Posted by psbagumba (Post 4449476)
In Edit -> Preferences under the Display tab, there is a checkbox for "Hide menu bar".
If you check it, your menu bar, and all of its keyboard shortcuts will go away.

If you want to change it back, you can to to home /.config/lxterminal/lxterminal.conf and reset the

hidemenubar=true

back to


hidemenubar=false


Thanks. It worked!.


All times are GMT -5. The time now is 05:23 AM.